Setup for multiple Cloud vendors

35 views
Skip to first unread message

Wojtek Kubiak

unread,
Sep 29, 2021, 7:25:39 AM9/29/21
to Cloud Carbon Footprint
Hello
We are trying to setup this tool for AWS and Azure accounts.
Configuration for AWS account was prepared with "guided-install" and worked fine.
We tried to add Azure and updated ./packages/api/.env file with Azure data
Nothing changed (after restart the server) so we decided to perform "guided-install" for Azure. Both  ./packages/api/.env and  ./packages/cli/.env files were updated correctly and contains only Azure credentials but we still can see only AWS analytic data on client side.
Is this data somewhere cached?
BR
/Wojtek

Arelys Alvarez

unread,
Sep 29, 2021, 12:06:19 PM9/29/21
to Cloud Carbon Footprint
Hi Wojtek,

Thank you for using our app!

Here are a couple of ideas for you to try: delete the 'estimates.cache.json' file in packages/api directory and run the app again and also make sure you have the 'AZURE_USE_BILLING_DATA' environment variable set to true in your .env file in packages/api directory. Also make sure you do not set 'AZURE_AUTH_MODE' environment variable. 

Please let us know if this works.

Best, 
Arelys

Wojtek Kubiak

unread,
Sep 29, 2021, 3:11:52 PM9/29/21
to Arelys Alvarez, Cloud Carbon Footprint
Hi Arley

It worked. Thanks

W.

--
You received this message because you are subscribed to a topic in the Google Groups "Cloud Carbon Footprint" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/cloud-carbon-footprint/OEd6YhcZbF4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to cloud-carbon-foot...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cloud-carbon-footprint/ad9d0769-d0d2-41bc-80a7-af774ca2589fn%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages