ERR_OSSL_EVP_UNSUPPORTED

26 views
Skip to first unread message

Nicolas Tyndal

unread,
Nov 22, 2021, 4:26:36 AM11/22/21
to Cloud Carbon Footprint
Hello , 
We have just finished the installation of Cloud Carbon Footprint using your doc "get started" but once we run the following command line : yarn start 
We get the following error :cdc848ca-8546-4dfc-b8c3-85dbe13da23d.jpg
We also tried to do another command line (in order to get some azure consumption metrics)  : yarn start-cli -i  
and we get the following error: 2a5abb72-dc98-4bcf-919f-0f3dac7b5ed5.jpg

Cloud Carbon Footprint

unread,
Nov 23, 2021, 12:53:44 PM11/23/21
to Cloud Carbon Footprint
Hello,

Thanks for reaching out. I don't believe we've seen this issue before. I referenced the following stack overflow source:
https://stackoverflow.com/questions/69692842/error-message-error0308010cdigital-envelope-routinesunsupported
Could you please try setting this env variable from the terminal and re-running the server?: export NODE_OPTIONS=--openssl-legacy-provider

Please let me know if that helps. Otherwise, it may be a good idea to set up a time to pair together on this one and debug! If you would like to do that, could you please send over some availability you have for next week?

Thanks,
Cam

Alban Boitier

unread,
Nov 30, 2021, 5:56:18 AM11/30/21
to Cloud Carbon Footprint
You can add the following piece of code to "node_modules/react-scripts/config/webpack.config.js"

const crypto = require("crypto");
const crypto_orig_createHash = crypto.createHash;
crypto.createHash = algorithm => crypto_orig_createHash(algorithm == "md4" ? "sha256" : algorithm);

This worked for me.
Reply all
Reply to author
Forward
0 new messages