Reserved property names - newbie

15 views
Skip to first unread message

jerome moliere

unread,
May 1, 2015, 5:37:31 AM5/1/15
to clojure-...@googlegroups.com
Hi all,
I am quite new with Clojure & Titanium ( I am a very long time Java developer since 1996).
I wish to prepare my infrastructure with some development code using Titanium and for dev purpose a Java Berkeley Db back-end.
I followed the getting started guide and everything works till playing with indexes.
I 've seen that Titanium uses a quite old Titan version and in this version exception messages were not very helpful.
My code (very simple at least , simplistic in reality) raises some IllegalArgumentException when calling defkey to define some types to be indexed.
I really don't understand why ? I suspect some property names to be already used , right?
Is there a list of such names ?
I've tried to add an id property name , but it may be already used...
I think the documentation page related to index is a little bit rude , could you try to improve it..It may be useful for newcomers...

Thanks for your work
Kind regards

jerome moliere

unread,
May 1, 2015, 5:41:03 AM5/1/15
to clojure-...@googlegroups.com
I just want to add that I ran & read the tests (very useful!!!).
In the tests code the defkey is not used directly (at least in the files found) but you use the addProperty method instead..
Is it a problem related to obsolete samples ? Is it a good thing to use the addProperty rather than the defkey macro?

Kind regards

jerome moliere

unread,
May 1, 2015, 10:28:11 AM5/1/15
to clojure-...@googlegroups.com
Sorry for any inconveniance.It seems that my application was already started so my index was already created...
Everything works well now...
I guess you 'll have some news soon...
Reply all
Reply to author
Forward
0 new messages