Clojure Newbie - ClassLoader Versioning issue

52 views
Skip to first unread message

Jasdeep Jaitla

unread,
Aug 25, 2012, 1:48:46 PM8/25/12
to clojure-...@googlegroups.com
I am new to Clojure/Lein, etc. and I cloned a project and ran into an issue I don't recognize or can't find a solution for, wondering if you had any advice (maybe I am doing something wrong) Much Appreciated!

$ cat project.clj
(defproject reddalyzr "0.1.0-SNAPSHOT"
:description "reddit stuff for clojure"
:url "http://github.com/apage43/reddalyzr"
:license {:name "WTFPL"
:url "http://sam.zoy.org/wtfpl/"}
:dependencies [[org.clojure/clojure "1.4.0"]
[clojurewerkz/spyglass "1.0.0"]
[clj-http "0.5.3"]])

$ lein repl
user=> (require 'loader '[clojurewerkz.spyglass.client :as cli])

UnsupportedClassVersionError clojurewerkz/spyglass/OperationFuture : Unsupported major.minor version 51.0 java.lang.ClassLoader.defineClass1 (ClassLoader.java:-2)

Michael Klishin

unread,
Aug 25, 2012, 2:13:02 PM8/25/12
to clojure-...@googlegroups.com
2012/8/25 Jasdeep Jaitla <jas...@jasdeep.com>

Spyglass 1.0.0 was unintentionally compiled for JDK 7. 1.0.1 targets JDK 6 and is already up on clojars.
--
MK

Jasdeep Jaitla

unread,
Aug 25, 2012, 9:28:41 PM8/25/12
to clojure-...@googlegroups.com
No worries! Thanks for the quick fix, got the project I was trying working good. Thanks for jumping into adding more Couchbase support. Clojure is gaining popularity amongst our dev's so this is great.
Reply all
Reply to author
Forward
0 new messages