Issue when creating new database during migration.

47 views
Skip to first unread message

Henri Watson

unread,
May 10, 2016, 10:12:44 PM5/10/16
to chucknorris
Having a fairly weird issue with RoundhousE.

Sometimes for databases that have never existed, RoundhousE will fail to create the database as it is unable to login to the yet to be created database.

Creating sampleDB database on [IP address] server with custom script.
RoundhousE encountered an error.
System.Data.SqlClient.SqlException: Cannot open database "sampleDB" requested by the login. The login failed.
Login failed for user 'roundhouse'.

Roundhouse is being run with the following arguments:
-cs `"data source=[IP address];initial catalog=sampleDB;persist security info=True;user id=roundhouse;password=password`" --silent --ct 900 -cds CreateDatabase.sql

This is an intermediate issue which presents itself seemingly randomly. When the issue is happening, databases that have previously existed on the server work fine even if they have been completely deleted. Only databases with new names fail in the above manner.

Since I'm not sure what causes this issue, I recognise it's difficult/impossible to reproduce. However, I figure it's worth asking if anyone has run into anything similar.

Cheers,
Henri Watson.

Any e-mail sent from Alternative Payments Ltd or its Group companies may contain information which is confidential and/or privileged. Unless you are the intended recipient you may not disclose, copy or use it; please notify the sender immediately and delete it and any copies. You should protect your system from viruses etc.; we accept no responsibility for damage that may be caused by them.

Matthew MacFarland

unread,
Oct 7, 2016, 2:35:58 PM10/7/16
to chucknorris, henri....@judopayments.com
We also have random failure to connect issues and have to run our deployment scripts again to resolve it.
Reply all
Reply to author
Forward
0 new messages