Having trouble building locally

399 views
Skip to first unread message

Raif Harik

unread,
Jun 27, 2014, 4:52:57 PM6/27/14
to chucknorri...@googlegroups.com
Hi, I have forked roundhouse and am trying to build it locally.  I have made a few changes and I want to see if they work so I want to build and get my RH.exe file and execute it.  However, when I run the build.bat it says 
      c:\Dev\sandbox\roundhouse\build\compile.step(195,14):
            Failed to start MSBuild.
                c:\Dev\sandbox\roundhouse\build\compile.step(195,14):
                External Program Failed: C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe (return code
 was 1)

not sure if exactly where to look.  The build process seems rather complex.
any help would be appreciated.
R

Rob Reynolds

unread,
Jun 30, 2014, 9:03:56 AM6/30/14
to chucknorri...@googlegroups.com
Do you have the .net framework version 4/4.5 installed?


--
You received this message because you are subscribed to the Google Groups "chucknorris" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframe...@googlegroups.com.
To post to this group, send email to chucknorri...@googlegroups.com.
Visit this group at http://groups.google.com/group/chucknorrisframework.
For more options, visit https://groups.google.com/d/optout.



--

Zak

unread,
Jun 30, 2014, 9:20:24 AM6/30/14
to chucknorri...@googlegroups.com
Hi all
@ Raif – what version of VS do you have ? Is the MsBUild in the correct path ? 

Thanks

Zakir Hoosen        

+44(0)1624 618950 

+44(0)7624 482071 (mobile)

www.FuzzelogicSolutions.comSuite 4, Well Road House, Market Street, Douglas, Isle of Man, IM1 2PQ
                                                        Create beautifulrevolutionary software that everyone wants to use.

Raif Harik

unread,
Jun 30, 2014, 10:07:23 AM6/30/14
to chucknorri...@googlegroups.com
Well, I'm on 2012, and I believe it is in the correct path.  I use grunt for my builds and I don't specify a location so I'm guessing it's just looking in C:\Windows\Microsoft.NET\Framework64\v4.0.30319.  
If roundhouse is looking somewhere specific, I'd be happy to put a copy there or if it takes a param I can point it in the right direction, I just don't see where it's look.
Thanks,
R
To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframework+unsub...@googlegroups.com.

To post to this group, send email to chucknorri...@googlegroups.com.
Visit this group at http://groups.google.com/group/chucknorrisframework.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "chucknorris" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframework+unsub...@googlegroups.com.

Raif Harik

unread,
Jun 30, 2014, 10:16:48 AM6/30/14
to chucknorri...@googlegroups.com
sorry @Rob, I didn't see your post when I responded to @zakir.  But yes I am on 4.5
Thanks,
R

Rob Reynolds

unread,
Jun 30, 2014, 2:59:44 PM6/30/14
to chucknorri...@googlegroups.com
No worries. Nant goes to look in the registry to find the path to the framework IIRC. Nant is the underlying framework that uppercut is built on top of. Not really sure why it would be failing on your box. What version of windows are you building from?


--
You received this message because you are subscribed to the Google Groups "chucknorris" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframe...@googlegroups.com.

To post to this group, send email to chucknorri...@googlegroups.com.
Visit this group at http://groups.google.com/group/chucknorrisframework.
For more options, visit https://groups.google.com/d/optout.

Raif Harik

unread,
Jun 30, 2014, 3:02:46 PM6/30/14
to chucknorri...@googlegroups.com
I'm using my work dev machine.  all is pretty currant.  I'm on win7 ( I don't concider win8 more current as it is huge ux step back. anyway...) I'm not running nant on my machine but I presume it's included in the nuget or something.  I should be able to run the build.bat and have it work out of the box, right?
thanks,
R


On Monday, June 30, 2014 1:59:44 PM UTC-5, ferven...@gmail.com wrote:
No worries. Nant goes to look in the registry to find the path to the framework IIRC. Nant is the underlying framework that uppercut is built on top of. Not really sure why it would be failing on your box. What version of windows are you building from?
On Mon, Jun 30, 2014 at 9:16 AM, Raif Harik <reh...@gmail.com> wrote:
sorry @Rob, I didn't see your post when I responded to @zakir.  But yes I am on 4.5
Thanks,
R


On Friday, June 27, 2014 3:52:57 PM UTC-5, Raif Harik wrote:
Hi, I have forked roundhouse and am trying to build it locally.  I have made a few changes and I want to see if they work so I want to build and get my RH.exe file and execute it.  However, when I run the build.bat it says 
      c:\Dev\sandbox\roundhouse\build\compile.step(195,14):
            Failed to start MSBuild.
                c:\Dev\sandbox\roundhouse\build\compile.step(195,14):
                External Program Failed: C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe (return code
 was 1)

not sure if exactly where to look.  The build process seems rather complex.
any help would be appreciated.
R

--
You received this message because you are subscribed to the Google Groups "chucknorris" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframework+unsub...@googlegroups.com.

To post to this group, send email to chucknorri...@googlegroups.com.
Visit this group at http://groups.google.com/group/chucknorrisframework.
For more options, visit https://groups.google.com/d/optout.

Rob Reynolds

unread,
Jun 30, 2014, 3:15:15 PM6/30/14
to chucknorri...@googlegroups.com
Things that can prevent the build from happening correctly are usually related to permissions and source on UNC shares. If you have either of those we can get into more details about why, but let's start with the actuals.

In build_output folder there is a build.log file that is created containing quite a few more details. But also in build_output/build_artifacts/compile there is some detailed information about what is failing.

Another thing you can try is to open the solution (after building or genning the SolutionVersion.cs file) and try building in there. If it doesn't build, then find what is going wrong there first. 


To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframe...@googlegroups.com.

To post to this group, send email to chucknorri...@googlegroups.com.
Visit this group at http://groups.google.com/group/chucknorrisframework.
For more options, visit https://groups.google.com/d/optout.

Raif Harik

unread,
Jun 30, 2014, 5:30:46 PM6/30/14
to chucknorri...@googlegroups.com
Hi, ok so I don't know what the ... heck I was doing before to get that msbuild is missing error.  I just ran build.bat again, and guess what??? a new and improved error.
Now it's saying 

 Could not load file or assembly 'roundhouse, Version=0.8.6.0, Culture=neutral, PublicKeyToken=91b86fd44f1f23bc' or one of its dependencies. Strong name validation failed. (Exception from HRESULT: 0x8013141A)

strong name validation failed.  I guess cuz I modified the project.  I don't know anything about strong naming projects.  There is supposed be a key or something right?  
If you can help me to get past the strong naming issue that would be great.
Or alternatively, I could just wait for a day and this problem will disappear just like the last one.  No don't do that.  I'm just feeling jaded.
R



To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframework+unsubscrib...@googlegroups.com.
To post to this group, send email to chucknorri...@googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "chucknorris" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chucknorrisframework+unsub...@googlegroups.com.
To post to this group, send email to chucknorri...@googlegroups.com.
Visit this group at http://groups.google.com/group/chucknorrisframework.
For more options, visit https://groups.google.com/d/optout.

Raif Harik

unread,
Jul 1, 2014, 4:36:03 PM7/1/14
to chucknorri...@googlegroups.com
Ok, so I think that the first issue, the no msbuild error was based on the fact that the build failed in visual studio.  I truly would like to thank microsoft for that very helpful error message.
Second error was with the strongly named dlls.  I cowardly took the easy route and removed strong names.  Now it builds as one would expect.
Thanks for the help.
R

 

On Friday, June 27, 2014 3:52:57 PM UTC-5, Raif Harik wrote:
Reply all
Reply to author
Forward
0 new messages