basic Mac OSX set up

65 views
Skip to first unread message

duckeyejey

unread,
Feb 3, 2012, 12:33:05 PM2/3/12
to Chronomotion Development & Technical Support
Hey thanks for setting up this group.

are you able to outline the basic set required to run the java app in
Mac OSX.

thanks

Sebastian Pichelhofer

unread,
Feb 3, 2012, 12:43:12 PM2/3/12
to chronomo...@googlegroups.com
http://code.google.com/p/chronomotion/wiki/Usage_Instructions

Did you successfully download and install the RXTX library?

Then just run the *.sh file from a terminal screen.

If you get any errors reported in terminal please post them here.

Regards Sebastian

Jay Shaffer

unread,
Jan 16, 2014, 5:03:45 PM1/16/14
to chronomo...@googlegroups.com
Hi Sebastian
First off, thanks so much for developing Chronomotion. It is exactly the software I need to control my time-lapse rig. I am trying to control a Celestron LCM series head, which uses the same control commands as the Merlin. I am running OSX version 10.7.5. I have downloaded Chronomotion V0.3 Mac and rxtx V2.1-7r2 that includes the rxtx jar file and native lib files. the rxtx read me says to place the rxtx files in the system library Java extensions directory. I have the Usb-serial cable and driver successfully installed and I have been able to send and receive commands from the telescope head using the Mac terminal screen app.

When attempting to launch Chronomotion via the terminal I get the Following errors: 

Jay-Shaffer-MacBook-Pro:Chronomotion-Mac-V0.3 administrator$ java -jar -Xmx256m Chronomotion-dist0.3.jar
java.lang.UnsatisfiedLinkError: /Library/Java/Extensions/librxtxSerial.jnilib:  no suitable image found.  Did find:  /Library/Java/Extensions/librxtxSerial.jnilib: no matching architecture in universal wrapper thrown while loading gnu.io.RXTXCommDriver
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: /Library/Java/Extensions/librxtxSerial.jnilib:  no suitable image found.  Did find:  /Library/Java/Extensions/librxtxSerial.jnilib: no matching architecture in universal wrapper


I get the same error whether the rxtx lib is in the same directory as Chronomotion or if it is in the Java extensions directory. Any help or hints would be vastly appreciated.
Thanks.

Best,
Jay

Sebastian Pichelhofer

unread,
Jan 17, 2014, 5:06:03 AM1/17/14
to clev...@gmail.com, chronomo...@googlegroups.com
Hi Jay

It seems like it could be a 32bit vs64bit issue where the Java VM is 64bit but the RXTX library is only available in 32bit and therefore "no matching architecture" could be found.
Unfortunately I never tried to run Chronomotion on a Mac so I can only give some estimated guesses what the problem is or how it could be solved :)
So you can try to either install Java as 32bit Virtual Machine or find a RXTX library in 64bit (http://rxtx.qbang.org/wiki/index.php/Download), I know there are some custom builds for windows but I dont know about Mac....

For windows I started packaging chronomotion together with the Java VM and matching DLLs which basically makes it work out of the box, for Mac I am looking for someone who can prepare such a package.

Regards Sebastian


--
You received this message because you are subscribed to the Google Groups "Chronomotion Development & Technical Support" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chronomotion-t...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply all
Reply to author
Forward
0 new messages