Not able to use peek, poke, step and expect for testing a simple hardware description

12 views
Skip to first unread message

Pinaki Chakrabarti

unread,
Jul 25, 2022, 4:25:50 AMJul 25
to chisel-users
Hello,

Recently I downloaded Chisel-3 from Github . I saw the examples and ran with the provided Makefile. It is able to create a .v file along with .fir, .cpp and a .json file. But when I tried experimenting with my own hardware description and tried using peek, poke, step and expect, as suggested in many chisel related documents/tutorials, I could not use those. It was saying undefined or not available. I also wrote a tester class extending from PeekPokeTester but did not help.

What is needed to do so that I can see all the generated files for my test case ?

Also, is there any way I can see the .fir (IR) dumping in different phases ?

Please help.

Thanks,
Pinaki Chakrabarti

lae...@berkeley.edu

unread,
Jul 29, 2022, 7:35:33 PMJul 29
to chisel-users

Hi Pinaki,

I would recommend you start with the chisel template which can be found here: https://github.com/freechipsproject/chisel-template


You can launch the test either with `sbt test` or when you use an IDE like IntelliJ it will show a green arrow next to the test that you can click to launch it.

Hope this helps.

- Kevin
Reply all
Reply to author
Forward
0 new messages