[typetools/checker-framework] 5096c3: Rename `CFAbstractValue.validateSet()` to `hasAnno...

0 views
Skip to first unread message

Michael Ernst

unread,
Jul 24, 2026, 12:39:37 PM (2 days ago) Jul 24
to checker-fr...@googlegroups.com
Branch: refs/heads/master
Home: https://github.com/typetools/checker-framework
Commit: 5096c3a5996cd7ec8438aa6b01cbd3e672dbdbfb
https://github.com/typetools/checker-framework/commit/5096c3a5996cd7ec8438aa6b01cbd3e672dbdbfb
Author: Michael Ernst <mer...@cs.washington.edu>
Date: 2026-07-24 (Fri, 24 Jul 2026)

Changed paths:
M checker/src/main/java/org/checkerframework/checker/nullness/KeyForAnalysis.java
M checker/src/main/java/org/checkerframework/checker/nullness/NullnessAnalysis.java
M docs/CHANGELOG.md
M framework/src/main/java/org/checkerframework/common/accumulation/AccumulationAnalysis.java
M framework/src/main/java/org/checkerframework/common/accumulation/AccumulationValue.java
M framework/src/main/java/org/checkerframework/framework/flow/CFAbstractAnalysis.java
M framework/src/main/java/org/checkerframework/framework/flow/CFAbstractValue.java

Log Message:
-----------
Rename `CFAbstractValue.validateSet()` to `hasAnnotationFromEveryHierarchy()`



To unsubscribe from these emails, change your notification settings at https://github.com/typetools/checker-framework/settings/notifications
Reply all
Reply to author
Forward
0 new messages