Line Numbers Missing w/Aptana&CF

27 views
Skip to first unread message

spra...@gmail.com

unread,
Oct 31, 2007, 12:34:43 PM10/31/07
to CFEclipse Users
I'm not sure if this is an Aptana or CFECLIPSE problem. I'm running
the latest Aptana (1.0) and CFECLIPSE. If I open a cfm file from the
Project view, everything loads up fine. If I open a cfm file from
File view, which includes all my FTP sites, none of the line numbers
show and my outline view doesn't populate. In fact, the gutter where
expandable tags and line numbers are does not even show. I have the
cfm extension mapped to the CFML Editor, and it opens in that. All my
tag validation, etc, works, but I have no gutter and I cannot use
outline view.

Does this make any sense? Why can't I get line numbers, etc, when I
open the file from the File view? I need to use file view because
that is where my FTP sites are, and that is where my project shortcuts
are.

PS - I have verified that "Show line numbers" is checked for CFECLIPSE
preferences and Editors preferences.

Priest, James (NIH/NIEHS) [C]

unread,
Oct 31, 2007, 1:01:55 PM10/31/07
to cfeclip...@googlegroups.com
> -----Original Message-----
> From: spra...@gmail.com [mailto:spra...@gmail.com]
> Sent: Wednesday, October 31, 2007 12:35 PM
> To: CFEclipse Users
> Subject: Line Numbers Missing w/Aptana&CF
>
>
> I'm not sure if this is an Aptana or CFECLIPSE problem. I'm running
> the latest Aptana (1.0) and CFECLIPSE. If I open a cfm file from the


What is your setup?

Aptana w/CFEclipse plugin?
Eclipse w/Aptana & CFEclipse plugin?

Was it working with a previous version of Aptana or is this a fresh
install?

Jim

Mike Henke

unread,
Nov 1, 2007, 10:17:06 AM11/1/07
to CFEclipse Users
There are two line number setting one for eclipse and another for
cfeclipse that will need set. Read this link.
http://groups.google.com/group/cfeclipse-users/browse_thread/thread/87620d9911964ce/f52a6d01a4f76721?lnk=gst&q=line#f52a6d01a4f76721

See if that solves your problem for line numbers as for outline, I am
not sure.

spra...@gmail.com

unread,
Nov 6, 2007, 10:37:15 PM11/6/07
to CFEclipse Users
I now have a case open with Aptana for this. I posted the problem on
their boards and they verified it and told me to open a case.

http://support.aptana.com/issues/browse/STU-72

On Nov 1, 9:17 am, Mike Henke <henkem...@gmail.com> wrote:
> There are two line number setting one for eclipse and another for

> cfeclipse that will need set. Read this link.http://groups.google.com/group/cfeclipse-users/browse_thread/thread/8...

Tom Lenz

unread,
Nov 7, 2007, 1:52:53 AM11/7/07
to cfeclip...@googlegroups.com
I was wandering if anybody has any tips on getting the debugger to break on
break points in a consistent manner.

On my XP Pro machine, sometimes a breakpoint will work, and sometimes it
won't. Sometimes a reboot of the machine will fix the problem, temporarily
at least. Sometimes I can break on something up-stream and step to the point
of interest, but this doesn't always work as sometimes after a step, app and
debugger go unresponsive.

Mike Henke

unread,
Nov 7, 2007, 10:48:48 AM11/7/07
to CFEclipse Users
Tom,

If FusionDebug try the FusionDebug group @ http://groups.google.com/group/fusiondebug
. They are really swell guys. Usually fast, friendly and thorough.

Best Regards,

Mike

Tom Lenz

unread,
Nov 7, 2007, 11:52:01 PM11/7/07
to cfeclip...@googlegroups.com

>
> If FusionDebug try the FusionDebug group @
> http://groups.google.com/group/fusiondebug
> . They are really swell guys. Usually fast, friendly and thorough.

I'm not using FusionDebug, but the the one that you get by installing the
plug-in from Adobe. I fussed with FusionDebug for a while but never got it
to work at all.

spra...@gmail.com

unread,
Nov 9, 2007, 7:18:46 PM11/9/07
to CFEclipse Users
Has anyone else seen this problem but me? I have Eclipse 3.2 with
CFEclipse 1.3.1.6, and Aptana 1.0 plug-ins.

Open up the File view under Aptana (Window>Show View>Other...>Aptana
Views>File).

Open up any cfm or cfc file from this view (project shortcuts, ftp, or
local files).

I get no line numbers and no options to enable them. My Outline view
also does not populate.

I get this on both of my computers, as does one of my co-workers.

On Nov 6, 10:37 pm, "sprag...@gmail.com" <sprag...@gmail.com> wrote:
> I now have a case open withAptanafor this. I posted the problem on

Mark Drew

unread,
Nov 10, 2007, 6:37:44 AM11/10/07
to cfeclip...@googlegroups.com
If they are opening in the CFEclipse editor (I presume this is the
case) you should be able to right click on the gutter to enable it for
*THAT* file

if not, I shall have a look, but go to Windows -> Prefereneces and
look for the editor settings and CFEclipse settings to set the line
numbers.

HTH

MD

--
Mark Drew
Blog: http://www.markdrew.co.uk/blog/
LinkedIn: http://www.linkedin.com/in/mdrew

spra...@gmail.com

unread,
Nov 10, 2007, 6:52:30 PM11/10/07
to CFEclipse Users
Hello Mark. In the preferences, the line numbers boxes are checked.
There is no gutter to right-click in, which I think is the whole
problem. The gutter does not open for CFM or CFC files. Yes, the
editor is CFEclipse. It looks like one other person has reported this
problem in my open bug case with Aptana. I'm just not sure if this is
an Aptana bug, or a CFEclipse bug.

On Nov 10, 6:37 am, "Mark Drew" <mark.d...@gmail.com> wrote:
> If they are opening in the CFEclipse editor (I presume this is the
> case) you should be able to right click on the gutter to enable it for
> *THAT* file
>
> if not, I shall have a look, but go to Windows -> Prefereneces and
> look for the editor settings and CFEclipse settings to set the line
> numbers.
>
> HTH
>
> MD
>

Tom Lenz

unread,
Nov 11, 2007, 1:07:31 AM11/11/07
to cfeclip...@googlegroups.com
I used http://www.cfeclipse.org/update for an update site to install
CFEclipse 1.3.1.6, and after the
installation, I got the subject error for the CFEclipse (including CFUnit
and Frameworks) 1.3.1.6 plugin. So, in this file,
\eclipse\plugins\org.cfeclipse.cfml_1.3.1.6\plugin.xml
I changed version="1.3.1.5" to version="1.3.1.6"
Is that all that's needed?

Stephen Davison

unread,
Nov 16, 2007, 1:10:05 PM11/16/07
to CFEclipse Users
Tom,
I got the same error and your fix appears to be all that needs to be
done to make it work -- it works great for me.

On Nov 10, 11:07 pm, "Tom Lenz" <astonishena...@gmail.com> wrote:
> I usedhttp://www.cfeclipse.org/updatefor an update site to install

Patriiiiiiiiiick

unread,
Nov 21, 2007, 1:35:22 PM11/21/07
to CFEclipse Users
I did this but now I see the warning: "Plug-in: "org.cfeclipse.cfml"
version: "1.3.1.6" referenced by this feature is not included at
runtime. Runtime includes plug-in version "1.3.1.6" supplied by
feature "CFEclipse (including CFUnit and Frameworks)" version
"1.3.1.6"."

Any hint?

Patrick

On Nov 11, 7:07 am, "Tom Lenz" <astonishena...@gmail.com> wrote:
> I usedhttp://www.cfeclipse.org/updatefor an update site to install

Brad Bourne

unread,
Nov 21, 2007, 3:27:57 PM11/21/07
to cfeclip...@googlegroups.com
At eclipse\features\org.cfeclipse.cfml.feature_1.3.1.6\feature.xml

<plugin
id="org.cfeclipse.cfml"
download-size="0"
install-size="0"
version="1.3.1.5"/>

eclipse is looking for 1.3.1.5 instead of 1.3.1.6

This is what Patriiiiiiiiiick said on 11/21/2007 10:35 AM:

Patriiiiiiiiiick

unread,
Nov 22, 2007, 11:28:23 AM11/22/07
to CFEclipse Users
I didn't do anything else and it seems to be fine today. Weird (I had
restarted Eclipse the other time).

On Nov 21, 7:35 pm, Patriiiiiiiiiick <patrick.lie...@gmail.com> wrote:
> I did this but now I see the warning: "Plug-in: "org.cfeclipse.cfml"
> version: "1.3.1.6" referenced by this feature is not included at
> runtime. Runtime includes plug-in version "1.3.1.6" supplied by
> feature "CFEclipse (including CFUnit and Frameworks)" version
> "1.3.1.6"."
>
> Any hint?
>
> Patrick
>
> On Nov 11, 7:07 am, "Tom Lenz" <astonishena...@gmail.com> wrote:
>
> > I usedhttp://www.cfeclipse.org/updateforan update site to install

Mark Drew

unread,
Nov 22, 2007, 11:36:47 AM11/22/07
to cfeclip...@googlegroups.com
I guess you just needed a restart and it was waiting for Thanksgiving ;)

MD

--

djailer

unread,
Nov 27, 2007, 7:49:28 PM11/27/07
to CFEclipse Users
I downloaded a fresh version of Europa, and updated to CFEclipse
1.3.1.6 (with CFUnit and CFFrameworks). I started with -clean and
still get errors. When I try to load the perspective it
says...'Problems opening perspective
'org.cfeclipse.cfml.perspective.CFML'. I can select and create a new
CF Project but when I try to create a cfml page I get ' The selected
wizard could not be started. Reason:Plug in
org.cfeclipse.cfml.wizards.cfmlwizard.NewCFMLWizard(unsupported minor
version 49.0) My Eclipse3.2 version (on a separate virtual disk) is
also not working. I changed the plugin.xml and features.xml to
version 1.3.1.6. -clean start but still no cfml perspective.
Anything I am missing?

Doug

On Nov 22, 8:36 am, "Mark Drew" <mark.d...@gmail.com> wrote:
> I guess you just needed a restart and it was waiting for Thanksgiving ;)
>
> MD
>
> On Nov 22, 2007 4:28 PM, Patriiiiiiiiiick <patrick.lie...@gmail.com> wrote:
>
>
>
>
>
> > I didn't do anything else and it seems to be fine today. Weird (I had
> > restarted Eclipse the other time).
>
> > On Nov 21, 7:35 pm, Patriiiiiiiiiick <patrick.lie...@gmail.com> wrote:
> > > I did this but now I see the warning: "Plug-in: "org.cfeclipse.cfml"
> > > version: "1.3.1.6" referenced by this feature is not included at
> > > runtime. Runtime includes plug-in version "1.3.1.6" supplied by
> > > feature "CFEclipse (including CFUnit and Frameworks)" version
> > > "1.3.1.6"."
>
> > > Any hint?
>
> > > Patrick
>
> > > On Nov 11, 7:07 am, "Tom Lenz" <astonishena...@gmail.com> wrote:
>
> > > > I usedhttp://www.cfeclipse.org/updateforanupdate site to install

Sonny Savage

unread,
Nov 28, 2007, 9:04:11 AM11/28/07
to cfeclip...@googlegroups.com
I'd normally recommend making sure your Java version was 1.5 or higher, but I thought Mark Drew put in a fix for that...

On Nov 27, 2007 7:49 PM, djailer < dja...@gmail.com> wrote:

I downloaded a fresh version of Europa, and updated to CFEclipse
1.3.1.6 (with CFUnit and CFFrameworks).  I started with -clean and
still get errors.  When I try to load the perspective it
says...'Problems opening perspective
'org.cfeclipse.cfml.perspective.CFML'.  I can select and create a new
CF Project but when I try to create a cfml page I get ' The selected
wizard could not be started.   Reason:Plug in
org.cfeclipse.cfml.wizards.cfmlwizard.NewCFMLWizard (unsupported minor

version 49.0)  My Eclipse3.2 version (on a separate virtual disk) is
also not working.  I changed the plugin.xml and features.xml to
version 1.3.1.6 .  -clean start but still no cfml perspective.

djailer

unread,
Nov 29, 2007, 3:42:49 AM11/29/07
to CFEclipse Users
It is anyway.

Actually, upon looking, I have 8 jre's in my 'Java' file. (Is that
bad?) I changed the "PATH" to the latest one, 1.6.0_03. I tried
moving all but that one out. No luck. I tried starting with a
command line \eclipse -vm \java\jre1.6.0_03\bin\java. It started but
took a looong time to load and CF stuff did not work in 3.2 or
Europa. The CFEclipse perspective opened but it could not find any
cfml templates. I also tried pointing at 1.5.0_10 and 1.5.0_06. Same
result. Hmmmm. I am working on W2K Pro(SP4), 1gig Intel processer,
40 GB hd(90% free), 1 GB ram. I am not all that good with this in the
first place but man am I stuck now!



On Nov 28, 6:04 am, "Sonny Savage" <sonnysav...@gmail.com> wrote:
> I'd normally recommend making sure your Java version was 1.5 or higher, but
> I thought Mark Drew put in a fix for that...
>
> On Nov 27, 2007 7:49 PM, djailer <djai...@gmail.com> wrote:
>
>
>
> > I downloaded a fresh version of Europa, and updated to CFEclipse
> > 1.3.1.6 (with CFUnit and CFFrameworks). I started with -clean and
> > still get errors. When I try to load the perspective it
> > says...'Problems opening perspective
> > 'org.cfeclipse.cfml.perspective.CFML'. I can select and create a new
> > CF Project but when I try to create a cfml page I get ' The selected
> > wizard could not be started. Reason:Plug in
> > org.cfeclipse.cfml.wizards.cfmlwizard.NewCFMLWizard(unsupported minor
> > version 49.0) My Eclipse3.2 version (on a separate virtual disk) is
> > also not working. I changed the plugin.xml and features.xml to
> > version 1.3.1.6. -clean start but still no cfml perspective.
> > Anything I am missing?
>
> > Doug
>
> > On Nov 22, 8:36 am, "Mark Drew" <mark.d...@gmail.com> wrote:
> > > I guess you just needed a restart and it was waiting for Thanksgiving ;)
>
> > > MD
>
> > > On Nov 22, 2007 4:28 PM, Patriiiiiiiiiick <patrick.lie...@gmail.com>
> > wrote:
>
> > > > I didn't do anything else and it seems to be fine today. Weird (I had
> > > > restarted Eclipse the other time).
>
> > > > On Nov 21, 7:35 pm, Patriiiiiiiiiick <patrick.lie...@gmail.com> wrote:
> > > > > I did this but now I see the warning: "Plug-in: "org.cfeclipse.cfml"
> > > > > version: "1.3.1.6" referenced by this feature is not included at
> > > > > runtime. Runtime includes plug-in version "1.3.1.6" supplied by
> > > > > feature "CFEclipse (including CFUnit and Frameworks)" version
> > > > > "1.3.1.6"."
>
> > > > > Any hint?
>
> > > > > Patrick
>
> > > > > On Nov 11, 7:07 am, "Tom Lenz" <astonishena...@gmail.com> wrote:
>
> > > > > > I usedhttp://www.cfeclipse.org/updateforanupdatesite to install

djailer

unread,
Dec 2, 2007, 5:10:59 PM12/2/07
to CFEclipse Users
Never mind. I told you I didn't know what I was doing. Once I got
the java vm to actually run 1.5 it works. I didn't have the jre
listed first in the PATH list. It was getting intercepted by the
java.exe somewhere in the System32 file and set it to 1.4. E 3.2
works now too. Thanks for the nudge.
> > > > > > > I usedhttp://www.cfeclipse.org/updateforanupdatesiteto install

Sonny Savage

unread,
Dec 3, 2007, 9:55:32 AM12/3/07
to cfeclip...@googlegroups.com
Glad it's working now.  It's always seemed strange to me that installing Java doesn't upgrade.  If you don't pay attention, you'll have several instances of it installed.
Reply all
Reply to author
Forward
0 new messages