Cannot Install 1.5.2

309 views
Skip to first unread message

Tiggrstaar

unread,
Feb 7, 2017, 6:19:21 PM2/7/17
to cfeclip...@googlegroups.com
I noticed version 1.5.2 was available today via the main update site but when I try to do the update it's still missing the dependency and won't let me update. I then thought maybe the conflict was related to the current version installed (1.5.1) so I uninstalled that. Once Eclipse was restarted I went to install the new version but I'm still getting the dependency issue.

It won't let me install anything beyond 1.4.5. Strangely if I select DocShare which is marked as optional it will let me install version 1.5.1 again.

I then tried using the update-dev site which people suggested in another thread. I have a similar experience there with the result being that I can install 1.5.1 at the latest.

Is DocShare not just optional? Any other way I could update to 1.5.2 or if not could someone please fix that issue when possible?

Also thanks for continuing to work on this! At some point I'll find some time to volunteer and help move things along myself.

Dependency issue:
Cannot complete the install because one or more required items could not be found.
  Software being installed: CFEclipse (including MXUnit and Frameworks) 1.5.2.201612262348 (org.cfeclipse.cfml.feature.feature.group 1.5.2.201612262348)
  Missing requirement: CFEclipse (including MXUnit and Frameworks) 1.5.2.201612262348 (org.cfeclipse.cfml.feature.feature.group 1.5.2.201612262348) requires 'org.mxunit.eclipseplugin.feature.feature.group 1.5.0' but it could not be found

Dependency issue using the update-dev site(basically the same besides version numbers):
Cannot complete the install because one or more required items could not be found.
  Software being installed: CFEclipse (including MXUnit and Frameworks) 1.5.3.201701082224 (org.cfeclipse.cfml.feature.feature.group 1.5.3.201701082224)
  Missing requirement: CFEclipse (including MXUnit and Frameworks) 1.5.3.201701082224 (org.cfeclipse.cfml.feature.feature.group 1.5.3.201701082224) requires 'org.mxunit.eclipseplugin.feature.feature.group 1.5.0' but it could not be found

Tiggrstaar

unread,
Mar 3, 2017, 5:15:41 PM3/3/17
to CFEclipse Users
Any tips so I can upgrade my cfeclipse version? It would be great to fix some annoying errors and get this better version.

Andrew Myers

unread,
Mar 3, 2017, 10:22:52 PM3/3/17
to cfeclip...@googlegroups.com
Hi,

What Eclipse Version and Update site are you using?

I currently have Eclipse Neon.2 (4.6.2) and CFEclipse installed from http://cfeclipse.org/update-preview. I use it daily and it's working fine, so I'm a bit curious to know what kind of issues you're having?

If you're using the same and see any errors, please give us a bit more information so we can try and help you further.

All the best,
Andrew.


On 4/03/2017 9:15 AM, Tiggrstaar wrote:
Any tips so I can upgrade my cfeclipse version? It would be great to fix some annoying errors and get this better version.
--
--
For more information on CFEclipse visit: cfeclipse.org
For support, FAQ and tips and tricks visit: https://github.com/cfeclipse/cfeclipse/wiki
 
You are subscribed to the Google Groups "CFEclipse Users" group.
To post send email to: cfeclip...@googlegroups.com
To unsubscribe send email to: cfeclipse-use...@googlegroups.com
For more options, visit this group online: http://groups.google.com/group/cfeclipse-users?hl=en

---
You received this message because you are subscribed to the Google Groups "CFEclipse Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cfeclipse-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Bernhard Döbler

unread,
Mar 7, 2017, 9:04:44 AM3/7/17
to CFEclipse Users
Use this Update site for latest CFEclipse: http://cfeclipse.org/update-dev/

Tiggrstaar

unread,
Mar 9, 2017, 5:05:38 PM3/9/17
to cfeclip...@googlegroups.com
I'm using Eclipse Neon.1a (4.6.1). Or I was. I just tried to update some other features and then the eclipse.exe disappeared. I've never seen that before. So now I'm updating to the very latest version unfortunately.

When I tried to install a newer version of cfeclipse from update-preview I only saw the latest version at 1.4.5. When I tried to install from update-dev I go the error message about not being to update because items couldn't be found.

Now that I've installed 4.6.2 it seems to be installing cfeclipse 1.5.3 successfully so looks like there's potentially a problem for people using anything but the latest version of eclipse or someone fixed the repository issue. Or a new install works but not upgrading.

Andrew Myers

unread,
Mar 9, 2017, 5:59:53 PM3/9/17
to cfeclip...@googlegroups.com
Interesting.  Sounds like there might be some incompatibility if using anything below 4.6.2.

I'll see what I can find out


On Fri, 10 Mar 2017 at 9:05 am, Tiggrstaar <sara...@gmail.com> wrote:
I'm using Eclipse Neon.1a (4.6.1). Or I was. I just tried to update some other features and then the eclipse.exe disappeared. I've never seen that before. So now I'm updating to the very latest version unfortunately.

When I tried to install a newer version of cfeclipse from update-preview I only saw the latest version at 1.4.5. When I tried to install from update-dev I go the error message about not being to update because items couldn't be found.

Now that I've installed 4.6.2 it seems to be installing cfeclipse 1.5.3 successfully so looks like there's potentially a problem for people using anything but the latest version of eclipse or someone fixed the repository issue.
--
Sent from Gmail Mobile
Reply all
Reply to author
Forward
0 new messages