Cannot Instally CFEclipse from Eclipse Marketplace - http://mxunit.org unavailable

162 views
Skip to first unread message

bruno.cha...@gmail.com

unread,
Oct 24, 2017, 6:18:47 PM10/24/17
to CFEclipse Users
Hello,

I am attempting to install the CFEclipse Plugin to work on a Coldfusion project, using Eclipse Oxygen.

I can find the CFEclipse Plugin in the Eclipse Marketplace, but when the download process begins, it stays stuck for minutes looking for alternatives.

I believe it is stuck when trying to download mxunit, and the site http://mxunit.org happens to be unavailable.


Can anyone help?

Thanks!

Paul S.

unread,
Oct 25, 2017, 4:54:18 PM10/25/17
to CFEclipse Users
I am experiencing the exact same issue, is there a manual install or something we can do to work around this issue? does anyone use MXUnit could it become an optional component of the install or are they inextricably tied together?


Andrew

unread,
Nov 7, 2017, 6:29:21 PM11/7/17
to CFEclipse Users

Hi,


Denny has put MXUnit on cfeclipse.org now, and I was able to install using the following steps:


Add http://cfeclipse.org/mxunit/update-dev as an update site in Eclipse (Help -> Install New Software -> Add -> http://cfeclipse.org/mxunit/update-dev).


Select that repo and install MXUnit.


Add the CFEclipse update site (Help -> Install New Software -> Add -> http://cfeclipse.org/update-dev)


Then CFEclipse should install as the dependency is met.


Regards,

Andrew.

bruno.cha...@gmail.com

unread,
Nov 9, 2017, 6:03:34 AM11/9/17
to CFEclipse Users
Hi Andrew,

thanks for the reply.

However, I am getting a CheckTrustPhase error when attempting the install MXUnit from the new update link.

"An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=C__Users_Bruno_eclipse_java-oxygen_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Error reading signed content.
Exception in opening zip file: C:\Users\Bruno\.p2\pool\features\org.mxunit.eclipseplugin.feature_1.5.0.201604240756"

I also noticed that the archive says 0 bytes, as you can see in the screenshot of the Install Details.



I have also tried downloading the jars and installing locally, but the same error occurs.

Can anyone help?

Thanks!

Bruno

Andrew Myers

unread,
Nov 14, 2017, 3:15:44 PM11/14/17
to cfeclip...@googlegroups.com
Hi Bruno,

I’m actually not sure about this one.  Are you still having the issue?

Are you using the /update or /update-dev site?

Andrew

--
--
For more information on CFEclipse visit: cfeclipse.org
For support, FAQ and tips and tricks visit: https://github.com/cfeclipse/cfeclipse/wiki
 
You are subscribed to the Google Groups "CFEclipse Users" group.
To post send email to: cfeclip...@googlegroups.com
To unsubscribe send email to: cfeclipse-use...@googlegroups.com
For more options, visit this group online: http://groups.google.com/group/cfeclipse-users?hl=en

---
You received this message because you are subscribed to the Google Groups "CFEclipse Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cfeclipse-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
Sent from Gmail Mobile
Reply all
Reply to author
Forward
0 new messages