Error updating to 1.5.3

63 views
Skip to first unread message

Richard Davies

unread,
Sep 26, 2019, 4:44:34 PM9/26/19
to CFEclipse Users
I got a notice today about a new version being available (v1.5.3) but when I try to update I get the following error:

An error occurred while collecting items to be installed
session context was:(profile=C__Users_csrichardd_eclipse2_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.cfeclipse.cfml,1.5.3
No repository found containing: org.eclipse.update.feature,org.cfeclipse.cfml.feature,1.5.3
No repository found containing: org.eclipse.update.feature,org.cfeclipse.cfml.snippets.feature,1.0.0.3
No repository found containing: osgi.bundle,org.eclipse.equinox.ds,1.6.0.v20190122-0806


Any one else getting this error? Any ideas on how to resolve the issue?

Richard Davies

unread,
Sep 26, 2019, 7:26:35 PM9/26/19
to CFEclipse Users
I was able to get it working by removing all CFEclipse-related update sites (MXUnit, CFLint, CFParser etc.), including http://cfeclipse.org/update, and then re-added http://cfeclipse.org/update as an update site. After doing that I was able to install the update.

Dan G. Switzer, II

unread,
Sep 27, 2019, 7:41:02 AM9/27/19
to cfeclip...@googlegroups.com
Glad you got it working, but I'd be a little scared to install any updates at this point. There doesn't appear to be any active development on it, so I'm not sure who pushed out the update or what it might address.

Does anyone know who pushed out the update and what's in it?

--
--
For more information on CFEclipse visit: cfeclipse.org
For support, FAQ and tips and tricks visit: https://github.com/cfeclipse/cfeclipse/wiki
 
You are subscribed to the Google Groups "CFEclipse Users" group.
To post send email to: cfeclip...@googlegroups.com
To unsubscribe send email to: cfeclipse-use...@googlegroups.com
For more options, visit this group online: http://groups.google.com/group/cfeclipse-users?hl=en

---
You received this message because you are subscribed to the Google Groups "CFEclipse Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cfeclipse-use...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cfeclipse-users/a299313e-d41c-4e34-a6d8-e845e7979061%40googlegroups.com.
Message has been deleted
Message has been deleted

Alan Holden

unread,
Sep 27, 2019, 12:32:55 PM9/27/19
to cfeclip...@googlegroups.com
I suspect the error message Richard Davies cites ("No repository found containing") may be due to a pretty common issue, in which Eclipse looses the ability to resolve one or more (or all in my case) package "sites", even the more common ones like Java, eGit and the Eclipse Marketplace itself.

After fiddling around with the settings (eg adding or removing the trailing slash from the site url, or removing and re-adding the plugin entirely, or unchecking the "contact all update sites" option or using the Marketplace's Update button instead), one can frequently kick Eclipse into finding, getting and installing the damn files again. Or not...

Google and SO are filled with stories from those who have been through this error message, regardless of the package they were going for. My .02 here is not to diminish the possibility that someone might actually have updated the package recently, just to suggest that the "No repository found containing" message may be entirely on Eclipse and not cfeclipse.org.

Al Holden

Richard Davies

unread,
Sep 27, 2019, 2:11:36 PM9/27/19
to CFEclipse Users
The code update was by Andrew Myers, who reached out to me privately after I posted my initial issue with some suggestions that lead me to the fix I shared.

As for what's in the update, I suppose you could look at the details in the GitHub repo https://github.com/cfeclipse/cfeclipse but it would be nice to have a changelog posted to this group or included in the project's readme.md

On Friday, September 27, 2019 at 4:41:02 AM UTC-7, Dan G. Switzer, II wrote:
Glad you got it working, but I'd be a little scared to install any updates at this point. There doesn't appear to be any active development on it, so I'm not sure who pushed out the update or what it might address.

Does anyone know who pushed out the update and what's in it?

On Thu, Sep 26, 2019 at 7:26 PM Richard Davies <richard...@gmail.com> wrote:
I was able to get it working by removing all CFEclipse-related update sites (MXUnit, CFLint, CFParser etc.), including http://cfeclipse.org/update, and then re-added http://cfeclipse.org/update as an update site. After doing that I was able to install the update.

On Thursday, September 26, 2019 at 1:44:34 PM UTC-7, Richard Davies wrote:
I got a notice today about a new version being available (v1.5.3) but when I try to update I get the following error:

An error occurred while collecting items to be installed
session context was:(profile=C__Users_csrichardd_eclipse2_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.cfeclipse.cfml,1.5.3
No repository found containing: org.eclipse.update.feature,org.cfeclipse.cfml.feature,1.5.3
No repository found containing: org.eclipse.update.feature,org.cfeclipse.cfml.snippets.feature,1.0.0.3
No repository found containing: osgi.bundle,org.eclipse.equinox.ds,1.6.0.v20190122-0806


Any one else getting this error? Any ideas on how to resolve the issue?

--
--
For more information on CFEclipse visit: cfeclipse.org
For support, FAQ and tips and tricks visit: https://github.com/cfeclipse/cfeclipse/wiki
 
You are subscribed to the Google Groups "CFEclipse Users" group.
To post send email to: cfeclip...@googlegroups.com
To unsubscribe send email to: cfeclip...@googlegroups.com

For more options, visit this group online: http://groups.google.com/group/cfeclipse-users?hl=en

---
You received this message because you are subscribed to the Google Groups "CFEclipse Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cfeclip...@googlegroups.com.
Reply all
Reply to author
Forward
Message has been deleted
0 new messages