Failed when getting Related Person by SSN

44 views
Skip to first unread message

Long Thanh Do

unread,
Jan 24, 2022, 4:26:40 AMJan 24
to Cerner FHIR Developers
Hi Cerner Team,

We have an issue when trying to get a related person by SSN after created successfully. There are steps we have tested:
Step 1: Create a related person with SSN - it returned 201 - Created.
Step 2: Search related person by patient Id - We found the related person created above.
Step 3: Search related person by SSN - it returns 200 - Ok but nothing in the response.

Here is the information about the search request:


Expected Result: 200 - Ok with related person's data

Actual Result: 200 - Ok with nothing in the response

8.png


X-Request-Id: 000709cc-e522-421d-9500-a7c04aecf18e

Please help us to investigate this issue and let us know if there is any update.

Thanks,

Do Thanh Long

Duc Van Tran

unread,
Jan 26, 2022, 10:39:12 PMJan 26
to Cerner FHIR Developers
Hi Cerner Team,

We received updates on the issue Failed when getting Related Person by SSN from Cerner that we need to remove the leading zero from SSN to get Related Person because The SSN was written in the domain stripping the leading zero. 

But we tried removing the leading zero and searching again, then nothing in the response.

Besides, I tried to test following the steps as Long mentioned with the leading non-zero and nothing in the response too. 

The steps to test are the same as above.

Here is the information about the search request:

Request URL: {{baseUrl}}/{{tenantId}}/RelatedPerson?identifier=http://hl7.org/fhir/sid/us-ssn|{{ssn}}&-relationship-level=http://hl7.org/fhir/resource-types|Patient

Expected Result: 200 - Ok with related person's data

Actual Result: 200 - Ok with nothing in the response

X-Request-Id: 999cf4ca-464d-4ed7-bdad-59ca3163c9b1Screenshot 2022-01-27 103005.png

Please help us to investigate this issue and let us know if there is any update.

Thanks,

Duc Van Tran


Fenil Desani (Cerner)

unread,
Jan 27, 2022, 9:41:15 AMJan 27
to Cerner FHIR Developers
Hello,

It seems our support team is already engaged with you. Please continue to work with that team to resolve your issue.

Thanks,
Fenil

Reply all
Reply to author
Forward
0 new messages