Issue adding a diagnosis to a patient

34 views
Skip to first unread message

David Corn

unread,
Apr 22, 2020, 4:58:02 PM4/22/20
to Cerner FHIR Developers
Hi there, I am trying to add an ICD-10 diagnosis to a patient as documented here - https://fhir.cerner.com/millennium/dstu2/general-clinical/condition/#create. I'm getting a 400 error with "Invalid request" as the response. The X-Request-Id = ecc44bcd6c4eae2c8480a5e0481a5659. I'm new to FHIR, any help would be appreciated.

Benjamin Eichhorn (Cerner)

unread,
Apr 22, 2020, 5:21:02 PM4/22/20
to Cerner FHIR Developers
Hi David,

It appears you're not testing in our sandbox domain and inside of a client domain. The issue you are seeing is caused by missing mappings for the verificationStatus field. You'll want to log an SR using these instructions for eService to the Open Development Services Solution family and Ignite APIs for Mill as the Solution. Please mention the version of FHIR you are using (DSTU2 or R4), the resource (example: Condition), the fields on the resource (example: Condition.verificationStatus), and specific standard codes (including the system) that you want mapped. You will likely want to mention more than just the verificationStatus field as if this domain has not been mapped before for the Condition Create resource, you'll want to ensure all mappings are there.

In the meantime you can test the Condition Create operation in our public sandbox.

Thanks,
Ben (Cerner)

David Corn

unread,
Apr 23, 2020, 2:57:07 PM4/23/20
to Cerner FHIR Developers
Thank you!
Reply all
Reply to author
Forward
0 new messages