Update on Chromium Browser support?

128 views
Skip to first unread message
Assigned to Fenil....@cerner.com by me

Lynsey Bentley

unread,
Aug 11, 2021, 4:32:03 PM8/11/21
to Cerner FHIR Developers
I saw a post for February titled "IE 11 Support" saying IE 11/10 is still the requirement - any updates to supporting Chromium-based browsers?

Thanks!
Lynsey

Fenil Desani (Cerner)

unread,
Aug 13, 2021, 12:45:49 PM8/13/21
to Cerner FHIR Developers
Hello,

Currently Cerner Millennium application teams are actively working to leverage Microsoft’s Edge browser for solutions that utilize Internet Explorer today. The applications that use Internet Explorer are planned to review their current configuration to try and transition to using the new Edge browser. Since Internet Explorer is not going away, the applications that use it will still function correctly. Applications that will use Edge will start updating their instructions to do so.

Browser requirement for SMART Apps - http://fhir.cerner.com/smart/#browser-requirement

Thanks,
Fenil

jo...@mouch.name

unread,
Nov 11, 2021, 1:41:05 PM11/11/21
to Cerner FHIR Developers
Are there any commitments to having Smart on FHIR work with Edge within the next year or two?  Or is there any more specific timeline?

Justin Tubbs

unread,
Nov 11, 2021, 3:48:09 PM11/11/21
to Cerner FHIR Developers
I have previously asked this question of Cerner and received this response:

Hey Justin,

If you noticed in that article it specifies the desktop application. Microsoft has been clear that the server operating systems are unaffected by the announcement.

In any event, Cerner is well underway making chromium available, but there are many workflows that must be validated and will be some time before IE is completely deprecated.

Drew @ Cerner




There is still some active development/validation across embedded web workflows so there may be additional changes, but 2018.08 is the correct Millennium base release.

Cameron Travers 
Director, Application & Service Platform Management

Justin Tubbs

unread,
Nov 15, 2021, 10:59:03 AM11/15/21
to Cerner FHIR Developers
Q: I’m personally interested in the Google Chromium support in PowerChart not specifically related to Edge browser (but I do know it is based on the Chromium engine)
A: Chromium will be supported in PowerChart via the embedded Edge browser.

Cameron Travers 
Director, Application & Service Platform Management



Justin Tubbs

unread,
Nov 17, 2021, 7:48:24 AM11/17/21
to Cerner FHIR Developers

2018.08 is the version of Millennium that includes support for the Microsoft Edge browser.  There is still additional work that is necessary to enable SMART applications to work with Microsoft Edge browser plugin that is targeted for 2022.

Cameron Travers 
Director, Application & Service Platform Management



Justin Tubbs

unread,
Jan 10, 2022, 5:12:23 PMJan 10
to Cerner FHIR Developers

For Microsoft Edge, the bare minimum code level we need is 2018.01.07

As far as requirements for mPage development: 

-          Standalone custom mPages: no baseline requirements
-          Custom component development on IE: mPages 6.12+
-          Custom component development on Edge: mPages 7.0+

Reply all
Reply to author
Forward
0 new messages