Web Dashboard doesn't run

88 views
Skip to first unread message

Jirong Hu

unread,
May 26, 2009, 6:55:17 PM5/26/09
to ccnet-user
I download the latest version of CruiseControl.Net installer. After
setup, I can start the service, or run from console, but when try to
access http://localhost/ccnet, I got this error. I am using IIS7 and
the web server is running, I also see the ccnet web app is installed
in IIS.

I haven't worked with MS stuff for long and don't even know how to
deploy a web app to IIS now.

Thanks
Jirong

-------- error msg while access the http://localhost/ccnet -------

Server Error in Application "DEFAULT WEB SITE/CCNET"Internet
Information Services 7.0

Error Summary
HTTP Error 500.23 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated
managed pipeline mode. Detailed Error InformationModule
ConfigurationValidationModule
Notification BeginRequest
Handler StaticFile
Error Code 0x80070032
Requested URL http://localhost:80/ccnet
Physical Path C:\Program Files (x86)\CruiseControl.NET\webdashboard
Logon Method Not yet determined
Logon User Not yet determined
Most likely causes:
This application defines configuration in the system.web/httpHandlers
section.
Things you can try:
Migrate the configuration to the system.webServer/handlers section.
You can do so manually or by using AppCmd from the command line - for
example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default
Web Site/". Using appcmd to migrate your application will enable it to
work in Integrated mode, and continue to work in Classic mode and on
previous versions of IIS.
If you are certain that it is OK to ignore this error, it can be
disabled by setting system.webServer/
validation@validateIntegratedModeConfiguration to false.
Alternatively, switch the application to a Classic mode application
pool - for example, appcmd set app "Default Web Site/" /
applicationPool:"Classic .NET AppPool". Only do this if you are unable
to migrate your application.
(Set "Default Web Site" and "Classic .NET AppPool" to your application
path and application pool name)

Ruben Willems

unread,
May 27, 2009, 1:39:37 AM5/27/09
to ccnet...@googlegroups.com
Hi


look at the bottom of the error message :

Alternatively, switch the application to a Classic mode application
pool - for example, appcmd set app "Default Web Site/" /
applicationPool:"Classic .NET AppPool". Only do this if you are unable
to migrate your application.
(Set "Default Web Site" and "Classic .NET AppPool" to your application
path and application pool name)



this works perfectly

with kind regards
Ruben Willems

Jirong Hu

unread,
May 27, 2009, 10:57:39 AM5/27/09
to ccnet-user
The commond line doesn't work, I changed from IIS Manager. It's
working now.

Thanks
Jirong

On May 26, 11:39 pm, Ruben Willems <ruben.will...@gmail.com> wrote:
> Hi
>
> look at the bottom of the error message :
> Alternatively, switch the application to a Classic mode application
> pool - for example, appcmd set app "Default Web Site/" /
> applicationPool:"Classic .NET AppPool". Only do this if you are unable
> to migrate your application.
> (Set "Default Web Site" and "Classic .NET AppPool" to your application
> path and application pool name)
>
> this works perfectly
>
> with kind regards
> Ruben Willems
>
>
>
> On Wed, May 27, 2009 at 12:55 AM, Jirong Hu <jirong...@gmail.com> wrote:
>
> > I download the latest version of CruiseControl.Net installer. After
> > setup, I can start the service, or run from console, but when try to
> > accesshttp://localhost/ccnet, I got this error. I am using IIS7 and
> > the web server is running, I also see the ccnet web app is installed
> > in IIS.
>
> > I haven't worked with MS stuff for long and don't even know how to
> > deploy a web app to IIS now.
>
> > Thanks
> > Jirong
>
> > -------- error msg while access thehttp://localhost/ccnet-------
>
> > Server Error in Application "DEFAULT WEB SITE/CCNET"Internet
> > Information Services 7.0
>
> > Error Summary
> > HTTP Error 500.23 - Internal Server Error
> > An ASP.NET setting has been detected that does not apply in Integrated
> > managed pipeline mode. Detailed Error InformationModule
> > ConfigurationValidationModule
> > Notification BeginRequest
> > Handler StaticFile
> > Error Code 0x80070032
> > Requested URLhttp://localhost:80/ccnet
> > Physical Path C:\Program Files (x86)\CruiseControl.NET\webdashboard
> > Logon Method Not yet determined
> > Logon User Not yet determined
> >  Most likely causes:
> > This application defines configuration in the system.web/httpHandlers
> > section.
> >  Things you can try:
> > Migrate the configuration to the system.webServer/handlers section.
> > You can do so manually or by using AppCmd from the command line - for
> > example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default
> > Web Site/". Using appcmd to migrate your application will enable it to
> > work in Integrated mode, and continue to work in Classic mode and on
> > previous versions of IIS.
> > If you are certain that it is OK to ignore this error, it can be
> > disabled by setting system.webServer/
> > validation@validateIntegratedModeConfiguration to false.
> > Alternatively, switch the application to a Classic mode application
> > pool - for example, appcmd set app "Default Web Site/" /
> > applicationPool:"Classic .NET AppPool". Only do this if you are unable
> > to migrate your application.
> > (Set "Default Web Site" and "Classic .NET AppPool" to your application
> > path and application pool name)- Hide quoted text -
>
> - Show quoted text -
Reply all
Reply to author
Forward
0 new messages