Problem loading admin access

41 views
Skip to first unread message

cyberdoo78

unread,
Nov 7, 2012, 3:39:02 AM11/7/12
to ccl...@googlegroups.com
So I think I got all the packages that need to be installed, all the PERL scripts that are needed and I run into this error everytime I try to login with the manager account to my database.

[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: defined(@array) is deprecated at ../lib/HTML/SimpleTemplate.pm line 169.
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: (Maybe you should just omit the defined()?)
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: defined(@array) is deprecated at ../lib/HTML/SimpleTemplate.pm line 352.
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: (Maybe you should just omit the defined()?)
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: defined(@array) is deprecated at ../lib/HTML/SimpleTemplate.pm line 169.
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: (Maybe you should just omit the defined()?)
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: defined(@array) is deprecated at ../lib/HTML/SimpleTemplate.pm line 352.
[Tue Nov  6 03:41:00 2012] SimpleTemplate.pm: (Maybe you should just omit the defined()?)
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 480.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 480.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 520.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 520.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 560.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 560.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 600.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 600.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 640.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 640.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 680.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 680.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 720.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 720.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 760.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 760.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 800.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 800.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 840.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 840.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st execute failed: No database selected at ../lib/Cclitedb.pm line 402, <CONFIG> line 880.
[Tue Nov  6 03:41:01 2012] cclite.cgi: DBD::mysql::st fetchall_hashref failed: statement contains no result [err was 4 now 2000000000]
[Tue Nov  6 03:41:01 2012] cclite.cgi: Field 'tradeId' does not exist (not one of ) at ../lib/Cclitedb.pm line 403, <CONFIG> line 880.

The first few I recognize  are just warnings, I think. The rest, I don't know. Looks like it's not taking the database name.

Hugh Barnard

unread,
Nov 7, 2012, 3:55:17 AM11/7/12
to ccl...@googlegroups.com
Hi

1. Is the user and password etc. for the database[s] OK in /usr/share/cclite/config/cclite.cf? Sometimes there's a permissions problem with updating it?

2. cpanelprefix=myprefix in cclite.cf may be a problem, if it's set because this allows databases in cpanel be used as 'name', rather than 'myprefix_name'

3. I'll modify Simpletemplate at some stage, it's used in cclite to avoid using the [much bigger and more complex] template toolkit for example, but I think sooner or later, it'll have to go there.

Best regards Hugh Barnard


--
You received this message because you are subscribed to the Google Groups "cclite" group.
To view this discussion on the web visit https://groups.google.com/d/msg/cclite/-/zEUTfGZvqnYJ.
To post to this group, send email to ccl...@googlegroups.com.
To unsubscribe from this group, send email to cclite+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/cclite?hl=en.



--
http://www.hughbarnard.org
http://www.twitter.com/hughbarnard
http://www.big-wave-heuristics.com/

cyberdoo78

unread,
Nov 8, 2012, 4:47:34 PM11/8/12
to ccl...@googlegroups.com
1. The user/password is correct in /usr/share/cclite/config/cclite.cf. I verified by using mysql to log into the database. Also the cgi scripts report being able to write to the file and they are actually writing data to the file.

2. I don't use cpanel, so I have left the cpanelprefix blank. This is confirmed in the cclite.cf file as well.

3. As it's just spitting out what appear to be warnings, it's no big deal.

My problem however remains the same.

Thanks again for your help Mr. Barnard.

Hugh Barnard

unread,
Nov 9, 2012, 2:16:15 AM11/9/12
to ccl...@googlegroups.com
Ok thanks, I'll try and take a closer look and see whether I can reproduce it...this will probably take a moment longer...

To view this discussion on the web visit https://groups.google.com/d/msg/cclite/-/ZoZTILkRJPcJ.

To post to this group, send email to ccl...@googlegroups.com.
To unsubscribe from this group, send email to cclite+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/cclite?hl=en.

hugh.b...@gmail.com

unread,
Nov 11, 2012, 9:33:08 AM11/11/12
to ccl...@googlegroups.com
Apparently there's been a great dealing of complaining about the Ubuntu SHA1 problem, it has broken a great many other, more high-profile packages:
https://bugs.launchpad.net/ubuntu/+source/libdigest-sha1-perl/+bug/993648 

I'm trying a few experiments on Amazon EC2, since these VMs are theoretically 'clean' and this is useful knowledge anyway...more later..


On Friday, November 9, 2012 7:16:20 AM UTC, hugh.b...@googlemail.com wrote:
Ok thanks, I'll try and take a closer look and see whether I can reproduce it...this will probably take a moment longer...

To unsubscribe from this group, send email to cclite+unsubscribe@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/cclite?hl=en.

cyberdoo78

unread,
Nov 11, 2012, 9:42:14 PM11/11/12
to ccl...@googlegroups.com
Yeah, I read those threads and near as I can understanding we are talking about two different SHA algorithms. SHA1 which is backwards compatible with SHA and SHA which isn't SHA-1. This may explain why I'm having database problems, since I've installed the Ubuntu SHA package and not the SHA-1 package, which there isn't any. 

I've used CPAN to install the SHA-1 perl package, but I need to figure out how to link it to the rest of the Digest so that it can be found.

I don't know, what do you think?

cyberdoo78

unread,
Nov 12, 2012, 2:35:05 AM11/12/12
to ccl...@googlegroups.com
Okay, I think I properly linked the SHA1.pm and SHA2.pm files to my file base. However, I'm still getting that DBD::mysql::st error. I don't understand PERL enough to help you figure it out. If there is anything I can do, let me know.

Forrest

Hugh Barnard

unread,
Nov 12, 2012, 6:35:57 AM11/12/12
to ccl...@googlegroups.com
Hi

Sorry, to step backwards a little, did you use: http://<yourdomain>/cgi-bin/protected/ccinstall.cgi and look at the installation analysis?

On my side, I've just been through a Debian package install on Amazon EC2. I had to use CPAN to install Digest::SHA1 and then it worked with no other problems.

Apparently the new library name breaks the Digest API calls, so just changing the control file entries will not solve the problem, although it'll allow the package to install.

So the current [slightly messy] fix is CPAN and Digest::SHA1. Hopefully since other high profile packages including spamassassin are affected, this will get fixed somehow.

I've put a warning up in sourceforge news for the moment.

Best regards Hugh


To view this discussion on the web visit https://groups.google.com/d/msg/cclite/-/uBHNczDx_qQJ.

To post to this group, send email to ccl...@googlegroups.com.
To unsubscribe from this group, send email to cclite+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/cclite?hl=en.

cyberdoo78

unread,
Nov 12, 2012, 9:57:20 PM11/12/12
to ccl...@googlegroups.com
Hugh,

Yeah, I did the installation analysis and it shows everything is good to go on that front.

I too installed the Digest::SHA1 perl package via CPAN. I've also checked to make sure that my perl directories are in the perl include path.

Perhaps I'll remove the cclite package and try installing from the tar package. See if it's just a problem with the way I installed and patched the missing files.

However this DBD::mysql::st error bothers me since I can't seem to find any information about it. I think it's part of the DBD::mysql CPAN package, but I don't know for sure. Guess I need to bone up on PERL.

I'll let you know how things go after the uninstall.

Forrest

Hugh Barnard

unread,
Nov 13, 2012, 5:19:36 AM11/13/12
to ccl...@googlegroups.com
Hi Forrest

It looks as though it's just not picking up a registry database, though it shouldn't do that as a result, should error out nicely.

1. Does the 'show registries' function work, it's in the installer: etc. etc.  /cgi-bin/protected/ccinstall.cgi?action=showregistries

2. All the logon etc. uses cookies so if these are turned off in your browser, that's a problem too.

3. Alternatively, if you have phpmyadmin, I'd have a look at your registry with that, for example.

Best regards Hugh




To view this discussion on the web visit https://groups.google.com/d/msg/cclite/-/c-jcv1hHyGQJ.

To post to this group, send email to ccl...@googlegroups.com.
To unsubscribe from this group, send email to cclite+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/cclite?hl=en.

cyberdoo78

unread,
Nov 13, 2012, 7:27:08 AM11/13/12
to ccl...@googlegroups.com
Hugh, 

Yeah the show registries works. Yeah, I'm using cookies. I use Google Chrome and haven't had any problems with it before. I'll try disabling my plug ins and see if that works, after I re-install it. I can see the database through phpmyadmin but I don't know what to be looking for.
Reply all
Reply to author
Forward
0 new messages