Failed to build cbioportal

10 views
Skip to first unread message

Carlos Espinosa

unread,
Jul 29, 2021, 2:46:50 AMJul 29
to cBioPortal for Cancer Genomics Discussion Group
Hi, 

I just recently tried to do a fresh build of cbioportal's latest version (3.6.21), and I'm getting the following error when building:

[INFO] ------------------------------------------------------------------------

[INFO] Reactor Summary for Portal Master 3.6.18-dirty-SNAPSHOT:

[INFO

[INFO] Portal Master ...................................... SUCCESS [  1.846 s]

[INFO] persistence ........................................ SUCCESS [  0.043 s]

[INFO] persistence-connections ............................ SUCCESS [  2.521 s]

[INFO] model .............................................. SUCCESS [  2.051 s]

[INFO] persistence-api .................................... SUCCESS [  1.220 s]

[INFO] db-scripts ......................................... SUCCESS [  0.661 s]

[INFO] persistence-mybatis ................................ SUCCESS [  1.595 s]

[INFO] service ............................................ SUCCESS [  2.360 s]

[INFO] security ........................................... SUCCESS [  0.027 s]

[INFO] security-spring .................................... FAILURE [  3.042 s]

[INFO] Portal Web Layer ................................... SKIPPED

[INFO] Portal Core ........................................ SKIPPED

[INFO] cBioPortal ......................................... SKIPPED

[INFO] Portal Scripts ..................................... SKIPPED

[INFO] ------------------------------------------------------------------------

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  25.179 s

[INFO] Finished at: 2021-07-29T06:15:48Z

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal on project security-spring: Could not resolve dependencies for project org.mskcc.cbio:security-spring:jar:3.6.18-dirty-SNAPSHOT: Failed to collect dependencies at org.springframework.security:spring-security-openid:jar:5.3.1.RELEASE -> net.sourceforge.nekohtml:nekohtml:jar:1.9.22 -> xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004: Failed to read artifact descriptor for xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004: Could not transfer artifact xerces:xercesImpl:pom:2.12.0-alfresco-patched-20191004 from/to plugins-release (https://repo.spring.io/plugins-release): Not authorized -> [Help 1]

[ERROR

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.


I tried to downgrade to what i had previously which was working (3.6.18) but I can't build anymore; I get the same error. Running maven with -e gets the following output (I trimmed it because it's too long):

[ERROR] Failed to execute goal on project security-spring: Could not resolve dependencies for project org.mskcc.cbio:security-spring:jar:3.6.18-dirty-SNAPSHOT: Failed to collect dependencies at org.springframework.security:spring-security-openid:jar:5.3.1.RELEASE -> net.sourceforge.nekohtml:nekohtml:jar:1.9.22 -> xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004: Failed to read artifact descriptor for xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004: Could not transfer artifact xerces:xercesImpl:pom:2.12.0-alfresco-patched-20191004 from/to plugins-release (https://repo.spring.io/plugins-release): Not authorized -> [Help 1]

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project security-spring: Could not resolve dependencies for project org.mskcc.cbio:security-spring:jar:3.6.18-dirty-SNAPSHOT: Failed to collect dependencies at org.springframework.security:spring-security-openid:jar:5.3.1.RELEASE -> net.sourceforge.nekohtml:nekohtml:jar:1.9.22 -> xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004

    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies (LifecycleDependencyResolver.java:269)

    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies (LifecycleDependencyResolver.java:147)

    at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved (MojoExecutor.java:248)

...

Caused by: org.apache.maven.project.DependencyResolutionException: Could not resolve dependencies for project org.mskcc.cbio:security-spring:jar:3.6.18-dirty-SNAPSHOT: Failed to collect dependencies at org.springframework.security:spring-security-openid:jar:5.3.1.RELEASE -> net.sourceforge.nekohtml:nekohtml:jar:1.9.22 -> xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004

    at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve (DefaultProjectDependenciesResolver.java:178)

    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies (LifecycleDependencyResolver.java:243)

    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies (LifecycleDependencyResolver.java:147)

    at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved (MojoExecutor.java:248)

    at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:202)

...

Caused by: org.eclipse.aether.collection.DependencyCollectionException: Failed to collect dependencies at org.springframework.security:spring-security-openid:jar:5.3.1.RELEASE -> net.sourceforge.nekohtml:nekohtml:jar:1.9.22 -> xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004

    at org.eclipse.aether.internal.impl.collect.DefaultDependencyCollector.collectDependencies (DefaultDependencyCollector.java:284)

    at org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencies (DefaultRepositorySystem.java:269)

    at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve (DefaultProjectDependenciesResolver.java:169)

    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies (LifecycleDependencyResolver.java:243)

...

Caused by: org.eclipse.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for xerces:xercesImpl:jar:2.12.0-alfresco-patched-20191004

    at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom (DefaultArtifactDescriptorReader.java:255)

    at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor (DefaultArtifactDescriptorReader.java:171)

    at org.eclipse.aether.internal.impl.collect.DefaultDependencyCollector.resolveCachedArtifactDescriptor (DefaultDependencyCollector.java:530)

...

Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Could not transfer artifact xerces:xercesImpl:pom:2.12.0-alfresco-patched-20191004 from/to plugins-release (https://repo.spring.io/plugins-release): Not authorized

    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve (DefaultArtifactResolver.java:413)

    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts (DefaultArtifactResolver.java:215)

    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact (DefaultArtifactResolver.java:192)

...

Caused by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact xerces:xercesImpl:pom:2.12.0-alfresco-patched-20191004 from/to plugins-release (https://repo.spring.io/plugins-release): Not authorized

    at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed (ArtifactTransportListener.java:52)

    at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run (BasicRepositoryConnector.java:368)

    at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run (RunnableErrorForwarder.java:75)

...

Caused by: org.apache.maven.wagon.authorization.AuthorizationException: Not authorized

    at org.apache.maven.wagon.providers.http.wagon.shared.AbstractHttpClientWagon.fillInputData (AbstractHttpClientWagon.java:1145)

    at org.apache.maven.wagon.providers.http.wagon.shared.AbstractHttpClientWagon.fillInputData (AbstractHttpClientWagon.java:1094)

    at org.apache.maven.wagon.StreamWagon.getInputStream (StreamWagon.java:126)

    at org.apache.maven.wagon.StreamWagon.getIfNewer (StreamWagon.java:88)


Have any of you encounter this and/or have any suggestions/tips? I cannot deploy cbioportal anymore at our institution. It appeared to be working fine a week ago when I updated the portal.

Thanks.

-Carlos

Pim van Nierop

unread,
Jul 30, 2021, 2:10:20 AMJul 30
to Carlos Espinosa, cBioPortal for Cancer Genomics Discussion Group
Dear Carlos,

This error is caused by the host system unable to retrieve maven dependencies. What may help in this case is to empty your maven caches and try again:

rm -rf ~/.m2/repositories

This is assuming you are on a Linux system. For OSX or Windows you may need to look on Internet to find the corresponding location.

If this does not help do not hesitate to reply here.

All the best,
Pim

--
You received this message because you are subscribed to the Google Groups "cBioPortal for Cancer Genomics Discussion Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cbioportal+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cbioportal/bc6c3dfe-9c20-4e23-9d82-7e6400f13c8an%40googlegroups.com.


--

Pim van Nierop

Software Engineer / cBioPortal specialist


E p...@thehyve.nl

T +31(0)30 700 9713

M +31(0)6 29464525

W thehyve.nl



    
Reply all
Reply to author
Forward
0 new messages