Error: WXIS|fatal error|unavoidable|noderead/read|

201 views
Skip to first unread message

Fernando Gómez

unread,
Jun 27, 2005, 12:35:20 PM6/27/05
to cat...@googlegroups.com
Recibí la siguiente consulta desde "Biblioteca Virtual de la UNR", y
la comparto con la lista:

> Instalamos el Catalis y en el momento de loguearnos con User = XX Pass =
> test nos devuelve el siguiente error:
>
> WXIS|fatal error|unavoidable|noderead/read|
>
> Que nos falta configurar....?

Ante todo, es importante saber si la instalación es sobre Linux o
Windows (y, por supuesto, si bajaron la versión de Catalis para ese
sistema operativo).

El mensaje de error no me resulta familiar, al menos en este contexto.
Parece hacer referencia a un problema de lectura del archivo invertido,
pero ¿de qué base? Puede ser la base de usuarios (user) o la base
bibliográfica demo, que es la primera que intenta presentar luego del
login.

Yo intentaría ejecutar mx en ambos directorios (user y demo, dentro de
bases/catalis_pack/catalis), para ver si detecto algo extraño en las
bases:

En user:
mx user now -all
mx dict=user now -all

En demo:
mx biblio now -all
mx dict=biblio now -all

En todos los casos, lo normal es que no aparezca *nada* en la pantalla.
Si sale algún mensaje, es señal de problemas.

Saludos.


--Fernando

Biblioteca Virtual de la UNR

unread,
Jun 28, 2005, 8:29:38 AM6/28/05
to cat...@googlegroups.com
Siguiendo tu consejo nos dió el siguiente error en la base user,
mientras que en la base demo no produjo ningún error:

C:\Apache\bases\catalis_pack\catalis\users>mx user now -all
dbxopen: 'user.xrf' errno=2
fatal: dbxopen/open


C:\Apache\bases\catalis_pack\catalis\users>mx dict=user now -all
dbxopen: 'user.cnt' errno=2
fatal: dbxopen/open

Desde ya muchas gracias...

Fernando Gómez ha escrito:

Fernando Gómez

unread,
Jun 28, 2005, 9:37:51 AM6/28/05
to cat...@googlegroups.com
Perdonen, hubo una distracción de mi parte. La base se llama 'users',
no 'user'. Por favor vuelvan a probar con el nombre correcto (que es
el nombre de los archivos que viven en esa carpeta: users.mst, etc.)

Si eso anda bien, entonces hagan allí mismo una búsqueda del usuario xx:

mx users xx

la salida debe ser:

1 XX
1 Set #000000001
Hits=1
mfn= 1
1 «XX»
2 «Instituci¾n»
3 «test»
4 «Nombre Apellido»
5 «demo^p2»
5 «celtic^p2»

(Luego con x+Enter salen de allí).

Si todo eso anda bien, entonces por la lado de la base users no anda
el problema. En el caso de la base demo, pueden probar esta búsqueda:

mx biblio "-nc=000100"

que debe devolver el último registro de la base (mfn = 100), que dice
entre otras cosas:

245 «04^aThe role of civic groups in promoting democracy and good
governance in southern Africa :^bexperiences of Malawi, South Africa,
Zambia, and Zimbabwe /

Saludos.

--
Fernando

Biblioteca Virtual de la UNR

unread,
Jun 29, 2005, 8:44:50 AM6/29/05
to cat...@googlegroups.com
Fernando: llevamos a cobo todos los pasos que nos indicaste y todo
salió bien, pero en el momento de comenzar a utilizar el Catalis,
después del intento de logueo sigue saliendo el mismo error.

WXIS|fatal error|unavoidable|noderead/read|

Desde ya muchas gracias....

Fernando Gómez

unread,
Jun 29, 2005, 10:48:07 AM6/29/05
to cat...@googlegroups.com
> después del intento de logueo sigue saliendo el mismo error.
>
> WXIS|fatal error|unavoidable|noderead/read|

Sigo sin tener una idea de lo que puede estar causando eso, así que
volvamos al principio.

* Descarguen nuevamente el .zip

* Verifiquen que el .zip tiene el tamaño correcto, que ahora se
muestra en el formulario de descarga:

http://inmabb.criba.edu.ar/catalis/catalis.php?p=download

* Repitan la instalación (si ya modificaron el catalis.conf,
consérvenlo así no pierden tiempo con eso)

Por otra parte, se me ocurre la sugerencia de instalarlo en alguna
otra máquina, que quizás ya lo hayan intentado.

Con este caso ya van *dos* de errores extraños --el otro caso lo
informó Claudia Boeris-- para los cuales no conozco una explicación.

--
Fernando

Biblioteca Virtual de la UNR

unread,
Jul 1, 2005, 9:54:57 AM7/1/05
to cat...@googlegroups.com
Estimado Feranando:
Hemos podido solucionar el problema, el error que nos daba era
debido a que teníamos una versión del wxis del 2001. Al utilizar una
versión nueva del mismo el Catalis funciona sin ningún problema...
Desde ya muchas gracias..
Atentamente Dep. Informático de la Biblioteca Virtual UNR.


Fernando Gómez ha escrito:

Fernando Gómez

unread,
Jul 1, 2005, 10:37:26 AM7/1/05
to cat...@googlegroups.com
Ante todo, gracias por informar sobre la solución, y es bueno saber
que tienen Catalis funcionando.

¿Podrías decirnos qué versión de wxis era la que causaba el error?
Número de versión (e.g. 5.0), y fecha de lanzamiento (WXIS release
date, e.g. 20010309). Es importante saber esto para que podamos ir
armando una lista de problemas y soluciones, y así otra gente no
pierde tiempo con el mismo problema.

Pero atención: yo no sabía que hubiese problemas con las viejas
versiones 5.x de wxis. En la UNS estamos usando Catalis con wxis 5.0
del 20010309, ahora en un servidor Linux, y antes en un Windows, y no
hemos tenido el problema que ustedes informaron.

Otro motivo por el cual es importante aclarar esto de las versiones, es
que la licencia de wxis no funciona con cualquier versión, de manera
que hay lugares donde se continúa utilizando un wxis de hace 4 ó 5
años, y no es nuestra intención que Catalis falle en esos casos.

Saludos.

--Fernando

Reply all
Reply to author
Forward
0 new messages