Castle Core Cosole Application

30 views
Skip to first unread message

Maurício Fedatto

unread,
Jul 2, 2018, 11:36:07 AM7/2/18
to Castle Project Users

I need some help getting my Core console app running.

I’ve managed to register my components  properly, but I can’t find how to resolve them. I’m trying to resolve GetAllItems, witch has some arguments in its constructor, also properly registered, but I just can’t manage to get it resolved. I’m using container.Resolve<GetAllItems>() but I’m getting exception “No component supporting the service was found”. I’ve tried with no arguments in construction and same behavior.

 

What am I doing wrong?

 

Maurício Fedatto

mfedatto.com

 

hammett

unread,
Jul 2, 2018, 11:42:44 AM7/2/18
to castle-pro...@googlegroups.com
Could you post your code?
> --
> You received this message because you are subscribed to the Google Groups
> "Castle Project Users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to castle-project-u...@googlegroups.com.
> To post to this group, send email to castle-pro...@googlegroups.com.
> Visit this group at https://groups.google.com/group/castle-project-users.
> For more options, visit https://groups.google.com/d/optout.



--
Cheers,
hammett
http://www.d-collab.com/
http://www.hammettblog.com/

Maurício Fedatto

unread,
Jul 2, 2018, 11:49:50 AM7/2/18
to castle-pro...@googlegroups.com

hammett

unread,
Jul 2, 2018, 12:09:59 PM7/2/18
to castle-pro...@googlegroups.com
Reply all
Reply to author
Forward
0 new messages