[err] Permission denied (publickey,keyboard-interactive).

824 views
Skip to first unread message

jared

unread,
Oct 16, 2007, 5:28:39 PM10/16/07
to Capistrano
I just upgraded to cap 2, and I'm getting the following error when
trying to deploy:

$ cap staging deploy
* executing `staging'
triggering start callbacks for `deploy'
* executing `deploy'
* executing `deploy:update'
** transaction: start
* executing `deploy:update_code'
* executing "svn checkout -q -r392 svn+ssh://myproject.com/repos/
myproject /var/www/apps/dev.myproject.com/releases/20071016185844 &&
(echo 392 > /var/www/apps/dev.myproject.com/releases/20071016185844/
REVISION)"
servers: ["myproject.com"]
[myproject.com] executing command
** [err] Host key verification failed.
** [err] svn: Connection closed unexpectedly
command finished
*** [deploy:update_code] rolling back
* executing "rm -rf /var/www/apps/dev.myproject.com/releases/
20071016185844; true"
servers: ["myproject.com"]
[myproject.com] executing command
command finished
command "svn checkout -q -r392 svn+ssh://myproject.com/repos/
myproject /var/www/apps/dev.myproject.com/releases/20071016185844 &&
(echo 392 > /var/www/apps/dev.myproject.com/releases/20071016185844/
REVISION)" failed on myproject.com

So it seems there's a problem with my ssh login, but

1) I'm not telling it to use an ssh key, it seems like it should be
prompting me for a password, so I tried adding ssh_options[:keys] =
%w(/Users/[myusername]/.ssh/id_rsa), but got the same error. Next I
tried deleting my authorized_keys entry on the remote server, after
which I did get prompted for a password twice, but the same error
comes up.

2) I have no problem logging in to ssh and running the checkout
command from the console

What am I missing?

Thanks.

Jamis Buck

unread,
Oct 16, 2007, 5:30:27 PM10/16/07
to capis...@googlegroups.com
See if adding the following line makes any difference:

default_run_options[:pty] = true

- Jamis

> --~--~---------~--~----~------------~-------~--~----~
> To unsubscribe from this group, send email to capistrano-
> unsub...@googlegroups.com
> For more options, visit this group at http://groups.google.com/
> group/capistrano
> -~----------~----~----~----~------~----~------~--~---
>

jared

unread,
Oct 16, 2007, 9:19:37 PM10/16/07
to Capistrano
Added that line and everything ran fine, thanks a lot for the
response.

Is this something I should add to all my recipes, or can you offer
some wisdom on why this happened/how to avoid it in the future?

Thanks Again!

> smime.p7s
> 3KDownload

Jamis Buck

unread,
Oct 16, 2007, 9:49:03 PM10/16/07
to capis...@googlegroups.com
Prior to 2.1, Capistrano would always allocate a "pseudo-tty" (or
pty) for every command it ran. This allowed commands that did
windowing stuff (e.g., via curses and friends) to query things like
the size of their window and so forth. However, it also meant that
when you ran a command via Capistrano, it would run in an environment
where your .profile (or .bashrc, or whatever) was not automatically
loaded.

With cap 2.1, I removed the auto-allocation of the pty, with the
effect that now people's .profile files will be autoloaded for every
command.

Alas, the side effect is that some commands, in some environments,
will apparently not prompt or run correctly when executed in the
absence of a pty. :( I may need to do a follow-up release soon that
makes the pty allocation the default, and allows you to disable it if
you want.

- Jamis

Reply all
Reply to author
Forward
0 new messages