2 rake db:migrate processes spawns when deploying

13 views
Skip to first unread message

Armin Primadi

unread,
Jul 18, 2017, 4:35:34 AM7/18/17
to Capistrano
Versions:
  • Ruby - 2.2.3
  • Capistrano - 3.4.1
  • Rake - 10.4.1
  • Rails - 4.1.2
Platform:
  • Working on Mac OS X
  • Deploying to Ubuntu (Digital Ocean)
Logs:
  • Please past logs (as completely as possible to a 3rd party pasting service such as pastie.org)
Doing `ps ax | grep rake` give me the following:

 8985 ?        Ss     0:00 bash -c cd /var/deploy/facilgo/releases/20170718050100 && ( export RAILS_ENV="staging" ; /var/deploy/facilgo/rvm1scripts/rvm-auto.sh . bundle exec rake db:migrate )

 8986 ?        S      0:00 bash -c cd /var/deploy/facilgo/releases/20170718050100 && ( export RAILS_ENV="staging" ; /var/deploy/facilgo/rvm1scripts/rvm-auto.sh . bundle exec rake db:migrate )

 8987 ?        Rl     1:29 /var/deploy/facilgo/shared/bundle/ruby/2.2.0/bin/rake db:migrate                                                                  

 9594 pts/4    S+     0:00 grep --color=auto rake


I wonder if this is correct? It seems that these two processes running at the same time causes race condition with the migration.

Lee Hambley

unread,
Jul 18, 2017, 4:43:01 AM7/18/17
to Capistrano
Probably you have more than on DB / Migration server defined and neither/both are flagged "primary".

--
You received this message because you are subscribed to the Google Groups "Capistrano" group.
To unsubscribe from this group and stop receiving emails from it, send an email to capistrano+unsubscribe@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/capistrano/c8488b97-c37f-4209-8820-df6445c4522f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages