Problems starting Camotics in Linux Mint 21

Skip to first unread message


Sep 22, 2022, 12:48:06 PM9/22/22
to CAMotics Users
Hi - I've used Camotics previously in versions of Linux Mint up to 20.3
I recently did a fresh install of Linux Mint 21, and re-installed Camotics.
As someone else here posted, the installation appeared to go OK, but Camotics will not launch.
I installed libqt5websockets5 and libqt5websockets-dev, and also tried to install libV8-dev, but got this response:
Note, selecting 'libnode-dev' instead of 'libv8-dev'
The following additional packages will be installed:
  libnode72 libssl-dev libuv1-dev
Suggested packages:
The following NEW packages will be installed
  libnode-dev libnode72 libssl-dev libuv1-dev

If I try to start Camotics from the terminal, I get the following:
camotics: error while loading shared libraries: cannot open shared object file: No such file or directory

Any suggestions would be welcome - I'm getting lost!

Joseph Coffland

Sep 23, 2022, 8:35:33 AM9/23/22
to CAMotics Users
You need libssl1.1 installed.


Sep 23, 2022, 12:18:45 PM9/23/22
to CAMotics Users
OK - That fixed it - thanks, Joseph.


Sep 23, 2022, 12:24:57 PM9/23/22
to CAMotics Users
Hi, Joseph,
It would perhaps be a help if you could post a list of possible dependencies that need to be installed - I have found references at various places,
and especially when there is a change in the required file, as I noted in my first post on this thread - I wasted a lot of time trying to install libv8-dev, which had changed to libnode-dev, not realising I also needed libssl1.1 - even though my terminal said I was missing - apart from that - a useful tool.
Regards, Keith
Reply all
Reply to author
0 new messages