htnlhelper

21 views
Skip to first unread message

Julienne Ingabire

unread,
Mar 16, 2009, 7:06:10 PM3/16/09
to cakep...@googlegroups.com
bonjour ,
j ai un lien comme ça:
echo $html->link($html->image("delete.gif", array('alt'=>'delete', 'title'=>'delete')),array('controller'=>'posts', 'action'=>'effacer'),null,'voulez vous effacer?!',false);
mais cela ne montre pas le message de confirmation, ça efface directement! pouvez vous me dire ou se trouve l erreur??
merci



Pierre MARTIN

unread,
Mar 17, 2009, 5:31:18 AM3/17/09
to Cakephp-fr
Bonjour,

La forme est ceci : link(string $title, mixed $url = null, array
$htmlAttributes = array(), string $confirmMessage = false, boolean
$escapeTitle = true)
Essayes donc avec le 3ème argument à "array()" au lieu de "null".

Pierre

Mehdi AMINI

unread,
Mar 17, 2009, 5:35:23 AM3/17/09
to cakep...@googlegroups.com
Hello,


> La forme est ceci : link(string $title, mixed $url = null, array
> $htmlAttributes = array(), string $confirmMessage = false, boolean
> $escapeTitle = true)
> Essayes donc avec le 3ème argument à "array()" au lieu de "null".
>

Chez moi ça fonctionne avec null


>
>> mais cela ne montre pas le message de confirmation, ça efface directement!
>> pouvez vous me dire ou se trouve l erreur??
>>

Peux-tu faire un minimum d'effort avant de t'adresser à une liste, comme
regarder le code généré par exemple et nous le transmettre. Nous donner
les différents essai que tu as réalisé, etc.
En l'occurence ce code génère bien un lien avec demande de confirmation
chez moi (cake 1.2)


Mehdi

Julienne Ingabire

unread,
Mar 17, 2009, 8:39:40 AM3/17/09
to cakep...@googlegroups.com
Hello ,
bien sur que j 'ai vraiment tout essayé avant de poster ma question.Je peux aussi comprendre ton énérvement mais au fait  le syntaxe était bon et le lien fonctionne aussi longtemps que je n utilise les accents et co! encore la résolution est donc comme ça:
echo $html->link($html->image("delete.gif", array('alt'=>'delete', 'title'=>'delete')),array('controller'=>'posts', 'action'=>'effacer'),null,'voulez vous effacer?!',false); et ça marche le pb était les caractères spéciaux!!
sorry

2009/3/17 Mehdi AMINI <joke...@gmail.com>
Reply all
Reply to author
Forward
0 new messages