no more present in debian testing, nor in debian sid. any eta for this issue?

72 views
Skip to first unread message

Salvatore Noschese

unread,
Apr 21, 2020, 11:08:53 AM4/21/20
to bup-list
with debian testing, cannot found bup package.
upgrade to sid, now i can found, but issue with some dependecy.

so, i cannot install atm and my kup-backup cannot work as expected (is a new install).

hope can be fixed soone :)

Salvatore Noschese

unread,
Apr 21, 2020, 11:13:18 AM4/21/20
to bup-list
This is apt test:
lupastro@wolfpc:~$ sudo apt install bup

[sudo] password di lupastro:  
Lettura elenco dei pacchetti... Fatto

Generazione albero delle dipendenze        
Lettura informazioni sullo stato... Fatto

Alcuni pacchetti non possono essere installati. Questo può voler dire

che
è stata richiesta una situazione impossibile oppure, se si sta

usando una distribuzione
in sviluppo, che alcuni pacchetti richiesti

non sono ancora stati creati o sono stati rimossi da
Incoming.

Le seguenti informazioni possono aiutare a risolvere la situazione:



I seguenti pacchetti hanno dipendenze non soddisfatte
:

 bup
: Dipende: python-pylibacl ma non è installabile

       
Dipende: python-pyxattr ma non è installabile

       
Raccomanda: bup-doc ma non sta per essere installato

       
Raccomanda: python-fuse ma non è installabile

       
Raccomanda: python-tornado ma non è installabile

E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

lupastro@wolfpc:~$





Greg Troxel

unread,
Apr 21, 2020, 11:57:14 AM4/21/20
to Salvatore Noschese, bup-list
Wrong list. Debian issues should be addressed to some debian place.

You should be able to build bup from sources.

Salvatore Noschese

unread,
Apr 21, 2020, 12:22:04 PM4/21/20
to bup-list


Il giorno martedì 21 aprile 2020 17:57:14 UTC+2, Greg Troxel ha scritto:
Wrong list.  Debian issues should be addressed to some debian place.

You should be able to build bup from sources.

So sorry. For some strange reason i thinked is related. Ty, and sorry again. ill try to compile now ;) 

Salvatore Noschese

unread,
Apr 21, 2020, 12:37:05 PM4/21/20
to bup-list


Il giorno martedì 21 aprile 2020 17:57:14 UTC+2, Greg Troxel ha scritto:

Wrong list.  Debian issues should be addressed to some debian place.

You should be able to build bup from sources.

Edit: tried to install, but i cant.
I seguenti pacchetti hanno dipendenze non soddisfatte:
builddeps:bup : Dipende: python-pylibacl ma non è installabile
                Dipende: python-pyxattr ma non è installabile
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
 

i can found only python3-pylibacl  and python3-pyxattr in my debian. So, sadness, but something is wrong with debian and bup :(

best regards.

Greg Troxel

unread,
Apr 21, 2020, 12:50:49 PM4/21/20
to Salvatore Noschese, bup-list
Not a problem and I was briefer than I should have been, trying to
answer quickly before doing something else.

This list is for bup itself, both development and usage. Various
packaging systems include bup, and as far as I know I'm the only package
maintainer here -- and that's for pkgsrc, not debian.

I have no idea why bup or its dependencies is or isn't in any version of
debian. Packaging is complicated, and there are many possible reasons.
So I'm just trying to point out that only the people that maintain
debian packaging can answer about the status of bup in debian.

Building from source should be pretty easy. Feel free to ask for help
if it isn't, or if the docs are not right. This is the right place for
those questions.


Greg Troxel

unread,
Apr 21, 2020, 12:55:02 PM4/21/20
to Salvatore Noschese, bup-list
Salvatore Noschese <salvu...@gmail.com> writes:

> Il giorno martedì 21 aprile 2020 17:57:14 UTC+2, Greg Troxel ha scritto:
>>
>>
>> Wrong list. Debian issues should be addressed to some debian place.
>>
>> You should be able to build bup from sources.
>>
>
> Edit: tried to install, but i cant.
> I seguenti pacchetti hanno dipendenze non soddisfatte:
> builddeps:bup : Dipende: python-pylibacl ma non è installabile
> Dipende: python-pyxattr ma non è installabile
> E: Impossibile correggere i problemi, ci sono pacchetti danneggiati
> bloccati.

bup is in the process of supporting python 3, but as far as I know has
not yet arrived at it working and being recommended.

builddeps:bup : Dipende: python-pylibacl ma non è installabile
Dipende: python-pyxattr ma non è installabile

You can perhaps disable extended attributes and acls with a configure
switch. I'm really not clear on that.

You can of course start from nothing and build up everything, but that's
a lot of work.

pkgsrc does work on linux, and this may help:
https://pkgsrc.joyent.com/install-on-linux/

but I'm not sure how wide the gulf is from Fedora-ish to Debian-ish.

an article about pkgsrc on linux:
https://opensource.com/article/19/11/pkgsrc-netbsd-linux

Rob Browning

unread,
Apr 25, 2020, 2:36:42 PM4/25/20
to Greg Troxel, Salvatore Noschese, bup-list, Rob...@defaultvalue.org, "Edmonds ...@debian.org
Greg Troxel <g...@lexort.com> writes:

> I have no idea why bup or its dependencies is or isn't in any version of
> debian. Packaging is complicated, and there are many possible reasons.
> So I'm just trying to point out that only the people that maintain
> debian packaging can answer about the status of bup in debian.
>
> Building from source should be pretty easy. Feel free to ask for help
> if it isn't, or if the docs are not right. This is the right place for
> those questions.

[Robert: here's the parent thread:
https://groups.google.com/d/msg/bup-list/QvU-_0oEiFw/fijmkHkuAwAJ ]

I believe that Robert may have been holding bup out of Debian stable as
a quite reasonable accommodation of all our caution in the README, and
if Saalvatore is actually packaging/maintaining kup for Debian, then I
imagine they may want to coordinate.

For what it's worth, I'm somewhat inclined to favor allowing bup into
Debian stable because cautionary statements aside, I think bup has
actually been fairly stable over the years, and perhaps more stable than
a large number of other things that are included in Debian stable.

I also think we generally have, and in the future I'd be inclined to,
provide stable releases for "important problems" (as with the 0.29.x
releases, and the soon to be proposed (I hope) 0.30.1[1]), help with
patch backports when feasible, etc.

[1] Actually working on that right now...

Hope this helps.
--
Rob Browning
rlb @defaultvalue.org and @debian.org
GPG as of 2011-07-10 E6A9 DA3C C9FD 1FF8 C676 D2C4 C0F0 39E9 ED1B 597A
GPG as of 2002-11-03 14DD 432F AE39 534D B592 F9A0 25C8 D377 8C7E 73A4

Rob Browning

unread,
Apr 25, 2020, 5:01:48 PM4/25/20
to Greg Troxel, Salvatore Noschese, bup-list, Robert Edmonds

Greg Troxel <g...@lexort.com> writes:

> I have no idea why bup or its dependencies is or isn't in any version of
> debian. Packaging is complicated, and there are many possible reasons.
> So I'm just trying to point out that only the people that maintain
> debian packaging can answer about the status of bup in debian.
>
> Building from source should be pretty easy. Feel free to ask for help
> if it isn't, or if the docs are not right. This is the right place for
> those questions.

[Resending because I made a complete mess of Rober's address in the
previous version. Robert: here's the parent thread:
Reply all
Reply to author
Forward
0 new messages