Function names are typically lower_case_with_underscores() or mixedCase(). A few important functions were once done in CapWords() style with a leading upper case letter. This can cause confusion with class names, consequently, the recommended style is a leading lowercase letter for function names.
Function names should be lowercase, with words separated by underscores as necessary to improve readability.
mixedCase is allowed only in contexts where that's already the prevailing style (e.g. threading.py), to retain backwards compatibility.
--
You received this message because you are subscribed to the Google Groups "Building Skills Books" group.
To unsubscribe from this group and stop receiving emails from it, send an email to building-skills-...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.