Different versions doing different things...

38 views
Skip to first unread message

Tim Barker

unread,
Mar 24, 2020, 6:52:22 AM3/24/20
to BubbleUPnP
I'm not sure how to start this but I do want to get a degree of consistency across my home network.  Probably best to describe it.

2 main rooms each with a sound system and each sound system attached to a Raspberry Pi, unfortunately of different ages.  2 android devices (1 phones, 1 tablet) for control of said.

Pi-G (my nomenclature) - Pi 3 Model B V1.2
runs    Linux 4.19.93-v7+ #1290 SMP Fri Jan 10 2020
Raspbian (ie Debian)
BubbleUPnPServer  0.9-5_all.deb
gmediarender 0.0.7-git; 0.0.7-git
minidlna 1.2.1
Java
OpenJDK 1.8.0_212
runtime ~8u212-b01-1+rpi1
clientVM 25.212-b01

Pi-H - Pi 2 Model B V1.1
runs    Linux 4.1.19-v7+ #858 SMP Tue Mar 15 2016
Raspbian (ie Debian)
BubbleUPnPServer 0.9-4_.all.deb
gmediarender  0.0.7-git; 2015-11-04_4003616
minidlna  1.0.24
Java
(Oracle) 1.8.0
SE Runtime -b132
VM 25.0-b70

I assume the 2 Android devices all use the same version (kept up-to-date automatically)

Each of the 'media servers' runs gmediarender and minidlna as per many suggested setups around the web.

Pi-H works the way I want it to.  Playlists start at the top and gradually work down to the bottom.  I do get error messages on the Android devices occasionally but they disappear before I get around to remembering how I do a screen shot.  BubbleUPnPServer is set up (via :58050) the same on both Pis.  I use the "openhome" version of the renderer.  Assuming the minidlna 'server' has the files indexed everything works well.  The 'played' time counts up and the 'to go' time counts down.

Using Pi-G  to serve the files doesn't work well even using the same controller.  Playlists only play one tune at a time at best (oh, options are set up the same way from what I can see but from memory these are controlled more by the controlling device (the Android tablet)).  Possible to set up the playlist and choose a library from any device but when you try to play it, it either plays each track individually or you get an error message "Current state of the service prevents invoking that action.  Error reading response message. Can't transform message payload: .org.fourthline.cling.b.a.c: the argument value is invalid.  Invalid number of input or output arguments in XML message, expected 3 but found 0.. (code 501)".

I suspect that it is the OpenJDK that is the problem but it is the same using versions 8, 9 or 11.  (I have all 3 now installed and use 'update-alternatives' to switch between the versions)  I have tried to install the same Oracle version of the SDK and JDK but haven't been able to do so to see whether that is the real problem.

Are there other log files that shows what is going on with the server or controller?  The one I found on the server resides in the same directory as the .jar, .bat and .sh files.  Is there anyway of setting this to go to /var/log?  A whole heap of gobbledegook in it and lots of warnings but nothing that really stands out.  Is it possible to change the loglevel on the .jar file easily? and also some of the other parameters?  Using the :58050 webpage would make some sense although a .conf file on the system would fit better with linux.

I changed the main server to the Pi 2 as it does more than just serve the music files and was starting to get slow, now it is the one that doesn't really work properly.  Should I go back to 0.9-4? and if so how do I download a copy or where do I find it?

Anybody have any idea what might be the problem? or able to help?  

 
 
 
 
 

Bubblesoft

unread,
Mar 24, 2020, 1:26:46 PM3/24/20
to BubbleUPnP
That "Invalid number of input or output arguments in XML message, expected 3 but found 0" points to a broken renderer
Are you sure the versions of gmediarender are identical ?

I really really do no recommend using gmediarender these days: it is old an unmaintained.
There are way better choices. I recommend mpd + upmpdcli. upmpdcli directly implements an OpenHome renderer,
making using BubbleUPnP Server not necessary if you use it just for OpenHome.
As a media server, I recommend using MinimServer (https://minimserver.com) which is free (but not OSS) and excellent for music.
Although if you are happy with minidlna, that's fine.

Adding more logging for BubbleUPnPServer.log.0 will not help but you can send me the file if you wish (bubblesof...@gmail.com).

Tim Barker

unread,
Mar 24, 2020, 9:47:41 PM3/24/20
to BubbleUPnP
Thanks, gives me something to do while we are forced to stay indoors.  My preference is to stay with what I know but if it's broken then I might need to go back to MPD (which I used years ago as a standalone before I became aware of gmediarender/minidlna and BubbleUPnP), the flexibility of the current setup being preferred although I never managed to get internet radio working.  I did have one thing wrong with the first commentary as I hadn't checked while writing the request and that was that the main problem seems to happen between OpenJDK 1.8 and 1.9 concerning the error message I wrote down.  I hadn't realised I had reset the JDK to 1.11 .  If I use 1.8 it plays the stream but the time counters remain fixed and only plays a single track at a time.  Works otherwise even with the error message.  With OpenJDK 1.11 it doesn't work at all so there seems to be something within the java implementation that causes it.  I suspect installing the Oracle version would probably work but haven't yet found a way of getting the same version there given it is an old version, just need to find the package binaries for this version.

On gmediarender the version numbers were straight off the running apps on the 2 machines so it would appear they are the same.  This was my first thought and as you say it is old but until recently worked well, perhaps the interface between Bubble and gmedia is the issue.  I did go back to using a Debian package version rather than a homebuilt one about 12 months ago, I just couldn't get the compiler to work after a debian upgrade.

Time I upgraded the Pi-G to a 4 and renamed the current one to Pi-H, rationalised the software in a big way, thinned out what software is loaded and running and tightened up all round.  Why do I have 2 media servers?  I utilise 2 homes and one is a roving machine between the 2 and the other is fixed here (my residence) and my internal server.

Tim Barker

unread,
Mar 25, 2020, 6:30:30 AM3/25/20
to BubbleUPnP
One thing I didn't add was that I also use the combination of BubbleUPnPServer, gmediarender and minidlna to serve and render images to various devices such as tablets, TVs around the house.  I would assume that is not an option with mpd from what I can see. 

The other comment is that whilst it might be a great combination when it works getting to that point is not going to be as simple as it was the last time I used it, probably 8 years ago.  As in the ways of the World it has become somewhat more complex.

Tim. 

Bubblesoft

unread,
Mar 26, 2020, 8:56:14 AM3/26/20
to BubbleUPnP
Yes mpd + upmpdcli will only work for music. You can have it running alongside your current setup for experimenting. This combo is vastly superior for music.

As for OpenJDK version, not too surprise OpenJDK 11 can be problematic, although the issue you have might be caused by something else.
I'd stick with OpenJDK 8 or Oracle JRE.
Reply all
Reply to author
Forward
0 new messages