brickschema installation error

18 views
Skip to first unread message

fahima rahman

unread,
Mar 21, 2022, 3:08:18 PMMar 21
to Brick User Forum (Unified Building Metadata Schema)
when i am trying to install brickschema i get this error

ERROR: Packages installed from PyPI cannot depend on packages which are not also hosted on PyPI.
dedupe depends on fastcluster@ https://github.com/dmuellner/fastcluster/archive/dbbf09361745c422517095fe783960782f7cc370.zip ; python_version >= "3.10"

i updated python 3.9 to 3.10. Before i was getting error about soft_unicode not found.

is there any solution?

Gabe Fierro

unread,
Apr 1, 2022, 4:22:53 PMApr 1
to Brick User Forum (Unified Building Metadata Schema)
Hi there!

I will look into the dedupe-specific error, but if you install brickschema==0.6.0a6 that should address the issue. 

Best,
Gabe

Reply all
Reply to author
Forward
0 new messages