output does not reflect if it has the same value in the field

11 views
Skip to first unread message

Borgee

unread,
Nov 26, 2022, 11:25:23 PM11/26/22
to Bots Open Source EDI Translator
Hi All
need some advise as to why output / value did not reflect.  see my sample code and the code. 

I use the same variable to for my DTM. however value did not produce in the second DTM. 

CODE:
   issuedate = time.strftime("%Y%m%d")

  #DTM 011
    shipment.put({'BOTSID':'HL'},{'BOTSID':'DTM','DTM01':'011'})
    shipment.put({'BOTSID':'HL'},{'BOTSID':'DTM','DTM02':issuedate})
    
    #DTM 067
    shipment.put({'BOTSID':'HL'},{'BOTSID':'DTM','DTM01':'067'})
    shipment.put({'BOTSID':'HL'},{'BOTSID':'DTM','DTM02':issuedate})

OUTPUT:
      DTM|011|20221127~
       DTM|011|~     <------------------------the issuedate did not output. 


Eppye Bots

unread,
Nov 27, 2022, 5:31:44 PM11/27/22
to bots...@googlegroups.com
please check examples provided in plugins  and documentation.
there is NOT ONE EXAMPLE like this.
so: you have made this up all by yourself!

kind regards, Henk-Jan Ebbers


--
You received this message because you are subscribed to the Google Groups "Bots Open Source EDI Translator" group.
To unsubscribe from this group and stop receiving emails from it, send an email to botsmail+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/botsmail/6f876e93-8a1d-4e47-9015-41edf1166672n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages