OutMessageError: [F50]: Characters not in character-set "cp1250"

28 views
Skip to first unread message

shik...@gmail.com

unread,
May 4, 2021, 8:36:52 AMMay 4
to Bots Open Source EDI Translator
Hello,
the error is: OutMessageError: [F50]: Characters not in character-set "cp1250": nstitut für Rechtsmedizin und|Verkehrsmedizin. 
I have the 'cp-1250' in the output grammer and 'utf-8' for the input. the Adress, where the error is shown is in the adress: Institut für Rechtsmedizin und. when i change the für to fuer, there will be no problem. What i don't understand is, there are other umlaut in other adress cell like 'Universitätsklinikum' , bots has no problem with this. How to solve this? 

regards,
Ke

Henk-Jan Ebbers

unread,
May 4, 2021, 9:01:50 AMMay 4
to bots...@googlegroups.com
the character is not in that characterset.....
it is not a bots problem; it is a characterset problem.


kind regards,
Henk-Jan Ebbers




--
You received this message because you are subscribed to the Google Groups "Bots Open Source EDI Translator" group.
To unsubscribe from this group and stop receiving emails from it, send an email to botsmail+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/botsmail/c09e58aa-c107-46f1-a5dc-5bc97bfb25cdn%40googlegroups.com.

shik...@gmail.com

unread,
Jun 9, 2021, 3:38:33 AMJun 9
to Bots Open Source EDI Translator
Hey Henk-Jan,
do you have any Idea how to solve the charset problem? i have both input and output utf-8 and it still not working? What do you think of a pre-processing? 

regards,
Ke

Eppye Bots

unread,
Jun 9, 2021, 5:19:15 AMJun 9
to 'Chuck Turco' via Bots Open Source EDI Translator
for some reason bots thinks output shoudl be 'cp-1250'
(which is not a default characterset for any editype)
so I would think you put it somewhere in grammar for out-going message.

change it, as you say you expect it to be utf-8.


kind regards, Henk-Jan Ebbers


shik...@gmail.com

unread,
Jul 8, 2021, 3:13:46 AMJul 8
to Bots Open Source EDI Translator
hey Henk-Jan,

i had actually both utf-8 in the grammer for iput and output-file. I don't know where comes this cp-1250..Do you have an idea? 

regards,
Ke

shik...@gmail.com

unread,
Jul 8, 2021, 3:59:51 AMJul 8
to Bots Open Source EDI Translator
oh! that's my mistake. I had another file for the grammer and the names are similar, so i got the wrong file in the translations. thanks! 
Reply all
Reply to author
Forward
0 new messages