VMStartException: VM initialization failed debugger message

4 views
Skip to first unread message

web...@gmail.com

unread,
May 16, 2005, 3:10:35 PM5/16/05
to
Hi,

All of a sudden one day, my debugger for JBuilder 8 stopped working.
When I run a program normally it runs fine. However, when I try to run
the same program, I get the error message below:

com.sun.jdi.connect.VMStartException: VM initialization failed for:
C:\JBuilder8\jdk1.4\bin\javaw -classpath
"C:\FWProjects\COMPONENT_ADMINISTRATOR\classes;C:\FWProjects\LIB_EXCEPTION\LIB_EXCEPTION.jar;C:\FWProjects\LIB_DATA\Data_Server\Data_Server.jar;C:\FWProjects\LIB_OBJECT\LIB_OBJECT.jar;C:\FWProjects\LIB_CONNECTION\Connection_ASA\Connection_ASA.jar;C:\FWProjects\LIB_UTIL\LIB_UTIL.jar;C:\JBuilder8\lib\jbcl.jar;C:\FWProjects\LIB_VISUAL\LIB_VISUAL.jar;C:\JBuilder8\jdk1.4\demo\jfc\Java2D\Java2Demo.jar;C:\JBuilder8\jdk1.4\demo\plugin\jfc\Java2D\Java2Demo.jar;C:\JBuilder8\jdk1.4\jre\lib\charsets.jar;C:\JBuilder8\jdk1.4\jre\lib\ext\dnsns.jar;C:\JBuilder8\jdk1.4\jre\lib\ext\ldapsec.jar;C:\JBuilder8\jdk1.4\jre\lib\ext\localedata.jar;C:\JBuilder8\jdk1.4\jre\lib\ext\sunjce_provider.jar;C:\JBuilder8\jdk1.4\jre\lib\im\indicim.jar;C:\JBuilder8\jdk1.4\jre\lib\jaws.jar;C:\JBuilder8\jdk1.4\jre\lib\jce.jar;C:\JBuilder8\jdk1.4\jre\lib\jsse.jar;C:\JBuilder8\jdk1.4\jre\lib\rt.jar;C:\JBuilder8\jdk1.4\jre\lib\sunrsasign.jar;C:\JBuilder8\jdk1.4\lib\dt.jar;C:\JBuilder8\jdk1.4\lib\htmlconverter.jar;C:\JBuilder8\jdk1.4\lib\tools.jar"
-Xdebug -Xnoagent -Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,address=dev:1881,suspend=y
fw.ComponentAdministrator
Transport dt_socket failed to initialize, rc = 509.

Does anyone know what's happening here? I've searched the web and
haven't found anything helpful. Any program I try to debug gives the
same error message. I've tried reinstalling JBuilder hoping to reset
settings, but that didn't work.

Help please! :)

webbsk

unread,
May 16, 2005, 5:07:01 PM5/16/05
to
BTW:

1) I have uninstalled my firewall and I'm running Windows 2000, so
there's no built-in firewall.
2) The ports it fails on are different every time so there's no point
trying to allow ports anyways because the port range is anywhere from
1000-5000.
3) I've tried uninstalling all the java SDKs on my computer.
4) I've renamed all the files on my computer named dt_socket.dll
5) There is no other spyware or virus protection on the computer to
block access.
6) I have disabled the ethernet connection to my LAN.

None of these solutions have worked, so just to save any helpers some
time...

Reply all
Reply to author
Forward
0 new messages