Bonsai install issue

168 views
Skip to first unread message

sbis

unread,
Jun 26, 2021, 5:24:56 PM6/26/21
to Bonsai Users
Hello,

I keep getting an error when I try to install Bonsai (picture attached). I had the software installed on this computer before, but because of some issues we had to wipe the memory. I was using Windows 10, but now the computer has Windows 10 Enterprise. I've tried installing Bonsai on another computer and it worked fine. I've tried with both the .exe and .zip files. Could you please help me resolve this? I have attached a log file with this post. Please let me know if you need any other information.

Regards,
Srijani
Bonsai_20210626162201.log
Bonsai_setup failed.PNG

Gonçalo Lopes

unread,
Jun 27, 2021, 12:45:10 PM6/27/21
to sbis, Bonsai Users
We've had similar reports very recently (starting last week). It seems this boils down to the installer of the .NET Framework 4.7.2 which ships with the Bonsai bootstrapper. It's really not clear what is broken at this point, but if you have this issue, installing .NET manually seems to work: Download .NET Framework 4.7.2 | Free official downloads (microsoft.com)

After running this, try installing Bonsai again (it might ask you to restart the computer first).

Hope this helps.

--
You received this message because you are subscribed to the Google Groups "Bonsai Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to bonsai-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/bonsai-users/4a1a2110-afd1-4461-9e67-aef639b8ac34n%40googlegroups.com.

sbis

unread,
Jun 28, 2021, 3:23:54 PM6/28/21
to Bonsai Users
Many thanks for your suggestion! Unfortunately that did not work. When I try to manually download the .NET Framework 4.7.2 I get this error: The .NET Framework 4.72 is not supported on this operating system.

I looked up possible fixes for this error here (picture attached) but as per the website, our OS is not Windows 7, and it does follow the system requirements (as shown in second picture attached).

I am at a loss as to what the problem may be, and I would greatly appreciate any help I can get! Thank you!
.NET not supported on this OS.JPG
System information.PNG

sbis

unread,
Jun 29, 2021, 7:57:58 PM6/29/21
to Bonsai Users
Update: It's fixed! It was an internal network issue that was stopping Windows updates from installing, sorry.

Thank you for your help!
Reply all
Reply to author
Forward
0 new messages