Another error when stopping daemons.

26 views
Skip to first unread message

Tim Uckun

unread,
Sep 12, 2010, 4:12:13 AM9/12/10
to bluep...@googlegroups.com
This is strange one.

./daemons stop
Received error from server:
#<NoMethodError: undefined method `zero?' for nil:NilClass>
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/process.rb:266:in
`stop_process'
(eval):9:in `join'
(eval):9:in `stop'
(eval):9:in `each'
(eval):9:in `stop'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:72:in
`send'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:72:in
`send_to_process_or_group'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:71:in
`collect'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:71:in
`send_to_process_or_group'
(eval):2:in `stop'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:95:in
`send'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:95:in
`start_listener'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:35:in
`synchronize'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:35:in
`mutex'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:95:in
`start_listener'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:90:in
`loop'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:90:in
`start_listener'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:89:in
`initialize'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:89:in
`new'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:89:in
`start_listener'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:128:in
`start_server'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/application.rb:40:in
`load'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bluepill-0.0.42/lib/bluepill/dsl.rb:153:in
`application'
/home/momentum/app/releases/20100908235822/lib/worker/config/bluepill.rb:8


The line eight is of course. Bluepill.application("MomentumDaemons",
:log_file => bluepill_log, :base_dir => CONFIG.daemons.pid_dir) do
|app|

Vladimir Rybas

unread,
May 27, 2012, 7:56:14 AM5/27/12
to bluep...@googlegroups.com
Just got this now on server. Any solution yet?
Reply all
Reply to author
Forward
0 new messages