Errors on Install .. any suggestion please?

1143 views
Skip to first unread message

PESTLEWeb England

unread,
Mar 28, 2013, 12:30:07 PM3/28/13
to blogofil...@googlegroups.com
I ran the install for Blogofile as show on the webpage and got these response. Note the errors hlighted in red in several places - followed by the fatel error at the end. Any suggestions please?

rob@Ubuntu-Dell-XPS420:/$ sudo easy_install Blogofile
Searching for Blogofile
Reading http://pypi.python.org/simple/Blogofile/
Reading http://www.blogofile.com
Best match: Blogofile 0.8b1
Downloading http://pypi.python.org/packages/source/B/Blogofile/Blogofile-0.8b1.tar.gz#md5=3c9de52b0cf85542bfc95b1e49cee2ca
Processing Blogofile-0.8b1.tar.gz
Running Blogofile-0.8b1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-SJyepX/Blogofile-0.8b1/egg-dist-tmp-BRzzBL
Adding Blogofile 0.8b1 to easy-install.pth file
Installing blogofile script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg
Processing dependencies for Blogofile
Searching for Unidecode==0.04.9
Reading http://pypi.python.org/simple/Unidecode/
Reading http://code.zemanta.com/tsolc/unidecode/
Best match: Unidecode 0.04.9
Downloading http://pypi.python.org/packages/source/U/Unidecode/Unidecode-0.04.9.tar.gz#md5=c156f2cf31dd186532f8b993629b5b91
Processing Unidecode-0.04.9.tar.gz
Running Unidecode-0.04.9/setup.py -q bdist_egg --dist-dir /tmp/easy_install-8lO1hE/Unidecode-0.04.9/egg-dist-tmp-nlhrDM
zip_safe flag not set; analyzing archive contents...
Adding Unidecode 0.04.9 to easy-install.pth file

Installed /usr/local/lib/python2.7/dist-packages/Unidecode-0.04.9-py2.7.egg
Searching for textile==2.1.4
Reading http://pypi.python.org/simple/textile/
Reading http://loopcore.com/python-textile/
Download error on http://loopcore.com/python-textile/: timed out -- Some packages may not be found!
Reading http://loopcore.com/python-textile/
Download error on http://loopcore.com/python-textile/: timed out -- Some packages may not be found!
Reading http://dealmeida.net/projects/textile/
Reading http://loopcore.com/python-textile/
Download error on http://loopcore.com/python-textile/: timed out -- Some packages may not be found!
Reading http://loopcore.com/python-textile/
Download error on http://loopcore.com/python-textile/: timed out -- Some packages may not be found!
Reading http://loopcore.com/python-textile/
Download error on http://loopcore.com/python-textile/: timed out -- Some packages may not be found!
Reading http://github.com/chrisdrackett/python-textile
Best match: textile 2.1.4
Downloading http://pypi.python.org/packages/source/t/textile/textile-2.1.4.tar.gz#md5=05ebee989379d5930e779f85d276abed
Processing textile-2.1.4.tar.gz
Running textile-2.1.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-ricp5V/textile-2.1.4/egg-dist-tmp-O2tJk5
zip_safe flag not set; analyzing archive contents...
Adding textile 2.1.4 to easy-install.pth file

Installed /usr/local/lib/python2.7/dist-packages/textile-2.1.4-py2.7.egg
Searching for six==1.1.0
Reading http://pypi.python.org/simple/six/
Best match: six 1.1.0
Downloading http://pypi.python.org/packages/source/s/six/six-1.1.0.tar.gz#md5=9e8099b57cd27493a6988e9c9b313e23
Processing six-1.1.0.tar.gz
Running six-1.1.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-_7Qz2J/six-1.1.0/egg-dist-tmp-YQzqUn
zip_safe flag not set; analyzing archive contents...
Adding six 1.1.0 to easy-install.pth file

Installed /usr/local/lib/python2.7/dist-packages/six-1.1.0-py2.7.egg
Searching for pytz==2012d
Reading http://pypi.python.org/simple/pytz/
Reading http://pytz.sourceforge.net
Reading http://sourceforge.net/project/showfiles.php?group_id=79122
Reading http://www.stuartbishop.net/Software/pytz
Reading http://sourceforge.net/projects/pytz/
Best match: pytz 2012d
Downloading http://pypi.python.org/packages/2.7/p/pytz/pytz-2012d-py2.7.egg#md5=e6f9219ae6eff242f13c6700413df69e
Processing pytz-2012d-py2.7.egg
creating /usr/local/lib/python2.7/dist-packages/pytz-2012d-py2.7.egg
Extracting pytz-2012d-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Adding pytz 2012d to easy-install.pth file

Installed /usr/local/lib/python2.7/dist-packages/pytz-2012d-py2.7.egg
Searching for docutils==0.9.1
Reading http://pypi.python.org/simple/docutils/
Reading http://docutils.sourceforge.net/
Reading http://sourceforge.net/projects/docutils/files/docutils/0.8.1/docutils-0.8.1.tar.gz/download
Reading http://sourceforge.net/projects/docutils/files/docutils/0.9.1/docutils-0.9.1.tar.gz/download
Reading http://sourceforge.net/projects/docutils/files/docutils/0.10/docutils-0.10.tar.gz/download
Reading http://sourceforge.net/projects/docutils/files/docutils/0.9/docutils-0.9.tar.gz/download
Best match: docutils 0.9.1
Downloading http://pypi.python.org/packages/source/d/docutils/docutils-0.9.1.tar.gz#md5=b0d5cd5298fedf9c62f5fd364a274d56
Processing docutils-0.9.1.tar.gz
Running docutils-0.9.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-32Ge5Q/docutils-0.9.1/egg-dist-tmp-AusucA
warning: no files found matching 'MANIFEST'
warning: no files found matching '*' under directory 'extras'
warning: no previously-included files matching '.cvsignore' found under directory '*'
warning: no previously-included files matching '*.pyc' found under directory '*'
warning: no previously-included files matching '*~' found under directory '*'
warning: no previously-included files matching '.DS_Store' found under directory '*'

zip_safe flag not set; analyzing archive contents...
docutils.parsers.rst.directives.misc: module references __file__
docutils.writers.pep_html.__init__: module references __file__
docutils.writers.odf_odt.__init__: module references __file__
docutils.writers.html4css1.__init__: module references __file__
docutils.writers.latex2e.__init__: module references __file__
docutils.writers.s5_html.__init__: module references __file__
Adding docutils 0.9.1 to easy-install.pth file
Installing rst2odt_prepstyles.py script to /usr/local/bin
Installing rst2xml.py script to /usr/local/bin
Installing rst2man.py script to /usr/local/bin
Installing rst2xetex.py script to /usr/local/bin
Installing rst2latex.py script to /usr/local/bin
Installing rst2odt.py script to /usr/local/bin
Installing rst2s5.py script to /usr/local/bin
Installing rst2html.py script to /usr/local/bin
Installing rstpep2html.py script to /usr/local/bin
Installing rst2pseudoxml.py script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/docutils-0.9.1-py2.7.egg
Searching for Pygments==1.5
Reading http://pypi.python.org/simple/Pygments/
Reading http://pygments.org/
Reading http://pygments.pocoo.org/
Best match: Pygments 1.5
Downloading http://pypi.python.org/packages/2.7/P/Pygments/Pygments-1.5-py2.7.egg#md5=8ea02c2eafb2580336b7637be629f7ce
Processing Pygments-1.5-py2.7.egg
creating /usr/local/lib/python2.7/dist-packages/Pygments-1.5-py2.7.egg
Extracting Pygments-1.5-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Adding Pygments 1.5 to easy-install.pth file
Installing pygmentize script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/Pygments-1.5-py2.7.egg
Searching for PyYAML==3.10
Reading http://pypi.python.org/simple/PyYAML/
Reading http://pyyaml.org/wiki/PyYAML
Best match: PyYAML 3.10
Downloading http://pyyaml.org/download/pyyaml/PyYAML-3.10.zip
Processing PyYAML-3.10.zip
Running PyYAML-3.10/setup.py -q bdist_egg --dist-dir /tmp/easy_install-2qy67N/PyYAML-3.10/egg-dist-tmp-VIOjz7
ext/_yaml.c:4:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: Setup script exited with error: command 'gcc' failed with exit status 1




Sean Davis

unread,
Mar 28, 2013, 12:55:22 PM3/28/13
to blogofil...@googlegroups.com
Just a guess, but it looks like you don't have the python headers installed.  You might need to install python-dev (or whatever the package that contains python.h is called on ubuntu).

Sean



--
You received this message because you are subscribed to the Google Groups "blogofile-discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to blogofile-disc...@googlegroups.com.
To post to this group, send email to blogofil...@googlegroups.com.
Visit this group at http://groups.google.com/group/blogofile-discuss?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

Doug Latornell

unread,
Mar 28, 2013, 12:55:58 PM3/28/13
to blogofil...@googlegroups.com
You can safely ignore the errors and warnings in the textile and docutils sections. The former look like easy_install bouncing off a site or page that no longer exists, but it eventually found the textile tarball. The latter are build process artifacts for excluding files that might exist on developers machines that don't belong in the distribution package.

The error from PyYAML indicates that you don't have the Python header files installed on your system. I don't recall the exact package name on Ubuntu, but it's probably something like python-dev. You should be able to install it via the Ubuntu package manager, or via sudo apt-get.

You might also want to consider working from the versions of blogofile and blogofile_blog on github as there have been a number of important updates done there since the 0.8b1 release that easy_install is fetching for you. See http://docs.blogofile.com/en/latest/developers.html#fordevelopers-section


PESTLEWeb England

unread,
Mar 28, 2013, 2:57:24 PM3/28/13
to blogofil...@googlegroups.com
Sean, Doug,

Thank you for the fast response. As suggested I ran ..

sudo apt-get install python2.7-dev


After which everything seemed to work ok.

I will have a look at updating from the latest version on github as suggested by Doug.

Thank you

Rob

Sean Davis

unread,
Mar 28, 2013, 3:07:59 PM3/28/13
to blogofil...@googlegroups.com
In case it isn't obvious (and I hope I am not making any typos):

git clone https://github.com/EnigmaCurry/blogofile.git
cd blogofile
python setup.py install

Sean




> Thank you
>
> Rob

PESTLEWeb England

unread,
Mar 30, 2013, 2:24:39 AM3/30/13
to blogofil...@googlegroups.com
Sean,

I followed the instructions to instal the latest version - the instal seemed to go ok (although I did need to 'sudo' the 'python setup.pw install'.

However, blogofile is now not working... I got:

rob@Ubuntu-Dell-XPS420:~/iwhblog/iwhblog$ blogofile serve 8080 iwhblog
Traceback (most recent call last):
  File "/usr/local/bin/blogofile", line 9, in <module>
    load_entry_point('Blogofile==0.8b1', 'console_scripts', 'blogofile')()
  File "/usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg/blogofile/main.py", line 58, in main
    args.func(args)
  File "/usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg/blogofile/main.py", line 418, in do_serve
    bfserver = server.Server(args.PORT, args.IP_ADDR)
  File "/usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg/blogofile/server.py", line 38, in __init__
    self.httpd = ServerClass(server_address, HandlerClass)
  File "/usr/lib/python2.7/SocketServer.py", line 408, in __init__
    self.server_bind()
  File "/usr/lib/python2.7/SocketServer.py", line 419, in server_bind
    self.socket.bind(self.server_address)
  File "/usr/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
socket.gaierror: [Errno -5] No address associated with hostname

Then, looking at the last line I wondered if the port number 8080 had been confused in some way so went with ..

rob@Ubuntu-Dell-XPS420:~/iwhblog/iwhblog$ blogofile serve iwhblog
Traceback (most recent call last):
  File "/usr/local/bin/blogofile", line 9, in <module>
    load_entry_point('Blogofile==0.8b1', 'console_scripts', 'blogofile')()
  File "/usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg/blogofile/main.py", line 58, in main
    args.func(args)
  File "/usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg/blogofile/main.py", line 418, in do_serve
    bfserver = server.Server(args.PORT, args.IP_ADDR)
  File "/usr/local/lib/python2.7/dist-packages/Blogofile-0.8b1-py2.7.egg/blogofile/server.py", line 27, in __init__
    self.port = int(port)
ValueError: invalid literal for int() with base 10: 'iwhblog'

Which made me think I had it right the first time.

By the way - the few experiments I did with the previous, working version looked great! I have also looked at a few examples on the web and people seem to be making good use of blogofile.

Rob



Doug Latornell

unread,
Mar 30, 2013, 1:20:25 PM3/30/13
to blogofil...@googlegroups.com
If ~/iwhblog/iwhblog is the directory that you created your site in with blogofile init, and you have built the site with blogofile build, then blogofile serve (without arguments) should start a local server to let you view the site on http://localhost:8080/ or, equivalently, http://127.0.0.1:8080/

All of the blogofile commands explain their usage via the --help option; e.g. blogofile serve --help

The first command you tried is telling the serve to use port 8080 and IP address iwhblog and the error is telling you that there is no IP address associated with iwhblog. In the second command you are trying to use the string iwhblog as the port number.


PESTLEWeb England

unread,
Mar 31, 2013, 3:05:22 AM3/31/13
to blogofil...@googlegroups.com
Doug,

Thank you. It worked first time.

I had noted those commands when running the earlier version and thought they had worked - but either I noted it wrong, or something has changed I guess.

Anyhow - it is working now and I am looking forward to giving the tool a proper run.

Regards

Rob

Reply all
Reply to author
Forward
0 new messages