QS alpha testing - b55a1

17 views
Skip to first unread message

Patrick

unread,
Jun 22, 2008, 5:40:49 AM6/22/08
to Blacktree: Quicksilver
This is an alpha release which has been worked on by tiennou.
The version number is b55 which happens to be the same as Ankur's
cleaned-up QS version, but note this is NOT the same build. Hopefully
this will be fixed in a later version.

This topic is for reporting any bugs encountered with tiennou's build
only.
Please note that this is only a bug fix version, the creator of
Quicksilver (Alcor) is working on a complete re-write of the
frameworks of Quicksilver and should hopefully release it soon ;)



Bugs / things I've found so far. (most of these are present in the
current QS build)

The 'Hold CMD-Q to quit' dialogue sometimes doesn't show up when
you're trying to quit after invoking QS.
It always shows up if you're in the preferences, but not if you're
just looking at the 2-pane interface. Also, when it does appear it's
behind the 2-pane interface window.

version number (already mentioned) - it's confusing!

Invoking preferences (CMD - ,) when it's already active brings up the
preferences pane but switches the view back to the 'preferences' tab.
Annoying if you've just been looking at triggers or plugins tab and
want to go straight back to them,

Keep up the goo work tiennou :D

Howard Melman

unread,
Jun 22, 2008, 11:21:38 AM6/22/08
to blacktree-...@googlegroups.com

On Jun 22, 2008, at 5:40 AM, Patrick wrote:

> Invoking preferences (CMD - ,) when it's already active brings up the
> preferences pane but switches the view back to the 'preferences' tab.
> Annoying if you've just been looking at triggers or plugins tab and
> want to go straight back to them,

Note, I don't think this is a bug.
cmd-, brings up prefs
cmd-; brings up catalog
cmd-' brings up triggers
cmd-" brings up plugins

Howard

nontoppo

unread,
Jun 22, 2008, 12:38:21 PM6/22/08
to Blacktree: Quicksilver
The file tagging plugin causes repeatable crashes at startup (as it
did to ankurs build IIRC). Crash logs are available if needed.

How should quicklook support work? Neither CMD+Y nor space trigger
quicklook.

nontoppo

unread,
Jun 22, 2008, 12:50:14 PM6/22/08
to Blacktree: Quicksilver
> How should quicklook support work? Neither CMD+Y nor space trigger
> quicklook.

Ah, quicklook displays within the pane itself. Neat, still I'd like to
⌘Y to get a larger version...

Reveal is inconsistently broken for me (doesn't work in ~/Library/Logs/
CrashReporter for example); still works in B54.

Patrick

unread,
Jun 22, 2008, 5:20:01 PM6/22/08
to Blacktree: Quicksilver
Is the 'play' action working for other people?
go: iTunes -> browse "whatever" -> -> select a song and then tab and
enter the action 'play'

Nothing happens when I try. Works in ankur's build, but not in this
one :(

Also, another bug that's been around a while: if you drag an item into
a folder showing up in QS's first pane and you're replacing a file,
the 'stop / smart replace / don't replace / replace' box pops up then
disappears, you have to re-invoke QS for it to pop up again.

Patrick

unread,
Jun 22, 2008, 5:21:23 PM6/22/08
to Blacktree: Quicksilver
Edit: just seen Howard's comment. I didn't realise that, I guess it's
not a bug then. ;)

tiennou

unread,
Jun 23, 2008, 5:12:46 PM6/23/08
to Blacktree: Quicksilver
@Patrick: Could you file issues on http://code.google.com/p/blacktree-quicksilver/issues/list
for the 'hold cmd-q' thing, the 'itunes don't play' thing ?
And sorry for the confusion on the ß55 thing, I didn't notice ankur
used it too. It's not too much of a problem, because if Ankur commited
his lastest code, ß55a1 is built from it too.

@nontoppo: I'll take a look at Cmd-Y, but my main goal here is
tackling as much bugs as I can, not introducing more of them ;-).
Thanks for the suggestion, and please report it on the issue tracker.
And about the file-tagging plugin, I'm working on it atm.

nontoppo

unread,
Jun 24, 2008, 12:10:00 AM6/24/08
to Blacktree: Quicksilver
> @nontoppo: I'll take a look at Cmd-Y, but my main goal here is
> tackling as much bugs as I can, not introducing more of them ;-).

I'll take the squelching sound of bug crushing over the clink of new
features any day ;-)

> Thanks for the suggestion, and please report it on the issue tracker.
> And about the file-tagging plugin, I'm working on it atm.

Great news. Are you using the issue tracker to guide your bug fixing?
I'll post a seperate thread on what we can do to help with bug fixing.

yelly

unread,
Jun 24, 2008, 10:43:20 AM6/24/08
to Blacktree: Quicksilver
Well, I've just installed installed the alpha release, and although it
seems snappier than the old version, I am having a rather annoying
problem, the menu item is gone! I've tried toggling the preference,
relaunching QS, the works, and nothing helps.
Anyone else experiencing this?

Patrick

unread,
Jun 24, 2008, 12:20:42 PM6/24/08
to Blacktree: Quicksilver
It works for me. Toggling the checkbox makes the icon appear, then
disappear. Not sure what the problem is for you :(

Graham Ashton

unread,
Jun 25, 2008, 12:03:29 AM6/25/08
to Blacktree: Quicksilver
On Jun 24, 5:20 pm, Patrick <robertson.patr...@gmail.com> wrote:
> It works for me. Toggling the checkbox makes the icon appear, then
> disappear. Not sure what the problem is for you :(

Menu item is also present for me.

I'm chuffed to bits with this new build, and have returned to using QS
after several months of using Butler.

QS used to crash on me within minutes of being launched. I've been
using this new build now (with the same setup) for a few days without
a single crash.

tiennou - Thank you!

Jono

unread,
Jun 25, 2008, 7:03:20 AM6/25/08
to Blacktree: Quicksilver
Great to see more people working on Quicksilver. Thanks tiennou!

On Jun 23, 10:12 pm, tiennou <tienn...@gmail.com> wrote:
> And sorry for the confusion on the ß55 thing, I didn't notice ankur
> used it too. It's not too much of a problem, because if Ankur commited
> his lastest code, ß55a1 is built from it too.

Does that mean you've taken Ankur's build & have continued to work on
that version? Or did you take the original (Alcor's) build & work on
that from scratch?

Etienne Samson

unread,
Jun 25, 2008, 9:39:54 AM6/25/08
to blacktree-...@googlegroups.com

Le 25 juin 08 à 13:03, Jono a écrit :

> Does that mean you've taken Ankur's build & have continued to work on
> that version? Or did you take the original (Alcor's) build & work on
> that from scratch?

Yes, given we both made releases from the subversion repository, so if
he has no commits pending, the code is the one from his ß55 plus the
things I changed.

I'm repackaged a ß56a1 release and I'm uploading it. Things I fixed :
Trigger scoping. (In fact there were no more notifications sent when
the active application changed. Trigger Scoping was affected by this
bug, but I can also see some other places were the notification was
expected (e.g. Proxy objects)).

And I'm reading my next TODO from the issue tracker, so please use it
for reporting bugs you know about but aren't tracked there.

tiennou

yelly

unread,
Jun 25, 2008, 12:02:00 PM6/25/08
to Blacktree: Quicksilver
OK, I've solved the menu icon problem by doing a clean install, but
now I'm facing and even bigger problem. The first time it worked fine,
but now, after I added a few triggers (I think that's what caused
it...), every time I click on the triggers pref pane icon a get a
blank pane and it seems to load forever, and in the console I get:
"Quicksilver[1884] *** -[NSScreen deviceName]: unrecognized selector
sent to instance 0x85e2a0"
What to do?

yelly

unread,
Jun 25, 2008, 12:13:08 PM6/25/08
to Blacktree: Quicksilver
I've tried again and noticed that what causes this is trying to add
mouse triggers, which crashes QS as well

nontoppo

unread,
Jun 25, 2008, 1:09:02 PM6/25/08
to Blacktree: Quicksilver
Wow, scopes are finally working, this is brilliant. Thank you
Etienne!!!

nitpick: Build still says it is B55 though...

Jono

unread,
Jun 25, 2008, 1:17:26 PM6/25/08
to Blacktree: Quicksilver
On Jun 25, 2:39 pm, Etienne Samson <tienn...@gmail.com> wrote:
> Yes, given we both made releases from the subversion repository, so if  
> he has no commits pending, the code is the one from his ß55 plus the  
> things I changed.


Cool, thanks for the info tiennou :)

One last thing... (sorry for my ignorance here, but) where is a link
to download this version?

Etienne Samson

unread,
Jun 25, 2008, 1:24:45 PM6/25/08
to blacktree-...@googlegroups.com
You can get the current "alphas" here : http://code.google.com/p/blacktree-alchemy/downloads/list

I'll update it from time to time, posting a message in this thread
when I do.

tiennou


yelly

unread,
Jun 25, 2008, 1:28:43 PM6/25/08
to Blacktree: Quicksilver
Couldn't you get the built in updates check to find your releases?

Patrick

unread,
Jun 25, 2008, 1:51:45 PM6/25/08
to Blacktree: Quicksilver
I'm still being told that I'm using b55?
Is it the svn/ branches/ B5X/ Quicksilver/ PropertyLists/
Quicksilver-Info.plist file that needs updating? I'd do it if I had
access ;)

Etienne Samson

unread,
Jun 25, 2008, 1:53:45 PM6/25/08
to blacktree-...@googlegroups.com
Le 25 juin 08 à 19:51, Patrick a écrit :

>
> I'm still being told that I'm using b55?
> Is it the svn/ branches/ B5X/ Quicksilver/ PropertyLists/
> Quicksilver-Info.plist file that needs updating? I'd do it if I had
> access ;)


Yes, I forgot changing the Info.plist for the b55a1 release. But
starting with b65a1 I'll try not to forget again ;-) .

tiennou


Howard Melman

unread,
Jun 25, 2008, 2:25:31 PM6/25/08
to blacktree-...@googlegroups.com
Just downloaded this to try. Seems a little zippier and uses slightly
less memory. In about 10 minutes of usage I found...

The version number says B55 (3814)

The menubar icon (at the top right of the screen) doesn't appear. I
checked that the preference was still set correctly and unchecked and
checked it.

Not all checked and scanned catalog sources show the number of items
in them. Particularly under the "Quicksilver" set. If I select one
and click the rescan button the number appears.

At least one address book contact that had an image didn't display the
image in Bezel. I think the old version of QS did this sometimes too.

If I delete a plugin it stays in the list until I do a manual rescan.

The ⌘ column under triggers is fixed width and some some extra glyph
that looks like the left half of a H following the hotkey icon.

My only mouse trigger (and my most used trigger) doesn't work. It
does Hide Current Application and is set to activate on mouse entering
the lower left corner. When I checked it wasn't configured that way
and when I set it to be that QS crashed.

At this point I went back to the old version.

Howard

Etienne Samson

unread,
Jun 25, 2008, 3:10:19 PM6/25/08
to blacktree-...@googlegroups.com

Le 25 juin 08 à 20:25, Howard Melman a écrit :

> Just downloaded this to try. Seems a little zippier and uses
> slightly less memory. In about 10 minutes of usage I found...
>
> The version number says B55 (3814)

My fault, uploaded my old archive ;-). I'm reuploading a2 right now.

> The menubar icon (at the top right of the screen) doesn't appear. I
> checked that the preference was still set correctly and unchecked
> and checked it.

This one is posing me problems, as I can see it working here, but some
people have reported that it fails. I'm suspecting something in QS's
Application Support folder, but I haven't been able to reproduce...

> Not all checked and scanned catalog sources show the number of items
> in them. Particularly under the "Quicksilver" set. If I select one
> and click the rescan button the number appears.

I have checked on a fresh install (after removing App Support & Caches
folder) that this works correctly. Again, I'm suspecting an upgrade
issue...

> At least one address book contact that had an image didn't display
> the image in Bezel. I think the old version of QS did this
> sometimes too.

I checked and it didn't have any problem displaying images. Maybe it's
an exotic format ? More info would be fine ;-).

> If I delete a plugin it stays in the list until I do a manual rescan.

> The ⌘ column under triggers is fixed width and some some extra
> glyph that looks like the left half of a H following the hotkey icon.

Fixed in the branch.

> My only mouse trigger (and my most used trigger) doesn't work. It
> does Hide Current Application and is set to activate on mouse
> entering the lower left corner. When I checked it wasn't configured
> that way and when I set it to be that QS crashed.

I don't have the source to the Mouse Triggers module (which handles
this stuff), but I would be interested in the issue report anyway.

If you have some time, could you file those concerns as issues (namely
Bezel not showing some images, and the plugin "uninstalled" doesn't
refresh list).

tiennou


Howard Melman

unread,
Jun 25, 2008, 4:10:49 PM6/25/08
to blacktree-...@googlegroups.com
On Jun 25, 2008, at 3:10 PM, Etienne Samson wrote:

> Le 25 juin 08 à 20:25, Howard Melman a écrit :
>
>> Just downloaded this to try. Seems a little zippier and uses
>> slightly less memory. In about 10 minutes of usage I found...
>>
>> The version number says B55 (3814)
>
> My fault, uploaded my old archive ;-). I'm reuploading a2 right now.

Good, now says B56 (3820).

>> The menubar icon (at the top right of the screen) doesn't appear. I
>> checked that the preference was still set correctly and unchecked
>> and checked it.
>
> This one is posing me problems, as I can see it working here, but
> some people have reported that it fails. I'm suspecting something in
> QS's Application Support folder, but I haven't been able to
> reproduce...

Still happens, let me know if there's info I can send you to help you
debug.

>> Not all checked and scanned catalog sources show the number of
>> items in them. Particularly under the "Quicksilver" set. If I
>> select one and click the rescan button the number appears.
>
> I have checked on a fresh install (after removing App Support &
> Caches folder) that this works correctly. Again, I'm suspecting an
> upgrade issue...

Seems to work now.

>> At least one address book contact that had an image didn't display
>> the image in Bezel. I think the old version of QS did this
>> sometimes too.
>
> I checked and it didn't have any problem displaying images. Maybe
> it's an exotic format ? More info would be fine ;-).

My formats are all jpegs. Seems to be working better w/ 3820. I'll
keep looking and see if it recurs. FYI, with the last one I tried, I
looked up my friend greg, saw no image in the bezel, did show contact
and Address Book opened (it was already running) and I saw gregs
contact including image. When brought him up again in QS the pic was
in the bezel.

>> If I delete a plugin it stays in the list until I do a manual rescan.
>
>> The ⌘ column under triggers is fixed width and some some extra
>> glyph that looks like the left half of a H following the hotkey icon.
>
> Fixed in the branch.

Still see it in 3820. Though I think that what you're saying, fixed
in the next release.

>> My only mouse trigger (and my most used trigger) doesn't work. It
>> does Hide Current Application and is set to activate on mouse
>> entering the lower left corner. When I checked it wasn't
>> configured that way and when I set it to be that QS crashed.
>
> I don't have the source to the Mouse Triggers module (which handles
> this stuff), but I would be interested in the issue report anyway.

Still fails, which makes this version difficult for me to use.

> If you have some time, could you file those concerns as issues
> (namely Bezel not showing some images, and the plugin "uninstalled"
> doesn't refresh list).

Will do

Howard

Etienne Samson

unread,
Jun 25, 2008, 4:48:41 PM6/25/08
to blacktree-...@googlegroups.com
>>> The menubar icon (at the top right of the screen) doesn't appear.
>>> I checked that the preference was still set correctly and
>>> unchecked and checked it.
>>
>> This one is posing me problems, as I can see it working here, but
>> some people have reported that it fails. I'm suspecting something
>> in QS's Application Support folder, but I haven't been able to
>> reproduce...
>
> Still happens, let me know if there's info I can send you to help
> you debug.

I guess I'll need the complete QS App Support directory (or a way of
creating an App Support dir with ß54 that will fail under ß56). Maybe
try launching with the Option key down.

BTW, quick debugging tip :
QS uses several environment variables to decide what's logged to the
Console or not. Holding Option at start enable some of them, but here
is the complete list :
verbose
NSDebugEnabled
QSDebugRanking
QSDebugMnemonics
QSDebugPlugIns
QSDebugMemory
QSDebugStartup
QSDebugCatalog

and then you can run QS with the following script (put it somewhere in
your PATH) :
# !/bin/sh
QSAPPLICATION=/Applications/Quicksilver.app/Contents/MacOS/Quicksilver
verbose=1 NSDebugEnabled=1 QSDebugRanking=1 QSDebugMnemonics=1
QSDebugPlugIns=1 QSDebugMemory=1 QSDebugStartup=1 QSDebugCatalog=1
$QSAPPLICATION

and you should get all QS logging in the Terminal window ;-).

I'll try enabling all of them by default on the alpha builds, and
redisable them when I'll be nearing release.

>
>>> At least one address book contact that had an image didn't display
>>> the image in Bezel. I think the old version of QS did this
>>> sometimes too.
>>
>> I checked and it didn't have any problem displaying images. Maybe
>> it's an exotic format ? More info would be fine ;-).
>
> My formats are all jpegs. Seems to be working better w/ 3820. I'll
> keep looking and see if it recurs. FYI, with the last one I tried,
> I looked up my friend greg, saw no image in the bezel, did show
> contact and Address Book opened (it was already running) and I saw
> gregs contact including image. When brought him up again in QS the
> pic was in the bezel.

It could be caused by Quicklook taking some time to create thumbnails
(since every image displayed is now going through QL), but I haven't
checked the AB module source code specifically.

>>> The ⌘ column under triggers is fixed width and some some extra
>>> glyph that looks like the left half of a H following the hotkey
>>> icon.
>>
>> Fixed in the branch.
>
> Still see it in 3820. Though I think that what you're saying, fixed
> in the next release.

Exactly ;-).


>>> My only mouse trigger (and my most used trigger) doesn't work. It
>>> does Hide Current Application and is set to activate on mouse
>>> entering the lower left corner. When I checked it wasn't
>>> configured that way and when I set it to be that QS crashed.
>>
>> I don't have the source to the Mouse Triggers module (which handles
>> this stuff), but I would be interested in the issue report anyway.
>
> Still fails, which makes this version difficult for me to use.

Then create an issue for this one too, attaching the crash report.
I'll take a look at it when I'll have the Mouse Triggers module source.

Thanks for the input (all of you!), I'm quite impressed by the 288
downloads b55a1 got in 4 days ;-).

tiennou


Patrick

unread,
Jun 25, 2008, 5:28:02 PM6/25/08
to Blacktree: Quicksilver
Thank YOU tiennou for your work :D

Something that I thought Howard had brought up, but he hadn't the
'trigger' column of the triggers pref pane doesn't always show the
whole trigger for me, (funnily enough I've just checked now and it's
working). So if I have a trigger that's CMD + OPTN + CTRL + L only the
"CMD +OPTN + CTRL" will show up. Annoying!

Jono

unread,
Jun 25, 2008, 5:55:30 PM6/25/08
to Blacktree: Quicksilver
On Jun 25, 6:24 pm, Etienne Samson <tienn...@gmail.com> wrote:
> You can get the current "alphas" here :http://code.google.com/p/blacktree-alchemy/downloads/list

Thanks a lot :)

JJ

unread,
Jul 8, 2008, 9:37:31 PM7/8/08
to Blacktree: Quicksilver
This is great. Any work on Quicksilver is good work.

Thanks tiennou!
Reply all
Reply to author
Forward
0 new messages