BitCurator Ubuntu Native Install Help

16 views
Skip to first unread message

Rachel Appel

unread,
Aug 13, 2021, 12:56:15 PMAug 13
to BitCurator Users
Hi all,

My team and I worked on installing BitCurator natively to an Ubuntu 18.04 computer last week. After install, a new user account "BitCurator" was created, but when we tried logging in it kept saying the password (bcadmin) was incorrect. I, perhaps naively, changed the password on our other user account but when we tried logging in we received the attached error message.

I ended up resetting Ubuntu and installing BitCurator on a VM. So now we have an Ubuntu VM on an Ubuntu host computer which is not ideal not to mention a little "inception-y." This is fine for now, but I would like to eventually put it on our dedicated computer.

I've found great quick start guides for booting from an ISO or installing a pre-made VM, but are there are instructions about installing natively? I'm thinking I missed a step.

Thanks for your time in advance!

Rachel



IMG-2350.jpg

[Matthew] Farrell

unread,
Aug 13, 2021, 1:32:54 PMAug 13
to BitCurator Users
Hi Rachel - 

I've been able to install BitCurator on the Linux partition of a dual-boot machine a couple of times over the years, most recently back in April 2021 (FWIW, I've also used these instructions to bootstrap a Hyper-V VM from Ubuntu --> BitCurator). I used the instructions found here: https://github.com/bitcurator/bitcurator-distro-salt and a clean Ubuntu 18.04 instance. My notes aren't any more extensive than what's in the GitHub readme because, well, the process has worked for me, potentially with a couple of component installation errors. Nothing like what you've described.

Following the simple install instructions, I made sure Ubuntu was updated and git was installed:

> sudo apt-get update
> sudo apt-get dist-upgrade
> sudo apt install git

Cloned the distro-installeer:

And ran the installer script:
> cd bitcurator-distro-installer
> sudo ./install.sh -u <username> 
(where <username> is replaced by an existing user)

The script ran for an hour or so, and the output to the console alerted me to any errors and I followed up on those by looking at the log in /var/log/bitcurator-install.log. Errors I encountered included the bootstrap script trying to install packages that were outdated or where the package maintainer had changed the installation process.

If you have time (always a precious commodity), I would try to bootstrap a Ubuntu VM into a BitCurator VM to see if you can reproduce the behavior you've experienced (you can always try it again on a native Ubuntu OS, too, but it's less stressful for me to test things on VMs first). Maybe that's what you did when you described installing BitCurator on a VM in your message...it's unclear to me whether you used the pre-built VirtualBox BitCurator VM or not.

Sorry this isn't the most helpful advice; I'm curious if others have run into the issue you describe or not.

best,
farrell

Rachel Appel

unread,
Aug 13, 2021, 2:15:41 PMAug 13
to bitcurat...@googlegroups.com
Hi Farrell,

This is actually really helpful. I did not use BitCurator-distro-salt but just BitCurator-distro. I’ll try a bootstrap next week, thank you!



--
You received this message because you are subscribed to the Google Groups "BitCurator Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to bitcurator-use...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/bitcurator-users/7335943b-c4a3-4a6c-8a39-435a0edb030cn%40googlegroups.com.

Rachel Appel

unread,
Aug 13, 2021, 2:16:03 PMAug 13
to bitcurat...@googlegroups.com
Wait I lied I did do that but I might check out the manual install instead—thank you.
Reply all
Reply to author
Forward
0 new messages