Odd problem with Referenced Parameter

Skip to first unread message


May 8, 2017, 7:08:15 PM5/8/17
to BioUno Developers
I have several Active Choices Reactive Parameters fields setup, first one is to get a dir from the build system, next one uses that dir to read in values from a file and the next one does the same from a different file.
Both the second and third ones are using a Referenced Parameter of the value selected in the first one. 
It works fine on the second one but in the third one the value doesn't get passed in. 

the groovy to read the files is the same for each one and the files do exist in the folder selected in the first.

The error I get simply states the referenced parameter variables has no value.

Is this a know issue and is there a work around?

Bruno P. Kinoshita

May 8, 2017, 7:33:31 PM5/8/17
to biouno-d...@googlegroups.com
Could you share your config.xml and/or some screen shots, please?


From: "js78...@gmail.com" <js78...@gmail.com>
To: BioUno Developers <biouno-d...@googlegroups.com>
Sent: Tuesday, 9 May 2017 11:08 AM
Subject: Odd problem with Referenced Parameter

You received this message because you are subscribed to the Google Groups "BioUno Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to biouno-develop...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


May 8, 2017, 7:50:14 PM5/8/17
to BioUno Developers, brunod...@yahoo.com.br
Here are some screen shots. 

First field:

Second Field (CURRENT_SCRIPT_PATH has a value here):

Third field (CURRENT_SCRIPT_PATH has no value here):

Bruno P. Kinoshita

May 10, 2017, 9:33:53 AM5/10/17
to biouno-d...@googlegroups.com
I have a simpler example, with two scripts depending one a single one. Tested with check boxes too, and everything worked fine.

Attaching the config.xml and screenshot. Take a look if that helps. Try changing the scripts, and slowly adding your code from your parameters.

I had a look at your screenshots, but couldn't find any obvious bug. Perhaps a space in the end of the parameter name?

I tested with the version from git, which may contain unreleased changes, but I used this scenario before. So it should work.

Let me know if that worked.


ps :let me know in case google groups filter out the attachments. You should find an xml and a png file attached to this message

Cc: brunod...@yahoo.com.br
Sent: Tuesday, 9 May 2017 11:59 AM
Subject: Re: Odd problem with Referenced Parameter
Screenshot from 2017-05-11 00-43-17.png


May 10, 2017, 1:13:41 PM5/10/17
to BioUno Developers, brunod...@yahoo.com.br
I guess it was the magic of you looking at it. Went back to that project just now, didn't change anything in Jenkins, and it worked.   ;-D

Actually I think in this case it may have been an issue with the file I am parsing at the location. I had made changes to that in the last few days.
The error though in Jenkins didn't complain about that but rather the Reference Param.

Anyway, thank you for taking the time to look into it and sorry it was a waste of time. 

Great plugin btw!

Reply all
Reply to author
0 new messages