No table after creation via csv import

57 views
Skip to first unread message

Matthias Weidinger

unread,
Mar 28, 2012, 9:33:24 AM3/28/12
to bigquery...@googlegroups.com
Hey!

After creation of my new table via csv import i can see the table in the dataset section to the left. If i try to click on the table i get an "table not found" error and after refreshing the page the table disappears completely.

Any ideas?

Thx in advance!

Jordan Tigani

unread,
Mar 28, 2012, 10:33:04 AM3/28/12
to bigquery...@googlegroups.com
It sounds like the import job may be actually failing. If you click on the "Recent Jobs" link on the left side of the UI, it should show your recent imports. If you click on the failed job to select it ou should be able to see the errors.

Note the behavior you are seeing where the table sticks around even though it doesn't exist is a known bug that should be fixed soon.

thanks
-jordan

Matthias Weidinger

unread,
Mar 29, 2012, 5:05:22 AM3/29/12
to bigquery...@googlegroups.com
The job is not even listened in the job history...

Maybe the size of ~2GB is the problem here?

After trying to use a smaller version of the file, everything works fine.

Craig Citro

unread,
Mar 29, 2012, 5:08:44 AM3/29/12
to bigquery...@googlegroups.com
Are you uploading the file directly from the UI, or via Google Storage?

Could you send some info about destination dataset and table names to
bigque...@google.com and we'll see if we can spot anything funny
going on?

--

-cc

Jeremy Condit

unread,
Mar 29, 2012, 1:23:35 PM3/29/12
to bigquery...@googlegroups.com
Since the job doesn't appear in the job history, it was probably never even started.  My suspicion is that the 2 GB file never finished uploading from the UI, and so the job insert operation never completed.

For uploading 2 GB of data, I'd recommend importing via Google Storage for the time being.  In the meantime, we're working to improve support for large uploads from the UI!

Jeremy
Reply all
Reply to author
Forward
0 new messages