Biffboot hangs while loading bzImage

29 views
Skip to first unread message

dmy...@forgetbox.com

unread,
Apr 24, 2015, 6:48:27 AM4/24/15
to biffe...@googlegroups.com
Hello,
I'm experiencing a problem during the biffboot warm boot, biffboot is stuck while loading kernel image:

BIFFBOOT v3.10 102030102030 32-bit Loader by bifferos (c) 
2012 Redistribution prohibited, all rights reserved. 
Press <ESC> 
NIC up in: 1200ms 
Link up 
Checking NIC 
Booting... 
00100000 loaded from flash. 
Booting Linux with: console=uart,io,0x3f8 rootfstype=squashfs,jffs2 init=/etc/preinit mtdnes

This doesn't seems to happen during cold boot, only during warm boot. It's systematic and reproducible with 5-10% chance.
Note that the same problem appears on the reboot by watchdog.

It's unlikely a problem of the kernel decompressor as I've not seen this problem during the soft reboot with kexec using exactly same kernel image.

Before the soft reboot I tried to reset the flash and ensure it's in a good state(anyways if it was in a bad state the CPU won't be able to even run biffboot).
Also I've tried to reset the NIC, flush and invalidate L1 cache, switch to real mode. Also I've tried linux "native" KBD reboot which triggers triple fault.
Still the same symptom.

Thanks for your support,
Dmytro Milinevskyy
Reply all
Reply to author
Forward
0 new messages