Problems with SWORD modules on new cloud install

8 views
Skip to first unread message

Tim Tribe

unread,
May 6, 2022, 7:44:01 AMMay 6
to Bibledit-General
Hi,

I've just spun up a new virtual Ubuntu server and installed bibledit-cloud, and all seems good - except...

Select a SWORD resource is blank, and when I go to Settings | Resources | SWORD and run "Refresh the list of modules...", I get:

6 May 2022 11:25:39 | Refreshing list of SWORD modules
6 May 2022 11:25:39 | installmgr: Unknown argument: --allow-internet-access-and-risk-tracing-and-jail-or-martyrdom
6 May 2022 11:25:39 | installmgr: Unknown argument: --allow-internet-access-and-risk-tracing-and-jail-or-martyrdom
6 May 2022 11:25:39 | Remote Sources:

Running installmgr from the command line shows no remote sources have been specified.

Any ideas?

Thanks,

Tim

Teus Benschop

unread,
May 6, 2022, 9:01:00 AMMay 6
to bibledit...@googlegroups.com
On Fri, 6 May 2022 at 13:44, Tim Tribe <tim.n...@gmail.com> wrote:
6 May 2022 11:25:39 | Refreshing list of SWORD modules
6 May 2022 11:25:39 | installmgr: Unknown argument: --allow-internet-access-and-risk-tracing-and-jail-or-martyrdom
6 May 2022 11:25:39 | installmgr: Unknown argument: --allow-internet-access-and-risk-tracing-and-jail-or-martyrdom
6 May 2022 11:25:39 | Remote Sources:

Running installmgr from the command line shows no remote sources have been specified.


Hello Tim,

The version of the libsword and associated utils may not be recent enough.
The error on the argument "--allow-internet-access-and-risk-tracing-and-jail-or-martyrdom" indicates that this version is now the newest version.
Locally here I tested the "installmgr" and it is version 1.9.0 and it allows the argument that has an error in your case.
Likely upgrading the libsword and utils may take care of the problem.

Teus.

Tim Tribe

unread,
May 6, 2022, 9:58:55 AMMay 6
to bibledit...@googlegroups.com
Thanks for the pointer Teus, I will take a look.

Blessings,

Tim

--
You received this message because you are subscribed to a topic in the Google Groups "Bibledit-General" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/bibledit-general/vsDO_1zhnLA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to bibledit-gener...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/bibledit-general/CAFueZ4wfXzDM6FZ2RSgQqVuv_WRwr-K%3Duskuc4Md6Sq9kPPaPg%40mail.gmail.com.

Tim Tribe

unread,
May 6, 2022, 11:08:24 AMMay 6
to Bibledit-General
Hi Teus,

Using apt, these are the only libsword packages I see installed, and there doesn't seem to be anything newer available :(

libsword-common is already the newest version (1.7.3+dfsg-9.1build2).
libsword-common set to manually installed.
libsword-utils is already the newest version (1.7.3+dfsg-9.1build2).
libsword11v5 is already the newest version (1.7.3+dfsg-9.1build2).
libsword11v5 set to manually installed.

(libsword-dbg and libsword-dev are available but not installed)

Do I need to do a manual update somehow?

Thanks,

Tim

Teus Benschop

unread,
May 6, 2022, 11:16:24 AMMay 6
to bibledit...@googlegroups.com
On Fri, 6 May 2022 at 17:08, Tim Tribe <tim.n...@gmail.com> wrote:
Using apt, these are the only libsword packages I see installed, and there doesn't seem to be anything newer available :(

libsword-common is already the newest version (1.7.3+dfsg-9.1build2).
libsword-common set to manually installed.
libsword-utils is already the newest version (1.7.3+dfsg-9.1build2).
libsword11v5 is already the newest version (1.7.3+dfsg-9.1build2).
libsword11v5 set to manually installed.

(libsword-dbg and libsword-dev are available but not installed)

Do I need to do a manual update somehow?

Hello Tim,

A manual update from the SWORD source could fix the problem. More information is at https://wiki.crosswire.org.

I checked on Ubuntu 20.04. It has libsword-1.8.1.
Guess: Are you running anything older than Ubuntu 20.04 or 22.04? If it's Ubuntu 18.04 then this would be four years old by now.
Updating to a newer Ubuntu version could remedy the problem too.

Teus.

Tim Tribe

unread,
May 10, 2022, 6:55:24 AMMay 10
to Bibledit-General
Hi Teus.

I was on Ubuntu 18, but after an upgrade to 20, I was able to get the SWORD modules working.

Many thanks,

Tim
Reply all
Reply to author
Forward
0 new messages