why so many parameters ESS are low using GTR model?

248 views
Skip to first unread message

xia wang

unread,
Jan 16, 2024, 10:05:46 PMJan 16
to beast-users
屏幕截图 2024-01-17 104124.png
Could you please help me solve the low ESS problem?
I used BEAST 2.6 version to analyze the whole chloroplast genome of 39 species choosing GTR substitution model and relaxed log normal clock and selecting 4  fossil calibration point. 
But prior, posterior, likelihood, etc., their ESSs always are low level (as the picture showed).
after that, I changed HYK model. em,  it seems turn to be okay but not all.屏幕截图 2024-01-17 105928.png
Can anyone help me understand the result and share some tips on how to boost the ESS? Thank you from my bottom of my heart!!!

Remco Bouckaert

unread,
Jan 17, 2024, 2:02:11 PMJan 17
to beast...@googlegroups.com
Hi Xia,

It might be that burn-in for the GTR analysis is too short. By looking at the trace in the “Trace” tab it should be obvious how large burn-in should be, since that is where the horizontal hairy caterpillar starts. Burn-in in tracer can be increased by editing the number in the “Burn-in” column in the “Trace File” table.

Regardless, you should run multiple runs (say 4) and make sure the posteriors agree with each other in order to get some confidence the MCMC converges to the correct distribution.

Also, if for the question you want to answer the site model is not something that is important, it is recommended to use bModelTest as site model. It averages over all common site models, which prevents over-parmaterisation — a common source of GTR not mixing well.

Cheers,

Remco

On 17/01/2024, at 4:03 PM, xia wang <x23...@gmail.com> wrote:

<屏幕截图 2024-01-17 104124.png>
Could you please help me solve the low ESS problem?
I used BEAST 2.6 version to analyze the whole chloroplast genome of 39 species choosing GTR substitution model and relaxed log normal clock and selecting 4  fossil calibration point. 
But prior, posterior, likelihood, etc., their ESSs always are low level (as the picture showed).
after that, I changed HYK model. em,  it seems turn to be okay but not all.<屏幕截图 2024-01-17 105928.png>
Can anyone help me understand the result and share some tips on how to boost the ESS? Thank you from my bottom of my heart!!!

--
You received this message because you are subscribed to the Google Groups "beast-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beast-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beast-users/e35ff6c4-f599-4d7d-8f5f-2f84aa745658n%40googlegroups.com.
<屏幕截图 2024-01-17 104124.png><屏幕截图 2024-01-17 105928.png>

xia wang

unread,
Jan 21, 2024, 1:36:09 PMJan 21
to beast-users

Dear Remco, 
Thank you for your suggestion! Unfortunately, it's a problem that BEAST 2.6.6 cannot update 'bModelTest'. And I apologize as I may not be familiar with what bModelTest is.
The latest version 2.7.7 also does not have bModelTest, and there are many options available in the site model of the latest version.

屏幕截图 2024-01-21 163336.png
someone told me that the fossil calibration point settings are incorrect, so I reconfigured the XML file.

Remco Bouckaert

unread,
Jan 21, 2024, 1:41:38 PMJan 21
to beast...@googlegroups.com
Hi Xia,

To use bModeltest, you need to install the bModelTest package via the package manager. This is easiest done in BEAUti, using the menu File => Manage packages. A dialog pops up where you can select the bModelTest package, then click the install button. Wait a little while for the package to be downloaded, then a dialog pops up to tell the package is installed. 
Don’t forget to restart BEAUti for the package to become available.

Cheers,

Remco

On 21/01/2024, at 9:57 PM, xia wang <x23...@gmail.com> wrote:


Dear Remco, 
Thank you for your suggestion! Unfortunately, it's a problem that BEAST 2.6.6 cannot update 'bModelTest'. And I apologize as I may not be familiar with what bModelTest is.
The latest version 2.7.7 also does not have bModelTest, and there are many options available in the site model of the latest version.

<屏幕截图 2024-01-21 163336.png>
someone told me that the fossil calibration point settings are incorrect, so I reconfigured the XML file.

在2024年1月18日星期四 UTC+8 03:02:11<Remco Bouckaert> 写道:
Hi Xia,

It might be that burn-in for the GTR analysis is too short. By looking at the trace in the “Trace” tab it should be obvious how large burn-in should be, since that is where the horizontal hairy caterpillar starts. Burn-in in tracer can be increased by editing the number in the “Burn-in” column in the “Trace File” table.

Regardless, you should run multiple runs (say 4) and make sure the posteriors agree with each other in order to get some confidence the MCMC converges to the correct distribution.

Also, if for the question you want to answer the site model is not something that is important, it is recommended to use bModelTest as site model. It averages over all common site models, which prevents over-parmaterisation — a common source of GTR not mixing well.

Cheers,

Remco

On 17/01/2024, at 4:03 PM, xia wang <x23...@gmail.com> wrote:

<屏幕截图 2024-01-17 104124.png>
Could you please help me solve the low ESS problem?
I used BEAST 2.6 version to analyze the whole chloroplast genome of 39 species choosing GTR substitution model and relaxed log normal clock and selecting 4  fossil calibration point. 
But prior, posterior, likelihood, etc., their ESSs always are low level (as the picture showed).
after that, I changed HYK model. em,  it seems turn to be okay but not all.<屏幕截图 2024-01-17 105928.png>
Can anyone help me understand the result and share some tips on how to boost the ESS? Thank you from my bottom of my heart!!!

-- 
You received this message because you are subscribed to the Google Groups "beast-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beast-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beast-users/e35ff6c4-f599-4d7d-8f5f-2f84aa745658n%40googlegroups.com.
<屏幕截图 2024-01-17 104124.png><屏幕截图 2024-01-17 105928.png>


-- 
You received this message because you are subscribed to the Google Groups "beast-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beast-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beast-users/ef8df37b-6d59-4db3-958c-832d7b0c8f92n%40googlegroups.com.
<屏幕截图 2024-01-21 163336.png>

xia wang

unread,
Jan 23, 2024, 6:50:44 PMJan 23
to beast-users
Dear Remco,
Thanks for your help!!!
but the terrible thing is that I cannot open Beauti ...
屏幕截图 2024-01-23 195743.png
屏幕截图 2024-01-23 195915.png
the two methods are both unable to open it.

Remco Bouckaert

unread,
Jan 23, 2024, 8:24:23 PMJan 23
to beast...@googlegroups.com
Hi Xia,

It looks like something may have gone wrong with the package installation.

Probably easiest to fix this is to remove the package directory. On Windows, this is C:\Users\<yourname>\BEAST, where <yourname> is your user name. So, deleting the directory C:\Users\wc\BEAST should do it in your case. You would have to reinstall the packages you want.

Hope this helps, Remco

On 24/01/2024, at 1:04 AM, xia wang <x23...@gmail.com> wrote:

Dear Remco,
Thanks for your help!!!
but the terrible thing is that I cannot open Beauti ...
<屏幕截图 2024-01-23 195743.png>
<屏幕截图 2024-01-23 195915.png>
To view this discussion on the web visit https://groups.google.com/d/msgid/beast-users/c2ad712d-eec1-485f-a00e-09d9c822bb8an%40googlegroups.com.
<屏幕截图 2024-01-23 195743.png><屏幕截图 2024-01-23 195915.png>

xia wang

unread,
Jan 23, 2024, 10:18:29 PMJan 23
to beast-users
Dear Remco,
Thank you uuuuu! So cool!
I've opened it!
屏幕截图 2024-01-24 110626.png

xia wang

unread,
Feb 7, 2024, 1:23:01 AMFeb 7
to beast-users
Dear Remco,
The ESS results after running bmodeltest are still not ideal, with some values being very low.屏幕截图 2024-02-06 204215.png

x231428

unread,
Mar 19, 2024, 1:20:24 PMMar 19
to beast-users@googlegro…
Dear Remco,
could you please help me? Every time I try to run BEAST after selecting the 'starting tree' panel when fixing the tree, it always throws an error. How can I solve this? I have attached the configured XML file, the Newick tree file, and the error message. I would be very grateful if someone could take a look. Thank you very much in advance.



---- Replied Message ----
From xia wang<x23...@gmail.com>
Date 2/7/2024 14:23
To beast-users<beast...@googlegroups.com>
Subject Re: why so many parameters ESS are low using GTR model?
You received this message because you are subscribed to a topic in the Google Groups "beast-users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/beast-users/UFQfDZEFUXU/unsubscribe.
To unsubscribe from this group and all its topics, send an email to beast-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beast-users/592eac9e-2632-4d34-b82e-86670eea997fn%40googlegroups.com.
从 网易邮箱大师 发来的云附件
90INPUT-3.XML
(32.4MB,2024年4月3日 17:9 到期)
下载
90byITOL.newick
Reply all
Reply to author
Forward
0 new messages