Angstrom : USB to Serial Missing every other Incoming Character

127 views
Skip to first unread message

Remo

unread,
May 20, 2012, 10:55:57 PM5/20/12
to beagl...@googlegroups.com
I've attached my BB to a modem dev platform using two methods.
1.  USB (Modem) to USB (BB)  FTDI Solution
2.  RS232(Modem) to USBtoSerial(BB)  Prolific PL2303 Solution

Drivers for both have been installed via opkg, and both give the same reusults, all characters are transmitted from the BB, but only about 50% of the characters returned are recived by the application.  (See attached)

To date, I've tried to use ps to locate another application that might be using my /dev/ttyUSBx port, but without success (See below)

root@beaglebone:~/tcp_serial_redirect# ps | grep tty                           
  238 root      1952 S    /sbin/agetty tty1 38400                              
  269 root      1772 S    grep tty                                             
root@beaglebone:~/tcp_serial_redirect# ps | grep usb                           
   16 root         0 SW<  [musb-hdrc.0]                                        
   17 root         0 SW<  [musb-hdrc.1]                                        
  271 root      1772 S    grep usb   

I was hoping that fuser might be of service, but has been fruitless thus far.  Hardware flow control is turned on in the modem, but since they modem platform works well under the same circumstances with my Ubuntu 10.04 host machine, I haven't changed anything there.

Any thoughts?

Thanks,

Remo
2012-05-20_223408.jpg

Remo

unread,
May 23, 2012, 10:50:44 AM5/23/12
to beagl...@googlegroups.com
Solved: The issue undoubtedly had to do with multiple stages of emulation, and loss of the CR/LF to the modem.  I was ssh'ing into a dev machine, microcoming into the BBone, then minicoming into the modem.  Somewhere in there, one of the terminals was eating my CR.

Pulled the miniterm python script from pyserial's website, and issues no longer exists.
Reply all
Reply to author
Forward
0 new messages