RE: Cross-Compiling apt: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/arm-linux-gnueabihf/libstdc++.so.6)

56 views
Skip to first unread message

set_

unread,
Dec 17, 2020, 4:09:03 PM12/17/20
to BeagleBoard
Hello,

I started to cross-compile and I am getting some headway here on my compilations. It seems I have been stumped so far w/ this error:

apt: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/arm-linux-gnueabihf/libstdc++.so.6)


...


So, I made an addition to my BBB from eclipse on a cross-compiled version of libstdc++.so.6.0.xx. If you know how to resolve this issue w/out me going backwards, please do chime in.

Seth

P.S. I used sftp to get the required libstdc++.so.6 onboard the BBB but it seems that there is a snag, i.e. as you can tell.

set_

unread,
Dec 17, 2020, 4:23:11 PM12/17/20
to BeagleBoard
Hello,

I mean, would i need to coss-compile glibc_2.29 from source and go from that point forward?

Seth

jonnymo

unread,
Dec 17, 2020, 5:15:38 PM12/17/20
to Beagle Board
What platform are you cross-compiling on?  Windows, Ubuntu, Debian, ... so on.

Are you following instructions from a particular web site or other source?

Jon

--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beagleboard/c7568541-1cec-4fc3-ab4d-4720c5bfdc3fn%40googlegroups.com.

Robert Nelson

unread,
Dec 17, 2020, 9:28:43 PM12/17/20
to Beagle Board
On Thu, Dec 17, 2020 at 3:23 PM set_ <fun...@gmail.com> wrote:
>
> Hello,
>
> I mean, would i need to coss-compile glibc_2.29 from source and go from that point forward?
>
> Seth
>
> On Thursday, December 17, 2020 at 3:09:03 PM UTC-6 set_ wrote:
>>
>> Hello,
>>
>> I started to cross-compile and I am getting some headway here on my compilations. It seems I have been stumped so far w/ this error:
>>
>> apt: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/arm-linux-gnueabihf/libstdc++.so.6)
>>
>> So, I made an addition to my BBB from eclipse on a cross-compiled version of libstdc++.so.6.0.xx. If you know how to resolve this issue w/out me going backwards, please do chime in.
>>
>> Seth
>>
>> P.S. I used sftp to get the required libstdc++.so.6 onboard the BBB but it seems that there is a snag, i.e. as you can tell.

Debian Buster on the Beagle uses glibc 2.28, your mistake was building
your application against glibc 2.29... So fix your cross compiler..

Regards,

--
Robert Nelson
https://rcn-ee.com/

set_

unread,
Dec 17, 2020, 9:34:29 PM12/17/20
to BeagleBoard
Hello,

Sorry. Ubuntu Focal 5.4.0-58-generic, 20.04.x LTS. The compilation is done from this page online: https://github.com/Teknic-ClearPath/TekTips-BeagleBone-Examples/blob/master/CrossCompilingBeagleBone.doc.

...

That doc. is completed up to the point of 9.  I cannot configure remote debugging but that is not the issue right now as my BBB is held useless w/out the glibc_2.29 versioning. I changed it back to the correct version.

Seth

P.S. So, for now, my BBB works. I can break things to make it work but I would rather be able to switch in b/t versioning.

set_

unread,
Dec 17, 2020, 9:35:16 PM12/17/20
to BeagleBoard
Hello,

Gotcha. Okay. The compiler. Sheesh.

Seth
Reply all
Reply to author
Forward
0 new messages