Skip to first unread message

Eloy Cain

unread,
Aug 15, 2020, 1:42:53 PM8/15/20
to BeagleBoard
hello gang, I'm having problems at the moment of wanting to turn on a led. I am using PUtty to enter the card and to program I use python. When I run a program or print a message, it works correctly. the problem is as if the pins of the card do not work for me. I don't know if I should use a library to activate them. I have updated the card and nothing. I have seen a lot of information and it has not worked for me.



python



Dennis Lee Bieber

unread,
Aug 16, 2020, 11:43:29 AM8/16/20
to Beagleboard
On Sat, 15 Aug 2020 10:42:53 -0700 (PDT), in
gmane.comp.hardware.beagleboard.user Eloy Cain
First... Please don't use screen grabs. Everything I know of -- and
especially PuTTY -- allows one to select, copy, and paste the TEXT.

Second... Show us the CODE. All your screen grab illustrates is that
you invoked an editor, and then ran listings of the directory contents
showing that some files exist.

Without the code, it is impossible to provide advice. How are you
trying to access the pins? Using sysfs references? Is the pin even set up
for GPIO or is it defined for some other usage? Adafruit_BBIO?
Adafruit_blinka/CircuitPython libraries?



What follows is Beaglebone Black and PocketBeagle (I only just noticed your
subject says "AI" -- the BB AI is NOT supported by blinka, and even BBIO
may be problematic (you may not be able to "setup" a pin for GPIO use, but
might be able to turn it on/off -- however, the PIN NUMBERS may not be
matching). Unless things have changed recently, the pin-mux of the BB AI
MUST be set up using the Device Tree! Config-Pin does not work to change
pin modes.

https://learn.adafruit.com/setting-up-io-python-library-on-beaglebone-black/using-the-bbio-library
I believe any recent BBB image includes this already -- note: the
"learning" documentation is a bit old.
https://pypi.org/project/Adafruit-BBIO/ may be somewhat more up-to-date --
there is no longer any mention of I2C access in it.

https://github.com/adafruit/Adafruit_Blinka
https://learn.adafruit.com/circuitpython-on-raspberrypi-linux/circuitpython-raspi
Also applies to BBB -- just ignore anything about installing Raspbian


For the AI, please see
https://github.com/adafruit/adafruit-beaglebone-io-python/issues/317
https://github.com/MalavPatel3501/BeagleBone-AI--mpBBAI-IO-Python-Library


--
Dennis L Bieber

Reply all
Reply to author
Forward
0 new messages