Latest Image (new Process) - Spring 2020 Release

188 views
Skip to first unread message

Robert Nelson

unread,
Mar 2, 2020, 6:03:36 PM3/2/20
to Beagle Board, Matthijs van Duin, Jason Kridner
Hi Everyone,

So it's been a long time since i posted one of these. So let's go more crazy..

In the past, Image releases have been kinda random. So let's try to
get things on a better schedule...

Maybe 3 times a year? We've been thinking, Early spring for GSOC,
Before School for universities who use our boards, and a mid December
which fits in between..

So... With a plan to have an NEW official image released on April
6th, 2020, let's get started with RC1: (which are up right now..) New
RC every Monday..

Right now i just want to limit images to the Base Console, IoT and IoT
TIDL. (For both Stretch 9.12 and Buster 10.3)

Let's be honest, who really uses the lxqt image? Raise hand???

Issue Tracker: https://github.com/beagleboard/Latest-Images/issues
elinux page with img links: https://elinux.org/Beagleboard:Latest-images-testing

Changes:

usb0/usb1: default ip address (192.168.7.2/192.168.6.2)
For users that like to plug many Beagle's into one PC, you can now
stop fighting usb-gadget, under /etc/default/bb-boot, you can now
update the usb0/usb1 default ip address in one location...

Node-RED : 1.0.4

Regards,

--
Robert Nelson
https://rcn-ee.com/

Gwen Stouthuysen

unread,
Mar 3, 2020, 2:41:45 AM3/3/20
to beagl...@googlegroups.com
Can we drop features we would like to be implemented in the April release?

I would like to have kernel 5.4 (or newer) to be functional in the Pocket/BeagleBoneBlack (Wireless)
Reason: I would like to use CAN J1939 directly from Kernel support.

I will keep an eye on the RCs and test them in my domain

Gwen


Op di 3 mrt. 2020 om 00:03 schreef Robert Nelson <robert...@gmail.com>:
--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beagleboard/CAOCHtYgP5GW-Wi4oCcY3OFfroEvEY7y1QtWnXco9EG41cmCJ4A%40mail.gmail.com.

Jason Kridner

unread,
Mar 3, 2020, 5:10:40 AM3/3/20
to beagl...@googlegroups.com
On Tue, Mar 3, 2020 at 8:41 AM Gwen Stouthuysen <gwen.sto...@gmail.com> wrote:
Can we drop features we would like to be implemented in the April release?

Please. There is a tracker. 


I would like to have kernel 5.4 (or newer) to be functional in the Pocket/BeagleBoneBlack (Wireless)
Reason: I would like to use CAN J1939 directly from Kernel support.

Cool. I need dtbo ovetlays for some of my workshops and a number of out of tree drivers. Really, I need to track them to mainline and create a regression test suite. 

Kernels are pretty big. Robert has scripts to load different kernels. Does that work for you?


I will keep an eye on the RCs and test them in my domain

Great!

--
https://beagleboard.org/about - a 501c3 non-profit educating around open hardware computing

Gwen Stouthuysen

unread,
Mar 3, 2020, 5:31:33 AM3/3/20
to beagl...@googlegroups.com
No,

Debian 9 ARMHF has no 5.4 version support, starting from the release version the unit does not boot if I enforce the kernel version.

With Debian10 testing version, 10 has 5.4 available in ARMHF, my device fails to mount/boot after upgrading the Kernel.

I will do the exercise with a serial debug connected, to get some info on what is going wrong. 

I don't use the overlays as it never really aligns exactly with the application.
I tend to define the pins in a startup script.

Gwen

Op di 3 mrt. 2020 om 11:10 schreef Jason Kridner <jkri...@beagleboard.org>:

Robert Nelson

unread,
Mar 3, 2020, 9:56:24 AM3/3/20
to Beagle Board, gwen.sto...@gmail.com
On Tue, Mar 3, 2020 at 1:41 AM Gwen Stouthuysen
<gwen.sto...@gmail.com> wrote:
>
> Can we drop features we would like to be implemented in the April release?

Please explain a little more, i don't know specifically what you mean..

Robert Nelson

unread,
Mar 3, 2020, 9:57:59 AM3/3/20
to Beagle Board, gwen.sto...@gmail.com
On Tue, Mar 3, 2020 at 4:31 AM Gwen Stouthuysen
<gwen.sto...@gmail.com> wrote:
>
> No,
>
> Debian 9 ARMHF has no 5.4 version support, starting from the release version the unit does not boot if I enforce the kernel version.
>
> With Debian10 testing version, 10 has 5.4 available in ARMHF, my device fails to mount/boot after upgrading the Kernel.
>
> I will do the exercise with a serial debug connected, to get some info on what is going wrong.

In either our Debian 9 or Debian 10 images, just run:

sudo /opt/scripts/tools/update_kernel.sh --ti-channel --lts-5_4

It should boot in the default state.

> I don't use the overlays as it never really aligns exactly with the application.
> I tend to define the pins in a startup script.

Robert Nelson

unread,
Mar 3, 2020, 10:25:58 AM3/3/20
to Beagle Board
BeagleBone Blue: Users

A bug was just fixed/found in the boot scripts.. It's a simple fix,
but a bad typo on my "hey your not a robotiscape, don't load that
service file cleanup patches, for other boards.."

cd /opt/scripts/
git pull

Regards,

https://rcn-ee.com/

Robert Nelson

unread,
Mar 3, 2020, 4:29:52 PM3/3/20
to Beagle Board
Console Users, there's a bug in the usb0/usb1 dnsmasq init:

Run:

sudo cp -v /opt/scripts/boot/default/bb-boot /etc/default/

and Reboot..

https://github.com/beagleboard/Latest-Images/issues/5

rksem...@gmail.com

unread,
Aug 17, 2020, 9:25:21 AM8/17/20
to BeagleBoard
Hmmm ... this may be me (very possible!), but applying the updates above - even with git pull, refreshing from the repository, and the copy command (to be safe), after running the kernel update, I can no longer boot from eMMC. No USB ip address, also the ethernet interface itself doesn't come up. I can "restore" with the eMMC-flasher microSD build, but that's back to the older kernel

Any thoughts of how to debug? I don't have a serial cable (yet), so somewhat flying blind :-(. Thanks!

Robert Nelson

unread,
Aug 17, 2020, 9:28:17 AM8/17/20
to Beagle Board, rksem...@gmail.com
On Mon, Aug 17, 2020 at 8:25 AM <rksem...@gmail.com> wrote:
>
> Hmmm ... this may be me (very possible!), but applying the updates above - even with git pull, refreshing from the repository, and the copy command (to be safe), after running the kernel update, I can no longer boot from eMMC. No USB ip address, also the ethernet interface itself doesn't come up. I can "restore" with the eMMC-flasher microSD build, but that's back to the older kernel
>
> Any thoughts of how to debug? I don't have a serial cable (yet), so somewhat flying blind :-(. Thanks!

Which board, what kernel did you try to install?

rksem...@gmail.com

unread,
Aug 17, 2020, 9:32:41 AM8/17/20
to BeagleBoard
Sorry! BeagleBone AI, rev A1. Tried upgrading to lts-5.4 (command as above). Make sense?

rksem...@gmail.com

unread,
Aug 17, 2020, 9:35:48 AM8/17/20
to BeagleBoard
Is it better to work this here, or put an Issue in to GitHub? Either one is fine with me, just not sure what the preferred answer is.

Thanks!

Robert Nelson

unread,
Aug 17, 2020, 9:35:57 AM8/17/20
to Beagle Board
On Mon, Aug 17, 2020 at 8:32 AM <rksem...@gmail.com> wrote:
>
> Sorry! BeagleBone AI, rev A1. Tried upgrading to lts-5.4 (command as above). Make sense?

eMMC is broken in 5.4.x with the AI, haven't had a moment to fix it.
It's a pinmux issue with the new driver.

rksem...@gmail.com

unread,
Aug 17, 2020, 9:44:53 AM8/17/20
to BeagleBoard
NP! Just glad I'm not going crazy ... LOL!

Would it make sense to addt this to GitHub? No biggie either way, just wondering.

Thanks!

Robert Nelson

unread,
Aug 17, 2020, 9:47:38 AM8/17/20
to Beagle Board
On Mon, Aug 17, 2020 at 8:44 AM <rksem...@gmail.com> wrote:
>
> NP! Just glad I'm not going crazy ... LOL!
>
> Would it make sense to addt this to GitHub? No biggie either way, just wondering.

It's fine, it's one of two reasons, why the Summer 2020 snapshot
(which should be released today) is still on v4.19.x

rksem...@gmail.com

unread,
Aug 17, 2020, 9:54:42 AM8/17/20
to BeagleBoard
That makes sense, thanks! Perhaps just capture in the release notes (saying not to try lts-5.4 :-)).

Appreciate it!
Reply all
Reply to author
Forward
0 new messages