How to check exact model of CPU on BBB

48 views
Skip to first unread message

Pavel Yermolenko

unread,
Sep 10, 2020, 5:51:19 AM9/10/20
to BeagleBoard
Hello,

How to check the exact model of CPU ?
cpuinfo gets just this: AM33XX

root@am335x-evm:~# cat /proc/cpuinfo
processor    : 0
model name    : ARMv7 Processor rev 2 (v7l)
BogoMIPS    : 597.68
Features    : half thumb fastmult vfp edsp neon vfpv3 tls vfpd32
CPU implementer    : 0x41
CPU architecture: 7
CPU variant    : 0x3
CPU part    : 0xc08
CPU revision    : 2

Hardware    : Generic AM33XX (Flattened Device Tree)
Revision    : 0000
Serial        : 2017BBBG0292


Thanks.

Regards.

Robert Nelson

unread,
Sep 10, 2020, 11:52:44 AM9/10/20
to Beagle Board
TI's image usually (or did) ship "omapconf"..


debian@bbb-pwr01-ser09:~$ sudo omapconf --cpuinfo
OMAPCONF (rev 1.73-nogit built Thu Jan 4 21:17:37 UTC 2018)

HW Platform:
Generic AM33XX (Flattened Device Tree)
AM3359 ES2.0 GP Device (UNKNOWN performance ZCZ package (1.0GHz))
Error: I2C Read failed
Error: I2C Read failed
Error: I2C Read failed
TPS65217C ES1.2
Error: I2C Read failed
UNKNOWN AUDIO IC

"AM3359 ES2.0 GP ZCZ"...

Regards,

--
Robert Nelson
https://rcn-ee.com/

Pavel Yermolenko

unread,
Sep 10, 2020, 1:46:48 PM9/10/20
to BeagleBoard
 It doesn't work on my board:

debian@beaglebone:~$ sudo omapconf --cpuinfo
[sudo] password for debian:
sudo: omapconf: command not found
debian@beaglebone:~$ 

Sincerely,

Pavel.

Robert Nelson

unread,
Sep 10, 2020, 2:00:32 PM9/10/20
to Beagle Board
On Thu, Sep 10, 2020 at 12:47 PM Pavel Yermolenko <py.o...@sunrise.ch> wrote:
>
> It doesn't work on my board:
>
> debian@beaglebone:~$ sudo omapconf --cpuinfo
> [sudo] password for debian:
> sudo: omapconf: command not found
> debian@beaglebone:~$

It's not installed by default in the BeagleBoard.org image's, as it
doesn't provide very much useful information for the average user.

I had merely reference TI's sdk as that is what you posted in this thread.

Pavel Yermolenko

unread,
Sep 10, 2020, 2:44:26 PM9/10/20
to BeagleBoard
Works. Thanks !
root@am335x-evm:~# sudo omapconf --cpuinfo
OMAPCONF (rev v1.74-1-g40ab0a2 built Sun Apr 19 07:10:00 UTC 2020)


HW Platform:
  Generic AM33XX (Flattened Device Tree)
  AM3358 ES2.1 GP Device (UNKNOWN performance ZCZ package (1.0GHz))

Error: I2C Read failed
Error: I2C Read failed
Error: I2C Read failed
  TPS65217B  ES1.2
Error: I2C Read failed
  UNKNOWN AUDIO IC

root@am335x-evm:~#

Before I tried on eMMC images. I've two Linux images:
  • downloaded from BeagleBone site (in eMMC)
  • flashed on SD card using TI SDK utility (on SD card)
Where can I find omapconf to install it on eMMC ?
Sincerely,
Pavel.

On Thursday, September 10, 2020 at 8:00:32 PM UTC+2, RobertCNelson wrote:

jonnymo

unread,
Sep 10, 2020, 2:53:37 PM9/10/20
to Beagle Board
Have you tried this?

--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beagleboard/e50ed685-21eb-42ed-a3ce-6377f22ea3b6o%40googlegroups.com.

Robert Nelson

unread,
Sep 10, 2020, 3:17:03 PM9/10/20
to Beagle Board
On Thu, Sep 10, 2020 at 1:44 PM Pavel Yermolenko <py.o...@sunrise.ch> wrote:
>
> Works. Thanks !
> root@am335x-evm:~# sudo omapconf --cpuinfo
> OMAPCONF (rev v1.74-1-g40ab0a2 built Sun Apr 19 07:10:00 UTC 2020)
>
> HW Platform:
> Generic AM33XX (Flattened Device Tree)
> AM3358 ES2.1 GP Device (UNKNOWN performance ZCZ package (1.0GHz))
> Error: I2C Read failed
> Error: I2C Read failed
> Error: I2C Read failed
> TPS65217B ES1.2
> Error: I2C Read failed
> UNKNOWN AUDIO IC
>
> root@am335x-evm:~#
>
> Before I tried on eMMC images. I've two Linux images:
>
> downloaded from BeagleBone site (in eMMC)
> flashed on SD card using TI SDK utility (on SD card)
>
> Where can I find omapconf to install it on eMMC ?

sudo apt install tiomapconf

Mark Lazarewicz

unread,
Sep 10, 2020, 4:13:56 PM9/10/20
to beagl...@googlegroups.com
Dude I'm getting dizzy following  this thread.
You must run this command on the sdk version of Linux

You said it works above on sdk now it appears you are running the command on Debian. It won't  work until you follow Robert's update command.

--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard...@googlegroups.com.
To view this discussion on the web visit

Pavel Yermolenko

unread,
Sep 11, 2020, 6:42:58 AM9/11/20
to BeagleBoard
You said it works above on sdk now it appears you are running the command on Debian. It won't  work until you follow Robert's update command.

As I previously mentioned, I've two version of Linux:
  • debian in eMMC
  • yocto-based in SD card
On yocto omapconf worked, on debian - not.
I installed it on debian using Robert's suggestion and now it also works on debian.
What confuses you ?
Sincerely,
Pavel.

Reply all
Reply to author
Forward
0 new messages