Trouble creating a BeagleBone Static IP

148 views
Skip to first unread message

Lidia Toscano

unread,
Aug 1, 2016, 1:55:10 PM8/1/16
to BeagleBoard
I am totally a nenwbie to BBB -  I am having trouble connecting it to my pc through ethernet.  I am using Angstrom.  I've tried following the instructions here: http://derekmolloy.ie/set-ip-address-to-be-static-on-the-beaglebone-black/    but then I run into lots of errors:


login as: root
ro...@beaglebone.local's password:
root@beaglebone:~# ls -al
total 64
drwxr-xr-x 10 root root 4096 Jan  1 00:00 .
drwxr-sr-x  4 root root 4096 Mar 18  2013 ..
-rw-------  1 root root 1320 Jan  1 00:00 .ICEauthority
-rw-------  1 root root  190 Jan  1  2000 .bash_history
drwxr-xr-x  4 root root 4096 Jan  1 00:01 .config
-rw-r--r--  1 root root   31 Jan  1 00:00 .dmrc
drwx------  4 root root 4096 Jan  1 00:00 .gconf
drwx------  5 root root 4096 Jan  1 00:01 .gnome2
dr-x------  2 root root    0 Jan  1 00:00 .gvfs
drwxr-xr-x  3 root root 4096 Jan  1 00:00 .local
drwxr-xr-x  2 root root 4096 Jan  1 00:01 .nautilus
drwx------  2 root root 4096 Jan  1 00:00 .pulse
-rw-------  1 root root  256 Jan  1 00:00 .pulse-cookie
-rw-------  1 root root    7 Jan  1 00:16 .python-history
-rw-------  1 root root 1501 Jan  1 00:00 .xsession-errors
-rw-------  1 root root 1501 Jan  1 00:00 .xsession-errors.old
drwxr-xr-x  2 root root 4096 Jan  1 00:01 Desktop
root@beaglebone:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.7.0     0.0.0.0         255.255.255.252 U     0      0        0 usb0
root@beaglebone:~# cat /etc/network/interfaces
cat: /etc/network/interfaces: No such file or directory
root@beaglebone:~# iface eth0 inet dhcp
-sh: iface: command not found
root@beaglebone:~# /etc/network/interfaces
-sh: /etc/network/interfaces: No such file or directory
root@beaglebone:~#

I cannot find the ethernet_c8a030ab323a_cable# Derek speaks about, I cannot fint the /etc/network/interfaces to try to edit the file indicated by Derek.  

Any idea why I am getting those errors?  You help will be greatly appreciated.

Thanks in advance!

Lidia

evilwulfie

unread,
Aug 1, 2016, 2:00:31 PM8/1/16
to beagl...@googlegroups.com
Flash Debian on it, I don't think anybody is supporting angstrom on the BBB ANYMORE
--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beagleboard/5404eb31-a8c8-43a3-9036-c4ca17f66a04%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Davide Picchi

unread,
Aug 10, 2016, 10:00:28 AM8/10/16
to beagl...@googlegroups.com
Lidia,
I think you got a corrupted file.

Install your SO again and follow what Robert says

Here the syntax:
sudo connmanctl config <service> --ipv4 manual <ip_addr> <netmask> <gateway> --nameservers <dns_server>

run:

debian@beaglebone:~$ connmanctl services
*AO Wired                ethernet_74daea0a4b52_cable

sudo connmanctl config ethernet_74daea0a4b52_cable --ipv4 manual 30.0.0.39 255.0.0.0 30.0.0.1 --nameservers 8.8.8.8

You don't need to edit the file /etc/network/interfaces
Just run connmanctl as above.


To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard+unsubscribe@googlegroups.com.

--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/beagleboard/2a5bf207-bdd6-ac79-f1e5-3c16b02f5ebb%40gmail.com.
Reply all
Reply to author
Forward
0 new messages