How

8 views
Skip to first unread message

Quist

unread,
Oct 1, 2009, 11:06:26 AM10/1/09
to Beagle Board
I am trying to get a PM-kernel (power menagement) running with a
matching filesystem, but it is giving me some problems.

I checkout openembedded "stable/2009" branch, add MACHINE =
"beagleboard" and "PREFERRED_VERSION_linux-omap = "pm_git" to
local.conf (taken from "openembedded/contrib/angstrom/local.conf"),
and then I "bitbake console-image".
I expected this to give me the kernel described in linux-omap-
pm_git.bb-file with a matching filesystem, but instead I get a "2.6.29-
omap1" kernel with no PM support. During boot I get this "Starting
advanced power management daemon: No APM support in kernel (failed.)",
so no PM support....

What am I doing wrong?
Is this the way to specify the kernel for your "console-image"?
How do you build a PM-kernel with matching file-system?

Regards
Quist

Quist

unread,
Oct 1, 2009, 11:09:07 AM10/1/09
to Beagle Board
Changed subject to something that makes sense... :-)

Koen Kooi

unread,
Oct 1, 2009, 11:40:43 AM10/1/09
to beagl...@googlegroups.com

Op 1 okt 2009, om 17:06 heeft Quist het volgende geschreven:

>
> I am trying to get a PM-kernel (power menagement) running with a
> matching filesystem, but it is giving me some problems.
>
> I checkout openembedded "stable/2009" branch, add MACHINE =
> "beagleboard" and "PREFERRED_VERSION_linux-omap = "pm_git" to
> local.conf (taken from "openembedded/contrib/angstrom/local.conf"),

'pm_git' is not a valid version. If you want to build against a -pm
kernel you need to do:

* get the 5 top patches from http://dominion.thruhere.net/git/cgit.cgi/openembedded/log/?h=stable/2009
* change PREFERRED_PROVIDER_virtual/kernel in conf/machine/
beagleboard.conf to linux-omap-pm
* bitbake something

regards,

Koen

Karsten Quist Jensen

unread,
Oct 2, 2009, 2:32:04 AM10/2/09
to beagl...@googlegroups.com
Thanks!

I applied the patches as you describe below and then bitbake console-image, but unfortunetly it failed. This is what I got:
NOTE: generating locale yi_US (UTF-8)
NOTE: generating locale pl_PL (UTF-8)
NOTE: generating locale ar_KW (UTF-8)
NOTE: collecting binary locales from locale tree
NOTE: Multiple libraries (libnss_nisplus.so.2, libnss_nis.so.2, libnss_hesiod.so.2) found, but LEAD_SONAME 'libc.so' doesn't match any of them
NOTE: Couldn't find shared library provider for libgcc_s.so.1
NOTE: Tasks Summary: Attempted 2127 tasks of which 2098 didn't need to be rerun and 1 failed.
ERROR: '/OE/openembedded/recipes/u-boot/u-boot_git.bb' failed

I guess it has something to do with the patches you gave me, but I can't see the library names in the patch.
Any thoughts, Koen?

Regards,
Quist

2009/10/1 Koen Kooi <ko...@beagleboard.org>

Koen Kooi

unread,
Oct 2, 2009, 3:53:01 AM10/2/09
to beagl...@googlegroups.com
that seems to be  a problem with  u-boot, which builds over here. Note that those patches are applied now, so a git pull --force should get you the final version

Op 2 okt 2009 om 08:32 heeft Karsten Quist Jensen <karste...@gmail.com> het volgende geschreven:\

Karsten Quist Jensen

unread,
Oct 2, 2009, 11:39:06 AM10/2/09
to beagl...@googlegroups.com
Thanks Koen, for being so patient with me :-)

Now it builds with no errors, but I still get kernel "2.6.29-omap1":
[    0.000000] Linux version 2.6.29-omap1 (karsten@quist-engineering) (gcc version 4.3.1 (GCC) ) #1 Fri Oct 2 15:08:15 CEST 2009

And with no PM support:

Starting advanced power management daemon: No APM support in kernel (failed.)

I still use local.conf copied from "openembedded/contrib/angstrom/local.conf", with machine set to beagleboard. And I have added PREFERRED_PROVIDER_virtual/kernel = "linux-omap-pm" to beagleboard.conf, just below SERIAL_CONSOLE = "115200 ttyS2". Thereby PREFERRED_PROVIDER_virtual/kernel = "linux-omap-pm" is defined after/below omap3.inc defines PREFERRED_PROVIDER_virtual/kernel = "linux-omap".

Any thoughts? Something I might have forgotten?

regards,
Quist

2009/10/2 Koen Kooi <ko...@beagleboard.org>

Koen Kooi

unread,
Oct 2, 2009, 12:00:07 PM10/2/09
to beagl...@googlegroups.com

Op 2 okt 2009, om 17:39 heeft Karsten Quist Jensen het volgende
geschreven:

> Thanks Koen, for being so patient with me :-)
>
> Now it builds with no errors, but I still get kernel "2.6.29-omap1":
> [ 0.000000] Linux version 2.6.29-omap1 (karsten@quist-
> engineering) (gcc version 4.3.1 (GCC) ) #1 Fri Oct 2 15:08:15 CEST
> 2009

Check tmp/deploy/glibc/images/beagleboard for the full name of the
uImage, if it has 'pm' in it then it's OK

>
> And with no PM support:
> Starting advanced power management daemon: No APM support in kernel
> (failed.)

APM is for x86 :) The pm kernels have cpufreq support, check /sys/
devices/system/cpu/cpu0/cpufreq.

regards,

Koen

Karsten Quist Jensen

unread,
Oct 2, 2009, 6:32:36 PM10/2/09
to beagl...@googlegroups.com
The full name is uImage-2.6.29-r46-pm2+gitre63cf0710a4fb639d91d3e8b05aa485fbfa381b3-beagleboard.bin, so I guess it's a PM kernel. I will try to test the cpufreq tomorrow.

Thanks a lot!
Reply all
Reply to author
Forward
0 new messages