USB1 throwing VBUS_ERROR and/or error -71?

37 views
Skip to first unread message

vito.m...@gmail.com

unread,
Feb 3, 2020, 10:54:47 AM2/3/20
to BeagleBoard
Hi, I've a PocketBeagle running the Debian 9.9 2019-08-03 4GB SD IoT image, updated following the directions in https://beagleboard.org/upgrade.

I've wired up USB1 on a breadboard, and when plugging in a high-speed USB device (wifi or ethernet adapter), dmesg shows:

[  170.215041] musb-hdrc musb-hdrc.1: VBUS_ERROR in a_wait_bcon (89, <AValid), retry #1, port1 00000104

When plugging in a low-speed USB device (keyboard), dmesg shows:

[  232.250630] usb 2-1: new low-speed USB device number 6 using musb-hdrc
[  232.378692] usb 2-1: device descriptor read/64, error -71
[  232.618628] usb 2-1: device descriptor read/64, error -71

When plugging in a powered USB hub, there is no response at all.  There's also no change when using a USB power injector.

Could the breadboard be the issue?  There's maybe six inches between the PocketBeagle and the USB plug.

Also, the first time I tried it, I wired it backwards.  Is it possible I fried something on the PocketBeagle?  I only have the one to try at the moment.

Thanks,
Vitorio

vito.m...@gmail.com

unread,
Feb 6, 2020, 1:04:06 PM2/6/20
to BeagleBoard
Just to follow up for future readers, I worked this through a bit with zmatt on IRC, it was both issues.

A new PocketBeagle with USB1 on a breadboard would connect low-speed USB devices, but not high-speed USB devices.

A new PocketBeagle with USB1 wired pretty directly would connect both.

The old PB still wouldn't connect even with the direct USB1 wiring, so it's likely I fried the USB1 components on that board.

Thanks!
Reply all
Reply to author
Forward
0 new messages